Showing results for 
Search instead for 
Did you mean: 
Join Customer Connection to register!
Yadhu Tony

Error opening tftp (Timed out)


I installed a new router and trying to backup the initial configuration to our tftp server. But getting the error " %Error opening tftp:// (Timed out)"

I can ping the tftp server from router. There is no firewall in between router and tftp server. Other network devices in the same subnet can upload / download from tftp server. Only this router can't use the tftp. I tried to install a seperate tftp server and tried but no hope with the freshly installed router. Router running config is attached. Please help me.


100 REPLIES 100

I was directly connected via a cross over cable to my ISR4331 and was having the same issue.  Adding ip tftp source-interface gig0/0/0 worked for me.  Thanks!

Same for me i had time outs and time outs on a ISR3121/K9 .. I forgot about this command but thanks for your post i solved it , i can TFTP again :) 

I ran into same scenario with isr 4321 tftp is working no windows firewall on server. I can ping the router from laptop and from router . I tried following command.

Router(config)#ip tftp source-interface gig0/0/1

where the int gig0/0/1 is where my server subnet is learning in ip routing tables

This fixed my problem.

ip tftp source-interface gig0/0/0

Interface laptop was connected to.

Hi Michael,

I spent more than 4 hours. Finally, I put the source and it worked.

Thanks a lot!

That worked. Thank you so much!

>>>>Router(config)#ip tftp source-interface gig0/0/0
where the int gig0/0/0 is where my laptop is directly connected.<<<<<

From the testing I've done, the point to the command is to give the TFTP transfer a source address. I've used a loopback for the interface and it still works. It didn't have to be the interface where my TFTP server is connected.

Oh - its really grate. I have facing same problem also - right now its working properly. 


That command certainly did- Tnx

We were experiencing this issue on a new VG450 .Worked straight away! Thank you...

This command was very useful, you save me!!

That was it. thank you! 

I have same problem. When I made a capture I could see the problem, Cisco uses port 21 for connection and not 69 as the answer.When entering the configuration "ip tftp source-interface gig0/0/0",the gateway made the connection to the correct port. This looks like an ISR BUG

Does FTP not use port 21 and TFTP use port 69 ? 


For so far i have seen many Cisco routers and switches need that command to specify the port on where you want to do the TFTP download , i do not think that is caused by a bug. 


For example Nexus switches or Catalyst 4900M and ASR1001-X and some newer ISR43xx (Generation3) routers require this command.  Aliter networks tests all ports and we use this command requirement on many different types of equipment .  


For example here you will find a example config for a 4500 supervisor engine also forced to configure the management vrf in order to copy a backup startup-configuration file on the management interface fastethernet1 :

Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#interface f1
Switch(config-if)#ip vrf forwarding mgmtVrf
Switch(config-if)#ip addr
Switch(config-if)#speed auto
Switch(config-if)#duplex auto
*Aug 14 07:54:43.611: %SYS-5-CONFIG_I: Configured from console by console
Switch#ping vrf mgmtVrf

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to, timeout is 2 seconds:
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/2/4 ms
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#ip tftp source-interface FastEthernet1