02-26-2018 05:28 PM - edited 03-08-2019 02:02 PM
What is the correct way to create a port channel between an SG300 and Cisco4506 running CatOS
02-26-2018 10:29 PM
interface Port-channel2
description portchannel on sg300
switchport mode trunk
switchport trunk allowed vlan 2,4,6,8,10
!
interface gigabitethernet2
switchport mode trunk
channel-group 2 mode auto
!
interface gigabitethernet3
switchport mode trunk
channel-group 2 mode auto
------------------------
interface Port-channel1
description portchannel on 4506
switchport mode trunk
switchport trunk allowed vlan 2,4,6,8,10
!
interface gigabitethernet 2/1
switchport mode trunk
channel-group 1 mode auto
!
interface gigabitethernet 2/2
switchport mode trunk
channel-group 1 mode auto
If you want to port channel as L3 interface then both member ports are must be L3.
Regards,
Deepak Kumar
02-28-2018 07:01 AM
Hi Deepak, the 4506 switch is running CatOS (cat4000-k8.8-4-11-GLX.bin) with1000BaseX Supervisor WS-X4013
i have an active port channel between the 4500 ports and 3560 the configuration is:
CatOS 4506
#port channel set port channel 1/1-2 5 >>>>>>>>>>>>>port channel active set port channel 2/25-28 8 set port channel 3/1-4 14 set port channel 3/45-48 25 set port channel 2/13-16 29 ! #module 1 : 2-port 1000BaseX Supervisor set vlan 10 1/1-2 set port trap 1/1-2 enable set trunk 1/1 on dot1q 1-1005,1025-4094 set trunk 1/2 on dot1q 1-1005,1025-4094 set port channel 1/1-2 mode desirable non-silent ! #module 2 : 48-port 10/100/1000 Ethernet set vlan 30 2/25,2/28,2/41 set vlan 94 2/37,2/48 set vlan 400 2/1-24,2/26-27,2/29-36,2/38-40,2/42,2/46-47 set vlan 962 2/43-45 set trunk 2/28 off dot1q 1-1005,1025-4094 set trunk 2/40 off dot1q 1-1005,1025-4094 set trunk 2/48 on dot1q 1-1005,1025-4094 set spantree portfast 2/28 enable set port channel 2/28 mode off ! #module 3 : 48-port 10/100BaseTx Ethernet set vlan 10 3/1-2 set vlan 30 3/3-4 set vlan 400 3/5,3/7-48 set vlan 900 3/6 set port membership 3/48 dynamic set trunk 3/1 on dot1q 1-1005,1025-4094 set trunk 3/2 on dot1q 1-1005,1025-4094 set trunk 3/48 off dot1q 1-1005,1025-4094 set spantree portfast 3/48 enable set port channel 3/1-2 mode on set port channel 3/48 mode off
3560
interface Port-channel40 switchport trunk encapsulation dot1q switchport trunk native vlan 10 switchport mode trunk ! interface GigabitEthernet0/1 switchport trunk encapsulation dot1q switchport trunk native vlan 10 switchport mode trunk channel-group 40 mode desirable non-silent ! interface GigabitEthernet0/2 switchport trunk encapsulation dot1q switchport trunk native vlan 10 switchport mode trunk channel-group 40 mode desirable non-silent
Now when i try the configure a port channel between 4506 and SG300 failed, i've used on the ports 3/1-2 on the CatOS and this for SG300 but doesn't work.
SG300
interface gigabitethernet27 channel-group 1 mode on ! interface gigabitethernet28 channel-group 1 mode on ! interface Port-channel1 description portchannel-sg300 switchport trunk native vlan 10
02-28-2018 09:48 AM
As I am getting your point there is some configuration issue.
Please check below link and read about silent or non-silent mode.
https://supportforums.cisco.com/t5/lan-switching-and-routing/pagp-silent-and-non-silent/td-p/1495264
Regards,
Deepak Kumar
02-28-2018 02:11 PM - edited 02-28-2018 02:12 PM
Hi,
Contrary to Cat3560 with SG300 you should specify Vlans permitted within a trunk. Will you please add these via the "switchport trunk allowed vlan add" command under the "Interface Port-Channel1". Required Vlans also need to be configured first under the "vlan database".
Best regards,
Antonin
Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: