11-15-2013 02:03 AM - edited 03-07-2019 04:37 PM
Hello,
I have some problems with portchannel. On one site i have 6506-E switch, on the other site 2960s series switch. Im using media converters between them. The configuration is like this:
#################
ON 6506-E
#################
interface Port-channel13
switchport
switchport trunk allowed vlan 15-18,20,97-99,102,104,106,108,110,200
switchport mode trunk
logging event link-status
logging event trunk-status
logging event bundle-status
logging event spanning-tree status
load-interval 30
spanning-tree portfast edge trunk
hold-queue 2000 out
interface GigabitEthernet1/3/43
switchport
switchport trunk allowed vlan 15-18,20,97-99,102,104,106,108,110,200
switchport mode trunk
logging event link-status
logging event trunk-status
logging event bundle-status
logging event spanning-tree status
load-interval 30
udld port
channel-protocol lacp
channel-group 13 mode active
hold-queue 2000 out
interface GigabitEthernet2/3/43
switchport
switchport trunk allowed vlan 15-18,20,97-99,102,104,106,108,110,200
switchport mode trunk
logging event link-status
logging event trunk-status
logging event bundle-status
logging event spanning-tree status
load-interval 30
udld port
channel-protocol lacp
channel-group 13 mode active
hold-queue 2000 out
#################
ON 2960S
#################
interface Port-channel1
switchport trunk allowed vlan 15-18,20,97-99,102,104,106,110,200
switchport mode trunk
load-interval 30
hold-queue 2000 in
hold-queue 2000 out
interface GigabitEthernet1/0/23
switchport trunk allowed vlan 15-18,20,97-99,102,104,106,110,200
switchport mode trunk
logging event trunk-status
logging event bundle-status
logging event spanning-tree
load-interval 30
udld port
mls qos trust dscp
channel-protocol lacp
channel-group 1 mode active
interface GigabitEthernet1/0/24
switchport trunk allowed vlan 15-18,20,97-99,102,104,106,110,200
switchport mode trunk
logging event trunk-status
logging event bundle-status
logging event spanning-tree
load-interval 30
udld port
mls qos trust dscp
channel-protocol lacp
channel-group 1 mode active
The interfaces are staying in the "stand alone" state in the etherchannel bundle. But they are working, the links are fine just the portchannel doesn't build. So one of the interfaces is blocked by the spanning-tree, which is fine. On the other 2960s switch the same configuration is working. But there are SFP+ modules, not media converters.
Can you see some configuration mistakes? Or could be the only problem in the media converters? The manufacturer ensures that LACP is supported but i'm not sure about that...
Does anyone have a similar experience regarding portchannel over media converters?
11-15-2013 02:16 AM
Hi,
Media convertors typically work on the physical layer providing a conversion between optical and electrical signalling so they shouldnt be blocking specific layer 2 protocols. It sounds like they are working correctly if the interfaces are up and spanning-tree BDPUs are being sent/received to determine the blocking port.
Have you checked that all of the interfaces are operating at the same speed of 1Gbps as member ports with different speeds will not bundle?
Can you post the output of 'show etherchannel summary' and 'show etherchannel port'?
11-15-2013 02:37 AM
Hi,
I know, this should work.
Yes i checked this already. The speeds and duplex are the same on all interfaces (1Gbps/Full-diplex).
We also have one 2960s switch connected to the 6506-E VSS like so... one interface is connected to the 6506-E with the UTP cable directly, the other link is connected to the 6506-E via media converter. And the portchannel also doesn't build.
11-15-2013 03:05 AM
Hi,
I know that you can mix media types in an etherchannel, so one link could be copper and one link could be fibre.
In your configuration, is one of the member links copper on one end and fibre on the other? If so then I'm not sure if this will work as the member interface capabilities have to be the same and in this instance once interface will be type 10/100/1000BaseTX and the other interface will be type 1000BaseSX SFP. I have not attempted to do this before.
11-15-2013 03:25 AM
No i have copper on both ends. Fiber is just in between.
So like this:
6506-E -> copper -> media converter -> optic -> media converter -> cooper -> 2960s
I noticed that on 6506-E the media tipe on the interface is 10/100/1000BaseT. On 2960s is 10/100/1000BaseTX. Could this be the problem? The cables are new and the same on each site (Cat 6). So i don't think so.
11-15-2013 05:29 AM
hmmm no, thinking about it I dont think that will be the problem.
Have you verified that you have full bi-directional communication between the 2960S and 6506 when they are connected togther. I noticed that you have UDLD configured. Can you provide the output of show udld for these ports?
11-21-2013 05:06 AM
Yes, the communication is full bi-directional. Both uplinks are active, the etherchannel just dont build.
SW-2960S#sh udld gigabitEthernet 1/0/24
Interface Gi1/0/24
---
Port enable administrative configuration setting: Enabled
Port enable operational state: Enabled
Current bidirectional state: Bidirectional
Current operational state: Advertisement - Single neighbor detected
Message interval: 15
Time out interval: 5
Entry 1
---
Expiration time: 44
Device ID: 1
Current neighbor state: Bidirectional
Device name: xxxxx
Port ID: Gi2/3/43
Neighbor echo 1 device: xxxxx
Neighbor echo 1 port: Gi1/0/24
Message interval: 15
Time out interval: 5
CDP Device name: LAN-VSS.xxx
SW-2960S#sh udld gigabitEthernet 1/0/23
Interface Gi1/0/23
---
Port enable administrative configuration setting: Enabled
Port enable operational state: Enabled
Current bidirectional state: Bidirectional
Current operational state: Advertisement - Single neighbor detected
Message interval: 15
Time out interval: 5
Entry 1
---
Expiration time: 43
Device ID: 1
Current neighbor state: Bidirectional
Device name: xxxxx
Port ID: Gi1/3/43
Neighbor echo 1 device: xxxxx
Neighbor echo 1 port: Gi1/0/23
Message interval: 15
Time out interval: 5
CDP Device name: LAN-VSS.xxx
11-21-2013 08:33 AM
All parameters must be ths same , I would go thru each side and see what doesn't match up. Does the 2960 have this in it's config , spanning-tree portfast edge trunk ? Between devices I would not think you would want this on the interfaces . I would remove it and see what happens . Bounce the port- channel and let it renegotiate after the change. check the logs also it will usually tell you why it didn't build the lacp channel.
11-24-2013 10:31 AM
No effect if i discard this command. It still doesn't work.
On the other Switch i use SFP's and it's woking - same config (10G LRM on the 6506-E side; 10G SFP+ on the 2960S side). Could it be that the media converter's don't support LACP?
11-24-2013 01:53 PM
No I don't think it would be the convertors not supporting lacp. The only other thing to try would be try and remove all those hold queue's on both sides and see what happens. Unless you have some specific issue usually most people will leave them at there default settings. Also you have mls qos on one side and not the other, try removing that also .
11-24-2013 02:00 PM
You are not allowing vlan 108 on the trunk link at the 2960 end but you are on the 6500 end. There are some posts on CSC suggesting these do not need to match in certain circumstances but i would still match them and see if that solves the issue.
Jon
11-25-2013 10:31 AM
How could i overlooked that. However, i fixed this, bounce the portchannel and still no effect.
#########
On 2960S
#########
interface Port-channel1
description *** PC TO VSS-LAN-6506-E ***
switchport trunk allowed vlan 15-18,20,97-99,102,104,106,108,110,200
switchport mode trunk
load-interval 30
hold-queue 2000 in
hold-queue 2000 out
end
interface GigabitEthernet1/0/23
description *** TRUNK TO VSS-LAN-6506-E ***
switchport trunk allowed vlan 15-18,20,97-99,102,104,106,108,110,200
switchport mode trunk
logging event trunk-status
logging event bundle-status
logging event spanning-tree
load-interval 30
udld port
mls qos trust dscp
channel-protocol lacp
channel-group 1 mode active
end
interface GigabitEthernet1/0/24
description *** TRUNK TO VSS-LAN-6506-E ***
switchport trunk allowed vlan 15-18,20,97-99,102,104,106,108,110,200
switchport mode trunk
logging event trunk-status
logging event bundle-status
logging event spanning-tree
load-interval 30
udld port
mls qos trust dscp
channel-protocol lacp
channel-group 1 mode active
end
################
Etherchannel stats
################
LAN1-VSS#sh etherchannel 13 summ
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use N - not in use, no aggregation
f - failed to allocate aggregator
M - not in use, no aggregation due to minimum links not met
m - not in use, port not aggregated due to minimum links not met
u - unsuitable for bundling
d - default port
w - waiting to be aggregated
Number of channel-groups in use: 6
Number of aggregators: 6
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
13 Po13(SD) LACP Gi1/3/43(I) Gi2/3/43(I)
Last applied Hash Distribution Algorithm: Adaptive
SW-2960S#sh etherchann 1 summ
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SD) LACP Gi1/0/23(I) Gi1/0/24(I)
12-22-2013 11:34 AM
Just so you know... It was the problem with media converters. They didn't support control protocols.
With "mode on" the etherchannel was working, but this is not recommended.
If anyone come across similar problems - check the media converters.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide