cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2136
Views
0
Helpful
4
Replies

Extending VLAN to remote switch that already has VLAN ID in use

I have two networks at two sites with a dot1q trunk between the two L3 switches at both sites (no routers involved)

SITE A - Cisco 3750 L3 - VLAN ID 50

10.10.50.0/24

SITE B - Cisco 3750 L3 - VLAN ID 50

10.20.50.0/24

I would like to extend the SITE A VLAN to SITE B so that I can move hosts from SITE A to SITE B without needing to change their IP address but the vlan ID is already in use. Obviously the easy solution is to change the VLAN ID for one or other of the sites but both sites contain hosts that run 24/7. Is there a way to join two VLANs with different IDs together.

So for example I create a new VLAN 60 at SITE B and associate it with VLAN 50 at SITE A.

Hope this makes sense. Thanks in advance.        

1 ACCEPTED SOLUTION

Accepted Solutions

Kyle McKay
Beginner
Beginner

I think the feature you are looking for is called VLAN Mapping.

VLAN Mapping allows you to perform a translation on a VLAN from one to another - just as we could translate IP addresses with NAT.

Take a look at the following Cisco Document for some additional details:

Below I have pasted an excerpt from the following URL: http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SX/configuration/guide/vlans.html#wp1044990

Command

Purpose

Step 1 

Router(config)# interface type1 slot/port

Selects the Layer 2 trunk port to configure.

Step 2 

Router(config-if)# switchport vlan mapping enable

Enables VLAN translation.

Step 3 

Router(config-if)# switchport vlan mapping original_vlan_ID translated_vlan_ID

Translates a VLAN to another VLAN. The valid range is 1 to 4094.

When you configure a VLAN mapping from the original VLAN to the translated VLAN on a port, traffic arriving on the original VLAN gets mapped or translated to the translated VLAN at the ingress of the switch port, and the traffic internally tagged with the translated VLAN gets mapped to the original VLAN before leaving the switch port. This method of VLAN mapping is a two-way mapping.

Step 4 

Router(config-if)# end

Exits configuration mode.

Step 5 

Router# show interface type1 slot/port vlan mapping

Verifies the VLAN mapping.

1 type = fastethernet, gigabitethernet, or tengigabitethernet

Hope this helps !

View solution in original post

4 REPLIES 4

shillings
Enthusiast
Enthusiast

If there isn't a Cisco feature that can do this, then you could look at a third party appliance to manipulate the tags. I know ADVA make 1RU devices for the carrier market that can do this. You'd need to check with an ADVA partner, but something like this might be suitable: -

http://www.advaoptical.com/~/media/Resources/Data%20Sheets/FSP_150CC.ashx

Kyle McKay
Beginner
Beginner

I think the feature you are looking for is called VLAN Mapping.

VLAN Mapping allows you to perform a translation on a VLAN from one to another - just as we could translate IP addresses with NAT.

Take a look at the following Cisco Document for some additional details:

Below I have pasted an excerpt from the following URL: http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SX/configuration/guide/vlans.html#wp1044990

Command

Purpose

Step 1 

Router(config)# interface type1 slot/port

Selects the Layer 2 trunk port to configure.

Step 2 

Router(config-if)# switchport vlan mapping enable

Enables VLAN translation.

Step 3 

Router(config-if)# switchport vlan mapping original_vlan_ID translated_vlan_ID

Translates a VLAN to another VLAN. The valid range is 1 to 4094.

When you configure a VLAN mapping from the original VLAN to the translated VLAN on a port, traffic arriving on the original VLAN gets mapped or translated to the translated VLAN at the ingress of the switch port, and the traffic internally tagged with the translated VLAN gets mapped to the original VLAN before leaving the switch port. This method of VLAN mapping is a two-way mapping.

Step 4 

Router(config-if)# end

Exits configuration mode.

Step 5 

Router# show interface type1 slot/port vlan mapping

Verifies the VLAN mapping.

1 type = fastethernet, gigabitethernet, or tengigabitethernet

Hope this helps !

Reza Sharifi
Hall of Fame Expert Hall of Fame Expert
Hall of Fame Expert

Hi,

If you only have one vlan on each site, you can change the trunk port between the 2 switch to access port and then you have vlan 50 on one site and 60 on the other site in the same subnet.

Something like this:

site A

interface GigabitEthernet1/0/12

switchport access vlan 50

switchport mode access

channel-group 10 mode passive

end

Sw1#sh run int vlan 50

Building configuration...

Current configuration : 62 bytes

!

interface Vlan50

ip address 10.10.50.1 255.255.255.0

end

site B

interface GigabitEthernet1/0/12

switchport access vlan 60

switchport mode access

channel-group 10 mode active

end

Switch#sh run int vlan 60

Building configuration...

Current configuration : 62 bytes

!

interface Vlan60

ip address 10.10.50.2 255.255.255.0

end

HTH

Kyle McKay - Thanks very much. This looks like exactly what I want to do. Really annoyed I couldn't find it myself. I'll give it a go and let you know how I get on.

shillings - Thanks for taking the time to post. I'll take a look at this if the VLAN mapping doesn't work

Reza Sharifi - Thanks for the info. Unfortunately I did simplify my example and we do have lots of other VLANs at both sites.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: