cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
1824
Views
0
Helpful
5
Replies
vladakoci
Beginner

GLC-T in C3KX-NM-10G, full duplex does not work

I have C3750X with C3KX-NM-10G, and have-T SFP in slot 3 ( means it is not in SFP+ slot ).

I need to set speed&duplex hard to 100/Full, but if I do the link goes down. I have the same settings on the other side, only IOS version is different.

I tried other speeds - 10 and 1000, but no one works with Full. When I change duplex to Auto it works fine.

The reason why I am doing this on C3KX-NM-10G is because I need to use NetFlow and cannot use the chassis' copper port. At the moment the ports are connected through a copper patch cord, but in full production there will be a radio link in between that requires 100M/Full to be set hard.

I am trying to search for any document that would describe this limitation, but cannot find any. Also port capabilities do not indicate duplex could not be set to full:

show interfaces g1/1/3 capabilities

GigabitEthernet1/1/3

  Model:                 WS-C3750X-48P

  Type:                  10/100/1000BaseTX SFP

  Speed:                 10,100,1000,10000,auto

  Duplex:                half,full,auto

  Trunk encap. type:     802.1Q,ISL

  Trunk mode:            on,off,desirable,nonegotiate

  Channel:               yes

  Broadcast suppression: percentage(0-100)

  Flowcontrol:           rx-(off,on,desired),tx-(none)

  Fast Start:            yes

  QoS scheduling:        rx-(not configurable on per port basis),

                         tx-(4q3t) (3t: Two configurable values and one fixed.)

  CoS rewrite:           yes

  ToS rewrite:           yes

  UDLD:                  yes

  Inline power:          no

  SPAN:                  source/destination

  PortSecure:            yes

  Dot1x:                 yes

Any help is appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions
glen.grant
Advisor

  Sounds to me like you don't have the correct cable and auto mdix is correcting for it  .  Auto mdix "only" works as auto/auto  and it will take the ports down if not auto .  You would need a crossover cable if you want to hardcode the ports.

View solution in original post

5 REPLIES 5
Leo Laohoo
VIP Community Legend

I am very sure GLC-T is set to 1 Gbps, full duplex and no less.

Can you post the output to the command "sh interface Gig 1/1/3 status"?

If the port settings are

speed auto 10 100

on both sides ( duplex is auto by default )

I get the link up

sh int g1/1/3

GigabitEthernet1/1/3 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet, address is 4403.a7c7.6d33 (bia 4403.a7c7.6d33)

  Description:

  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive not set

  Full-duplex, 100Mb/s, link type is auto, media type is 10/100/1000BaseTX SFP

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:00, output 00:00:02, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 58000 bits/sec, 63 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     187640 packets input, 21534917 bytes, 0 no buffer

     Received 156115 broadcasts (135450 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 135450 multicast, 0 pause input

     0 input packets with dribble condition detected

     10717 packets output, 1576239 bytes, 0 underruns

     0 output errors, 0 collisions, 3 interface resets

     120 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 pause output

     0 output buffer failures, 0 output buffers swapped out

If the port settings are

speed 100

duplex full

on both sides

I get the link down. The same applies if I change the speed to any speed 10, 100 or 1000.

sh int g1/1/3

GigabitEthernet1/1/3 is down, line protocol is down (notconnect)

  Hardware is Gigabit Ethernet, address is 4403.a7c7.6d33 (bia 4403.a7c7.6d33)

  Description:

  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive not set

  Full-duplex, 100Mb/s, link type is auto, media type is 10/100/1000BaseTX SFP

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:27, output 00:00:23, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 51000 bits/sec, 56 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     198105 packets input, 22717767 bytes, 0 no buffer

     Received 164553 broadcasts (142758 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 142758 multicast, 0 pause input

     0 input packets with dribble condition detected

     11417 packets output, 1641822 bytes, 0 underruns

     0 output errors, 0 collisions, 3 interface resets

     127 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 pause output

     0 output buffer failures, 0 output buffers swapped out

Just adding sh int status for the two cases

#sh int g1/1/3 status

Port      Name               Status       Vlan       Duplex  Speed Type
Gi1/1/3                              connected    trunk      a-full  a-100 10/100/1000BaseTX SFP

l

#sh int g1/1/3 status

Port      Name               Status       Vlan       Duplex  Speed Type
Gi1/1/3                            notconnect   trunk        full    100 10/100/1000BaseTX SFP

Wilson Bonilla
Participant

Good morning Vladimir.

I see a lot of duplex mismatch in the logs:

Jun  5 08:02:04.355: %CDP-4-DUPLEX_MISMATCH: duplex mismatch discovered on GigabitEthernet3/1/3 (not full duplex), with lonn2025 GigabitEthernet1/1/3 (full duplex). (lonn2001-3)

Upon initialization, each device transmits a 16 bit message called a fast link pulse burst, because of fastethernet to its link partner, which is used to negotiate, if you hardcode the interface in one end, the fast link pulse burst will sent 16 bit message with all its bits turned off, and the neighbor won't be able to understand that message.

Action plan:

Hard code both interfaces.

Loop the wire between the two copper interfaces in the C3KX module, interface 2 and 4 if I'm not mistaken. ( is it coming up?)

What is it connected in the other side?

Regards

Wilson B

glen.grant
Advisor

  Sounds to me like you don't have the correct cable and auto mdix is correcting for it  .  Auto mdix "only" works as auto/auto  and it will take the ports down if not auto .  You would need a crossover cable if you want to hardcode the ports.

View solution in original post