cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5996
Views
13
Helpful
12
Replies

How setup basic IP routing on 3725 router.

NB243_243
Level 1
Level 1

Below is the router and interface configuration of two 3725 routers. The problem is, I'm not able to ping PC connected to each router (PC1 connected to Router_01 and PC2 connected to Router_02, (Router_01 directly connected to Router_02). I'm able to ping each router's port but not the PC beyond each of the routers. As an added note each PC is connected to its respective router through a 2950 switch. I can ping from PC to PC when I remove the routers and just use the switch so I know the swithes are pass the packets.

What am I missing?...

Thanks in advance,

NB243

===========================================

Router #1:

===========================================

no aaa new-model

ip subnet-zero

ip cef

!

ip multicast-routing

no ftp-server write-enable

!

interface FastEthernet0/0

ip address 148.x.0.x.255.0.0

ip information-reply

ip directed-broadcast

ip rip advertise 59

ip rip send version 1

ip rip receive version 1

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 148.x.0.x.255.0.0

ip information-reply

ip directed-broadcast

ip rip advertise 59

ip rip send version 1

ip rip receive version 1

duplex auto

speed auto

!

router rip

network 148.33.0.0

network 148.34.0.0

network 148.35.0.0

network 148.36.0.0

neighbor 148.x.0.2

!

ip classless

ip http server

!

!

line con 0

line aux 0

line vty 0 4

!

end

===========================================

Router #2:

===========================================

no aaa new-model

ip subnet-zero

ip cef

!

ip multicast-routing

no ftp-server write-enable

!

interface FastEthernet0/0

ip address 148.x.0.x.255.0.0

ip information-reply

ip directed-broadcast

ip rip advertise 59

ip rip send version 1

ip rip receive version 1

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 148.x.0.x.255.0.0

ip information-reply

ip directed-broadcast

ip rip advertise 59

ip rip send version 1

ip rip receive version 1

duplex auto

speed auto

!

interface FastEthernet2/0

ip address 148.x.0.x.255.0.0

ip information-reply

ip directed-broadcast

ip rip advertise 59

ip rip send version 1

ip rip receive version 1

duplex auto

speed auto

!

router rip

version 1

network 148.33.0.0

network 148.34.0.0

network 148.35.0.0

network 148.36.0.0

neighbor 148.x.0.1

!

ip classless

no ip http server

!

!

line con 0

line aux 0

line vty 0 4

!

end

===========================================

Typical interface configuration:

===========================================

Router_02#show ip interface fast 0/0

FastEthernet0/0 is up, line protocol is up

Internet address is 148.x.0.1/16

Broadcast address is 255.255.255.255

Address determined by setup command

MTU is 1500 bytes

Helper address is not set

Directed broadcast forwarding is enabled

Multicast reserved groups joined: 224.0.0.9

Outgoing access list is not set

Inbound access list is not set

Proxy ARP is enabled

Local Proxy ARP is disabled

Security level is default

Split horizon is enabled

ICMP redirects are always sent

ICMP unreachables are always sent

ICMP mask replies are never sent

IP fast switching is enabled

IP fast switching on the same interface is disabled

IP Flow switching is disabled

IP CEF switching is enabled

IP CEF Fast switching turbo vector

IP multicast fast switching is enabled

IP multicast distributed fast switching is disabled

IP route-cache flags are Fast, CEF

Router Discovery is disabled

IP output packet accounting is disabled

IP access violation accounting is disabled

TCP/IP header compression is disabled

RTP/IP header compression is disabled

Policy routing is disabled

Network address translation is disabled

WCCP Redirect outbound is disabled

WCCP Redirect inbound is disabled

WCCP Redirect exclude is disabled

BGP Policy Mapping is disabled

===========================================

12 Replies 12

Hello,

make sure you router 1 is running RIP version 1 as well (as is your router 2). Also, what cable are you using between your 2950(s) and your router(s) ? Make sure you are using straight cables, not cross cables. And lst but not least, check the default gateways on your client computers, and make sure they match the IP addresses of your respective router interfaces...

Regards,

GP

Hello GP.

I have done all that... As I have indicated in my post, I can ping the router ports from each PC and I have the gateway configured on each PC to match the respective connected router interfaces. Also The cables are correct. I can also ping the neighboring router (using the console connection and submiting commands directly from each router, but again, I'm not able to ping the PC connected to the other interface through that respective router). Also note the configuration info I supplied... It indicates that I have configured RIP version 1 on each router...

So what am I missing?...

NB243

From routerA:

Do an extended ping (ping ip )

make sure that the target ip is interface or gateway of PC in router B and source is the interface of the gateway from PC in router A. are the pings going through? If not, there the issue is routing. On both router inverstigate the result of show ip route:

from Router A:

show ip route

From router B:

show ip route

From both of this show ip route I am sure you will find which router is pointing to the wrong interface. If all is working per output, post all the output requested here. Let us take a look at it.

Please rate this post if it helps.

From the description of the synptoms in the original post I thought that the most likely problem was that the default gateway in one or both PCs was not set correctly. But the original poster states that they are set correctly.

From the configs it looks like the routers should talk and should share routes. But I agree with Roberto that it sounds like the routers may not have correct routing information about the remote destinations. It would be very helpful to see the output of show ip route from both routers. I think it would also be helpful to see the output of show cdp neighbor detail from both routers.

HTH

Rick

HTH

Rick

Hello Rick, and others.

I've made some changes.

(Focusing on Router_02, if resolved then I can fix Router_01 too).

Here is current configuration and output:

FastEthernet0/0=148.33.0.1

FastEthernet0/1=148.35.0.2

FastEthernet2/0=148.36.0.1

PC#1=148.35.254.1 connected via switch into interface 0/1.

PC#2=148.36.200.200 connected directly into interface 2/0.

I can ping all interfaces on router from the router's CLI.

I can ping interface 0/1 from PC#1.

Cannot ping interfaces 0/0 & 2/0 from PC#1.

I can ping PC#2 directly from the router's CLI.

I cannot ping from PC#1 -> PC#2 or PC#2 -> PC#1.

Also I cannot ping interfaces 0/0 & 0/1 from PC#2.

==========================

PC#1 Command Prompt Output

==========================

> ping 148.35.0.2

Pinging 148.35.0.2 with 32 bytes of data:

Reply from 148.35.0.2: bytes=32 time<1ms TTL=255

> ping 148.33.0.1

Pinging 148.33.0.1 with 32 bytes of data:

Request timed out.

> ping 148.36.0.1

Pinging 148.36.0.1 with 32 bytes of data:

Request timed out.

>

==========================

Router_02 CLI Output

==========================

Router_02#show ip interface brief

Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 148.33.0.1 YES manual up up

FastEthernet0/1 148.35.0.2 YES manual up up

FastEthernet2/0 148.36.0.1 YES manual up up

Router_02#show ip route

Gateway of last resort is not set

S 148.34.0.0/16 [1/0] via 148.35.0.1

C 148.35.0.0/16 is directly connected, FastEthernet0/1

C 148.33.0.0/16 is directly connected, FastEthernet0/0

C 148.36.0.0/16 is directly connected, FastEthernet2/0

Router_02#ping 148.36.200.200

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 148.36.200.200, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Router_02#ping 148.35.254.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 148.35.254.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Router_02#show arp

Protocol Address Age (min) Hardware Addr Type Interface

Internet 148.35.254.1 18 0011.433b.c752 ARPA FastEthernet0/1

Internet 148.36.200.200 7 0010.a47a.021d ARPA FastEthernet2/0

Internet 148.36.0.1 - 0012.013d.60a1 ARPA FastEthernet2/0

Internet 148.33.0.1 - 0012.013d.6080 ARPA FastEthernet0/0

Internet 148.35.0.2 - 0012.013d.6081 ARPA FastEthernet0/1

Internet 148.35.0.1 0 Incomplete ARPA

Router_02#

=================================

no aaa new-model

ip subnet-zero

ip cef

!

ip multicast-routing

ip multicast multipath

no ftp-server write-enable

!

interface FastEthernet0/0

ip address 148.x.0.x.255.0.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 148.x.0.x.255.0.0

duplex auto

speed auto

!

interface FastEthernet2/0

ip address 148.x.0.x.255.0.0

duplex auto

speed auto

!

router rip

network 148.33.0.0

network 148.34.0.0

network 148.35.0.0

network 148.36.0.0

neighbor 148.35.0.1

!

ip classless

ip route 148.33.0.0 255.255.0.0 148.35.0.1 permanent

ip route 148.34.0.0 255.255.0.0 148.35.0.1 permanent

ip route 148.35.0.0 255.255.0.0 148.35.0.1 permanent

ip route 148.36.0.0 255.255.0.0 148.35.0.1 permanent

no ip http server

!

line con 0

line aux 0

line vty 0 4

!

end

I think your strategy of troubleshooting by simplifying the environment is good. The information that you have proveded in this post is helpful.

I think that it is especially helpful to see the output from ping that demonstrates that the router can communicate directly with both PCs. And I think the output from the ARP table showing successful layer 2 connectivity to both PCs is successful is also helpful.

I would suggest a follow up test to your ping test. When you ping to PC#1 at 148.35.254.1 it uses as source address the interface address of interface 0/1 and it is successful. Now I suggest that you do an extended ping. In the extended ping specify the destination as PC address 148.35.254.1 and specify the source address (using the extended commands in extended ping) as interface 2/0.

I suspect that the extended ping will probably fail. If the standard ping succeeds then it demonstrates that the router has a route to the PC. If the extended ping fails, and we know that the router has a route to the PC, then the failed extended ping probably means that the PC does not have a route to the address of interface 2/0. And that probably indicates a problem with the configuration of default gateway in the PC. Perhaps you could do an ipconfig on the PC and post the output.

HTH

Rick

HTH

Rick

Hello,

can you also post the output of 'route print' from your PC2 ?

Regards,

GNT

Looking at the original config's

On router 1 there are only two interfaces but four networks configured under RIP.

On router 2 there are only three interfaces but four networks configured under RIP.

Also, the networks are the same on each router RIP process. I would think that the only overlap would be the network connecting the two routers, 148.35.0.0

I would clean up the RIP config then see how things work.

router 1

router rip

network 148.34.0.0

network 148.35.0.0

neighbor 148.35.0.2

router 2

router rip

network 148.33.0.0

network 148.35.0.0

network 148.36.0.0

neighbor 148.35.0.1

Hello Sean Conway and others that have sounded in on this problem...

I have been digging into this problem all along then I was out of town for a while. I never got the original computers to talk properly across the routers and I gave up on them due to time constraints... BUT! When I connected the computers that would ultimately be doing the work 'so-to-speak' they presented almost the same symptoms. I found out that they were cloned disk images and there are applications that run on these computers that have IP address embedded in them. Anyway what tipped me off was one-way intermittent ping success. I change the embedded IP address to match the Windows NIC address configuration and gateway and now they talk...

Also Sean the 3rd address in RIP on router #1 is the neighboring router's port address and the 4th address in RIP on router #2 is the neighboring router's port address. Notice they are preceded with the word 'neighbor' and not 'network'.

Thank you all for helping me solve this problem... Maybe, if I have the time I'll hook up the original two computers back up to the routers and figure out why they would not ping each other properly and give feedback on what I found...

Later,

NB_243

Hello Sean.

OOPS! I didn't look at my last post, I just looked at yours and I didn't realize that you had posted a correction to what I had posted.

I had the network address for all routes on each router's RIP configuration. You're right I did have more network addresses than the number of interfaces on each router... Excuse my ignorance... How do the extra network addresses affect the router's performance in forwarding/passing routes for the way I have things setup?

Thank you,

NB_243

Sorry for the double posting of this message... When I did a reload/hard refresh of the page it posted again.

Hello Sean.

OOPS! I didn't look at my last post, I just looked at yours and I didn't realize that you had posted a correction to what I had posted.

I had the network address for all routes on each router's RIP configuration. You're right I did have more network addresses than the number of interfaces on each router... Excuse my ignorance... How do the extra network addresses affect the router's performance in forwarding/passing routes for the way I have things setup?

Thank you,

NB_243

Having extra network statements is ineffecient. They do no good. But they also do no harm. There is no impact from having extra network statements beyond the impact of making the configuration file slightly larger.

The basic principle of network statements for Interior Routing Protocols (RIP, OSPF, EIGRP) is that you should have network statements for the locally connected interface/network that you want to participate in the routing protocol. There is no benefit in having network statements for networks that are remote to the router.

HTH

Rick

HTH

Rick
Review Cisco Networking products for a $25 gift card