cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
283
Views
20
Helpful
4
Replies

How to remove trunk config on SX350X

StefanoFereri
Beginner
Beginner

Hi,

up to now I'm used to configure interfaces on 2960 or 3850 switches. Now we've got two SX350X devices, and I tried to setup interfaces as trunk or access (CLI only!). I'm unable to find a way to get rid of any trunk config, once it is been there. After dozens of trials and errors interface shows a real mess:

 

sh run int te1/0/1

interface TenGigabitEthernet1/0/1
no switchport
switchport mode general
switchport access vlan 180
switchport trunk allowed vlan 1

 

"default int te1/0/1" does not work on this model (btw backspace key does not work either). May be this thing is broken, or maybe it isn't a switch?

 

Any idea how to clean up this mess, how to remove any config from interface, reset it to default, or simply make it an access port?

 

Thanks and regards,

Stefano 

1 Accepted Solution

Accepted Solutions

Flavio Miranda
VIP Advisor VIP Advisor
VIP Advisor

Hi

 I also prefer CLI but when it comes to this switch model and any other Small Business swittch, web interface is the best and easier way to handle config.

 Actually, cisco is moving to web interface, dont matter which device model

 

trunk.JPG

 

View solution in original post

4 Replies 4

Flavio Miranda
VIP Advisor VIP Advisor
VIP Advisor

Hi

 I also prefer CLI but when it comes to this switch model and any other Small Business swittch, web interface is the best and easier way to handle config.

 Actually, cisco is moving to web interface, dont matter which device model

 

trunk.JPG

 

Hi Flavio,

 

bad news, only via GUI. But yes, it works.

 

Thanks and regards

Stefano 

Hi Flavio,

 

sorry, I was to fast. It still does not work. I still see multiple conflicting settings on the interfaces. I cannot find a way to make an interface EITHER access OR trunk. A show interface TE1/0/1 does allways show me a mix of these configurations.

I can select trunk and tagging, which is ok so far:

 

2022-07-01 15_44_53-Edit Interface Settings.png

But when I switch to VLAN Mode Access, I would expect the tagging options to grey out, but they don't:

2022-07-01 15_44_36-Edit Interface Settings.png

And finally the interface looks like this on CLI:

 

interface TenGigabitEthernet1/0/1
switchport mode trunk
switchport access vlan 4
switchport trunk native vlan none
switchport trunk allowed vlan 2-4094

 

I've been fumbling around with it for days now. Any other idea?

 

My firmware is:

Active-image: flash://system/images/image_tesla_hybrid_2.5.8.15_release_cisco_signed.bin

Thanks again,

Stefano

Hi,

 

just to doument this, I finally was able to get an interface back to "normal" with

 

 no switchport access vlan
 no switchport trunk allowed vlan

 

Regards,

Stefano

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers