cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2938
Views
5
Helpful
15
Replies
Highlighted

%HSRP-4-DIFFVIP1

Hi All,

I am getting this error message continuously in our dist, however the configurations are fine.

%HSRP-4-DIFFVIP1: Vlan12 Grp 1 active routers virtual IP address 10.230.148.193 is different to the locally configured address 10.230.134.129

1 ACCEPTED SOLUTION

Accepted Solutions
Advocate

%HSRP-4-DIFFVIP1

Hi,

when you interconnect your two VLANs, HSRP multicast  frames originated within one VLAN can reach the HSRP device in the other VLAN.

As you are using the same HSRP group number, the device will accept the HSRP frame and realize there was an incorrect virtual IP address configured within that frame (originated from the other VLAN/subnet).

Here you can read more details about HSRP:

http://www.cisco.com/en/US/customer/tech/tk648/tk362/technologies_q_and_a_item09186a00800a9679.shtml

http://www.cisco.com/en/US/customer/tech/tk648/tk362/technologies_tech_note09186a0080094afd.shtml

http://www.cisco.com/en/US/customer/docs/ios/12_3t/12_3t4/feature/guide/gthsrpv2.html

HTH,

Milan

View solution in original post

15 REPLIES 15
Rising star

%HSRP-4-DIFFVIP1

Hi

The IP's are in different subnet,they need to be in same subnet.

Thanks

Re: %HSRP-4-DIFFVIP1

Hi All,

FYI i have pasted the configuration for your referance.

interface Vlan12
ip address 10.230.134.130 255.255.255.192
ip helper-address 10.230.129.10
ip helper-address 10.230.129.26
no ip unreachables
ip directed-broadcast 198
standby 1 ip 10.230.134.129
standby 1 priority 110
standby 1 preempt
end

interface Vlan181
  ip address 10.230.148.194 255.255.255.192

ip helper-address 10.230.129.10
ip helper-address 10.230.129.26
ip directed-broadcast 198
ip flow ingress
standby 1 ip 10.230.148.193
end

Cisco Employee

Re: %HSRP-4-DIFFVIP1

Hi Hemakumar,

Check the configurations on the Peer HSRP  router

Also check if there is some conenctivity issue which is causing Vlan 12 of one HSRP router connecting Vlan 181 and vice versa

Thanks

Raju

%HSRP-4-DIFFVIP1

Please find the configuration in the peer. There is no connectivity issue ( FYR )

interface Vlan12

ip address 10.230.134.131 255.255.255.192

ip helper-address 10.230.129.10

ip helper-address 10.230.129.26

no ip unreachables

ip directed-broadcast 198

ip flow ingress

standby 1 ip 10.230.134.129

end

interface Vlan181

ip address 10.230.148.195 255.255.255.192

ip helper-address 10.230.129.10

ip helper-address 10.230.129.26

ip directed-broadcast 198

standby 1 ip 10.230.148.193

standby 1 priority 110

standby 1 preempt

end

Cisco Employee

%HSRP-4-DIFFVIP1

Hi Hemakumar,

Please do the following from the router which has IP 10.230.134.130 under vlan 12

1. ping 10.230.134.131 source 10.230.134.130

2. Ping 10.230.148.195 source 10.230.148.194

3. Show ip arp | inc 10.230.134.13

4. Show ip arp | inc 10.230.148.19

Thanks

Raju

Advocate

%HSRP-4-DIFFVIP1

Hi,

I believe you would stop the error messages by changing the HSRP group number in one of your VLANs.

But your LAN might be in a deeper trouble - it seems your VLANs 12 and 181 are interconnected somewhere creating one common VLAN in fact?

BTW, are you running HSRP v.1 or 2?

HTH,

Milan

%HSRP-4-DIFFVIP1

Hi Milan,

How can i check which version of HSRP i am running. I cannot chante the group number. If you refer my post i have mentioned the issue have solved. But not sure the way how it was resolved.

Advocate

Re: %HSRP-4-DIFFVIP1

Hi,

sh stanby

command will show you the HSRP version used.

Ver 1 is the deafult.

But you already explained yourself what the key problem was:

Your VLANs 12 and 181 were interconnected - creating one big common VLAN in fact.

That was caused by an access port assigned to VLAN12 connected by a cable to an access port assigned to VLAN181.

That's all.

HTH,

Milan

%HSRP-4-DIFFVIP1

Hi Milan

Its in Verstion 1, how a change in layer 2 is affecting HSRP. Please brief me or give please share me a link where i can gain more knowledge on this.

Advocate

%HSRP-4-DIFFVIP1

Hi,

when you interconnect your two VLANs, HSRP multicast  frames originated within one VLAN can reach the HSRP device in the other VLAN.

As you are using the same HSRP group number, the device will accept the HSRP frame and realize there was an incorrect virtual IP address configured within that frame (originated from the other VLAN/subnet).

Here you can read more details about HSRP:

http://www.cisco.com/en/US/customer/tech/tk648/tk362/technologies_q_and_a_item09186a00800a9679.shtml

http://www.cisco.com/en/US/customer/tech/tk648/tk362/technologies_tech_note09186a0080094afd.shtml

http://www.cisco.com/en/US/customer/docs/ios/12_3t/12_3t4/feature/guide/gthsrpv2.html

HTH,

Milan

View solution in original post

%HSRP-4-DIFFVIP1

Hi Milan and raj,

Thanks...

%HSRP-4-DIFFVIP1

Hi All,

The issue is resolved, but not sure what has created this problem. Here is connectivity diagram

We have two Core switches.  Core 1 & Core 2... A Access switch with dual uplink is connected to Core1 and Core 2.. We have one more standalone switch which is connected to the access( Dual uplink to the access switch ) In of the link from Standalone switch to Access switch was in access mode ( Vlan 181 is enabled.) and in other port it is in Access mode ( Vlan 12 is enabled ).

We have changed one of the where vlan 12 is enabled to vlan 181 post the issue is solved.

Please help me in understanding what was the exact issue.

Cisco Employee

%HSRP-4-DIFFVIP1

Hi Hemakumar,

If there was a mismatching configuration of access Vlans between these 2 access switches, the packets from  Vlan 12 and Vlan 181 would have leaked to each other causing the error messages you noticed

Thanks

Raju

%HSRP-4-DIFFVIP1

Hi Raju,

Can you give any link where in i can refere more on leakage. So that it would be useful for me to analyse further.

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards