08-23-2015 11:51 PM - edited 03-08-2019 01:28 AM
Hello,
i have a question.
I would like to import export routes between VRF's and use OSPF for this.
But the difficult part is that i want to do this accross a GRE Tunnel.
As below is shown.
VRF TEST1 is fully operational and i would like to import TEST2
How can i accomplish this ?
THANKS
Solved! Go to Solution.
08-24-2015 06:14 AM
Most important thing I forgot to ask. What about your MP-BGP configuration?
You should have a vrf address-family for TEST2 and redistribute the routes there. There's no need of neighbor configuration. Just something like this:
router bgp 1
address-family ipv4 vrf TEST2
redistribute connected
Take a look at this link about inter vrf route leakage.
And regarding RD and RTs, here.
08-24-2015 01:27 AM
Hi Johan,
I guess, you will need to add route-target import/export for vrf TEST1 to import/export routes of vrf TEST2 , hence the GRE tunnel is based on vrf TEST1. This solution called Inter VRF route leaking.
Regards,
Mohammad
08-24-2015 02:01 AM
Hello Mohammad,
Thanks for your reply!.
i tried this:
ip vrf TEST1
rd 65000:1
route-target export 65000:1
route-target import 65000:1
route-target import 65000:2
!
ip vrf TEST2
rd 65000:2
route-target export 65000:2
route-target import 65000:2
route-target import 65000:1
but after this still no routes are visible in both VRF's.
08-24-2015 02:04 AM
Hi Johan,
Please try it like this:
ip vrf TEST1
rd 65000:1
route-target export 65000:1
route-target export 65000:2
route-target import 65000:1
route-target import 65000:2
!
ip vrf TEST2
rd 65000:2
route-target export 65000:2
route-target import 65000:2
Regards,
Mohammad
08-24-2015 02:15 AM
Tried it but still no luck.
i'm kinda new with VRF so i correct me if i'm wrong
but could i be that i need to create a static route to connect the VRF's?
08-24-2015 02:17 AM
No, there's no need of static route here.
Do you use the below commands to check the routes?
show ip route vrf TEST1
show ip route vrf TEST2
08-24-2015 02:40 AM
Yes i'm using the command :
show ip route vrf TEST1
show ip route vrf TEST2
:)
08-24-2015 03:06 AM
Sounds strange, because you should at least see the connected routes in each vrf.
Could you please paste the output of show ip vrf detail?
08-24-2015 03:42 AM
VRF TEST1 (VRF Id = 1); default RD 65000:1; default VPNID <not set>
Interfaces:
Tu1 Gi0/0.1
VRF Table ID = 1
Export VPN route-target communities
RT:65000:1 RT:65000:2
Import VPN route-target communities
RT:65000:1 RT:65000:2
No import route-map
No export route-map
VRF label distribution protocol: not configured
VRF label allocation mode: per-prefix
VRF TEST2 (VRF Id = 1); default RD 65000:2; default VPNID <not set>
Interfaces:
Gi0/0.2
VRF Table ID = 1
Export VPN route-target communities
RT:65000:2 RT:65000:1
Import VPN route-target communities
RT:65000:2 RT:65000:1
No import route-map
No export route-map
VRF label distribution protocol: not configured
VRF label allocation mode: per-prefix
08-24-2015 06:14 AM
Most important thing I forgot to ask. What about your MP-BGP configuration?
You should have a vrf address-family for TEST2 and redistribute the routes there. There's no need of neighbor configuration. Just something like this:
router bgp 1
address-family ipv4 vrf TEST2
redistribute connected
Take a look at this link about inter vrf route leakage.
And regarding RD and RTs, here.
08-26-2015 01:30 AM
i didn't had BGP after adding that everthing works!
Many thanks Mohammed!!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide