cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
20027
Views
21
Helpful
30
Replies
Highlighted
Beginner

Inter-vlan routing not working on the C3750X Layer 3 Switch. Help!!!

Hi all,

Just configured a 3750x switch as a DHCP server for some vlans and even though the ip routing is enabled, I am unable to route between vlans.

Note that the 3750x serves as a core switch that connects through trunking to 2960s accesss switches. VTP v3 is enabled, as well as VTP pruning, all SVIs configured. DHCP gives the respective SVI as gateway for the PCs. The computers connect through IP phones so the ports on the 2960S are on multi-vlan access mode.

I am wondering why I am unable to route between my vlans as I can see all subnets on respective SVIs in the routing table of the switch. I also used the default gateway comand on the 2960S switches so they are able to ping all the SVIs but the PCs on the access ports are not able to do the same and possibly exchange information with each other on different networks.

Thanks in advance for your help.

Regards,

Igor

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Have you run the debug ip icmp command on the 3750-X, as per Karsten's suggestion yesterday? Depending upon the situation, it might be best to ensure that you only send output to your log, not the command line interface. Setup the debug and then jump onto one of the clients and run a ping to an SVI on the 3750-X. If the 3750-X receives the ICMP requests, then you'll see them in the log (one for each echo request.)

Testing the other way can be done by running wireshark on a client. Then jump onto the 3750-X and source a Ping from another network (either the VLAN ID or SVI IP address): -

ping x.x.x.x source vlan xx

ping x.x.x.x source x.x.x.x

I would also connect a client machine directly to the switch, in case the problem is related to the IP phones. Amend the switchport config accordingly.

View solution in original post

30 REPLIES 30
Highlighted
VIP Mentor

Can you reach the default-gateway address from the PCs?

If not, are all needed VLANs allowed on the trunk? Are the VLANs really availabe on the Access-switch (or is VTP really working)?

-- 
Don't stop after you've improved your network! Improve the world by lending money to the working poor:
http://www.kiva.org/invitedby/karsteni

Highlighted

Thanks for your answer,

Yes the PCs are able to ping their respective default gateways.

for now all VLANs are allowed on the trunk, as I am receiving all of them through VTP v3 on the access switches.

The access switches are able to ping all SVIs but the devices connected to them are not. Only their default gateways.

Highlighted

If you run a "debug ip icmp" on the 3750X and ping a IP of the switch that is not the DG of the PC (pinging from the PC), do you see any output?

-- 
Don't stop after you've improved your network! Improve the world by lending money to the working poor:
http://www.kiva.org/invitedby/karsteni

Highlighted

do traceroute from PC to IP. does this reach your default gateway?

Highlighted

No please, the traceroute dies at the default gateway.

Highlighted

When I ping my default Gateway I see the debuging packcets but when I ping an external network, nothing shows.

Highlighted

Have you double-checked the IP-settings that the PC learns? Escpecially that there is no typo in the Default-Gateway?

-- 
Don't stop after you've improved your network! Improve the world by lending money to the working poor:
http://www.kiva.org/invitedby/karsteni

Highlighted

There is also no output if you ping 192.168.10.254 from the PC?

-- 
Don't stop after you've improved your network! Improve the world by lending money to the working poor:
http://www.kiva.org/invitedby/karsteni

Highlighted

Can you share route print from PC ? I am suspecting subnet mask configured on your system

Highlighted

I know you can ping the local default gateway from each client machine, but has DHCP correctly learned a default gateway address?

Any ACLs configured?

Any permenant routes configured on the client machines that might be preferred over the DHCP-learned default route?

Highlighted

I have not configured any route yet, nor any access lists. I just uploaded the configuration on the core switch to the discussion. If anyone spot an error, I will be so pleased.

Highlighted
Beginner

The configuration is as follow:

Current configuration : 5284 bytes

!

! Last configuration change at 00:50:41 UTC Mon Mar 1 1993

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname xxxx

!

boot-start-marker

boot-end-marker

!

!

!

username admin privilege 15 password 7 xxxx

no aaa new-model

switch 1 provision ws-c3750x-24

system mtu routing 1500

ip routing

!

ip dhcp excluded-address 192.168.30.1 192.168.30.50

ip dhcp excluded-address 192.168.30.254

ip dhcp excluded-address 192.168.40.1 192.168.40.50

ip dhcp excluded-address 192.168.40.254

!

ip dhcp pool DATA

   network 192.168.30.0 255.255.255.0

   default-router 192.168.30.254

   domain-name xxxx

   dns-server 4.2.2.2

!

ip dhcp pool PHONE

   network 192.168.40.0 255.255.255.0

   default-router 192.168.40.254

   domain-name xxxx

   dns-server 4.2.2.2

!

!

ip domain-name xxxx

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

!

!

!

vlan internal allocation policy ascending

!

!

!

!

!

!

!

interface FastEthernet0

no ip address

no ip route-cache cef

no ip route-cache

!

interface GigabitEthernet1/0/1

description ### CONNECTIONS TO SERVER LAN PORTS ###

switchport access vlan 10

switchport mode access

!

interface GigabitEthernet1/0/2

description ### CONNECTIONS TO SERVER LAN PORTS ###

switchport access vlan 10

switchport mode access

!

interface GigabitEthernet1/0/3

description ### CONNECTIONS TO SERVER LAN PORTS ###

switchport access vlan 10

switchport mode access

!

interface GigabitEthernet1/0/4

description ### CONNECTIONS TO SERVER LAN PORTS ###

switchport access vlan 10

switchport mode access

!

interface GigabitEthernet1/0/5

description ### CONNECTIONS TO SERVER LAN PORTS ###

switchport access vlan 10

switchport mode access

!

interface GigabitEthernet1/0/6

description ### CONNECTIONS TO SERVER LAN PORTS ###

switchport access vlan 10

switchport mode access

!

interface GigabitEthernet1/0/7

description ### CONNECTION TO STORAGE AND SERVER iSCSI PORTS ###

switchport access vlan 20

switchport mode access

!

interface GigabitEthernet1/0/8

description ### CONNECTION TO STORAGE AND SERVER iSCSI PORTS ###

switchport access vlan 20

switchport mode access

!

interface GigabitEthernet1/0/9

description ### CONNECTION TO STORAGE AND SERVER iSCSI PORTS ###

switchport access vlan 20

switchport mode access

!

interface GigabitEthernet1/0/10

description ### CONNECTION TO STORAGE AND SERVER iSCSI PORTS ###

switchport access vlan 20

switchport mode access

!

interface GigabitEthernet1/0/11

description ### CONNECTION TO STORAGE AND SERVER iSCSI PORTS ###

switchport access vlan 20

switchport mode access

!

interface GigabitEthernet1/0/12

description ### CONNECTION TO STORAGE AND SERVER iSCSI PORTS ###

switchport access vlan 20

switchport mode access

!

interface GigabitEthernet1/0/13

description ### DOWNLINK TO ACCESS SWITCHES ###

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/0/14

description ### DOWNLINK TO ACCESS SWITCHES ###

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/0/15

description ### DOWNLINK TO ACCESS SWITCHES ###

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/0/16

description ### DOWNLINK TO ACCESS SWITCHES ###

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/0/17

description ### DOWNLINK TO ACCESS SWITCHES ###

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/0/18

description ### DOWNLINK TO ACCESS SWITCHES ###

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/0/19

!

interface GigabitEthernet1/0/20

!

interface GigabitEthernet1/0/21

!

interface GigabitEthernet1/0/22

!

interface GigabitEthernet1/0/23

!

interface GigabitEthernet1/0/24

description ### UPLINK TO INTERNET ROUTER ###

switchport access vlan 90

switchport mode access

!

interface GigabitEthernet1/1/1

!

interface GigabitEthernet1/1/2

!

interface GigabitEthernet1/1/3

!

interface GigabitEthernet1/1/4

!

interface TenGigabitEthernet1/1/1

!

interface TenGigabitEthernet1/1/2

!

interface Vlan1

no ip address

!

interface Vlan10

description ### FOR SERVER LAN DATA TRAFFIC ###

ip address 192.168.10.254 255.255.255.0

!

interface Vlan20

description ### FOR iSCSI SAN TRAFFIC COMMUNICATIONS ###

ip address 192.168.20.254 255.255.255.0

!

interface Vlan30

description ### FOR END-USER WIRED LAN TRAFFIC ###

ip address 192.168.30.254 255.255.255.0

!

interface Vlan40

description ### FOR IP TELEPHONY TRAFFIC ###

ip address 192.168.40.254 255.255.255.0

!

interface Vlan50

description ### FOR DMZ SERVER TRAFFIC ###

ip address 192.168.50.254 255.255.255.0

!

interface Vlan60

description ### FOR IN-BAND MANAGEMENT TRAFFIC ###

ip address 192.168.60.254 255.255.255.0

!

interface Vlan90

description ### UPLINK FROM CORE SWITCH TO INTERNET ROUTER ###

ip address 192.168.90.254 255.255.255.0

!

!

ip http server

ip http secure-server

!

!

logging esm config

!

!

!

line con 0

logging synchronous

line vty 0 4

privilege level 15

login local

transport input telnet ssh

line vty 5 15

privilege level 15

login local

transport input telnet ssh

!

end

Highlighted

Hello,

The problem is that you have configured the same ip of the gateway X.X.X.254 for the management of the router. Each VLAN has its own management IP and it has to be different from the gateway of the same VLAN

ip dhcp pool DATA
    network 192.168.30.0 255.255.255.0
    default-router 192.168.30.254 ---> Gateway
    domain-name xxxx
    dns-server 4.2.2.2


Vlan30 interface
description ### FOR END-USER WIRED LAN TRAFFIC ###
ip address 192.168.30.254 255.255.255.0 -> Management IP

When you ping 192.168.30.254 from a VLAN 30 PC, you are reaching the management IP, not the gateway. Surely if you put 192.168.30.254 in a web browser by http you enter the configuration mode of the 3750
Highlighted
Beginner

I am begining to wonder if there is not a default command somewhere that needs to be changed or soemthing of that sort that is specific to 3750x switches.

Content for Community-Ad