cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
965
Views
0
Helpful
8
Replies

InterVlan Routing -ISR with ESM

Hi guys, 

 

Apologies if this is posted in the wrong place but I'm just looking for some advice...

I've got a 2811 ISR with a NM-16ESW, the router is connected to my cable modem with it's FastEth 0/0 interface, and there are 2 vlans on the router 10 & 15 each has 8 ports of the ESM assigned to it.

 

FastEth 0/0         -> Cable modem

FastEth 1/0 - 7   -> Vlan 10

FastEth 1/8 - 15 -> Vlan 15

 

I'd like to have machines on both vlans to access the internet via the Cable modem but not be able to access the machines on the other vlan. I've managed to get one of the two vlans up so it can access the internet but machines on the second vlan can't ping the router.

 

Below is sample of the relevant parts of my config;

!
interface FastEthernet0/0
 ip address 192.168.1.60 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 switchport access vlan 10
!
interface FastEthernet1/1
 switchport access vlan 10
!
interface FastEthernet1/2
 switchport access vlan 10
!
interface FastEthernet1/3
 switchport access vlan 10
!
interface FastEthernet1/4
 switchport access vlan 10
!
interface FastEthernet1/5
 switchport access vlan 10
!
interface FastEthernet1/6
 switchport access vlan 10
!
interface FastEthernet1/7
 switchport access vlan 10
!
interface FastEthernet1/8
 switchport access vlan 15
!
interface FastEthernet1/9
 switchport access vlan 15
!
interface FastEthernet1/10
 switchport access vlan 15
!
interface FastEthernet1/11
 switchport access vlan 15
!
interface FastEthernet1/12
 switchport access vlan 15
!
interface FastEthernet1/13
 switchport access vlan 15
!
interface FastEthernet1/14
 switchport access vlan 15
!
interface FastEthernet1/15
 switchport access vlan 15
!
interface Vlan10
 ip address 192.168.10.254 255.255.255.0
!
interface Vlan15
 ip address 192.168.15.254 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!


Any help would be greatly appreciated.

 

Thanks in advance for any replies,

    Yanni

1 Accepted Solution

Accepted Solutions

Hi guys,

 

Looks like I've fixed it now...

So as a last ditch effort I wiped my configuration and rebuilt from scratch, and well now it all works.

 

 

Thanks for all the suggestions and thank you guys for your time!

View solution in original post

8 Replies 8

Julio E. Moisa
VIP Mentor VIP Mentor
VIP Mentor

Hi

Your configuration looks fine at simple sight, have you verified if the computers are using the proper gateway IP (SVI IP on ther router)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Hi there,

 

Yes I've confirmed that all machines have the correct IP address configurations, and upon further troubleshooting I have found that while the router itself can ping both the physical interface and one of the vlan interfaces, it can't ping the other vlan interface... 

Here is a sample of the ping outputs.

 

Ping FastEth interface;
Athena#ping 192.168.1.60 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.168.1.60, timeout is 2 seconds: !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms Ping vlan 10 interface; Athena#ping 192.168.10.254 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.168.10.254, timeout is 2 seconds: ..... Success rate is 0 percent (0/5) ping vlan 15 interface; Athena#ping 192.168.15.254 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.168.15.254, timeout is 2 seconds: !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms