Showing results for 
Search instead for 
Did you mean: 
Join Customer Connection to register!
shelly mathew

IP DHCP name with space


I have a Cisco 4503 with Software version 03.03.00.SG. I have a dhcp pool name with spaces, i'm unable to manage this pool, or delete it. 

ip dhcp pool AAA Gxxx Wi-Fi


I get the following error when trying 

Invalid input detected at '^' marker. 


appreciate any help.


I've attached the config here. i'm connecting using teraterm/ putty. I've tried directly through serial, but i'm still unable to edit.

Georg Pauwen
VIP Expert



on a side note, I tried this in GNS3 with IOSv 15.6(2)T, and it lets me create and delete DHCP pools with white spaces just fine.


Either way, not sure if somebody has mentioned this, but try and copy the startuo config to a TFTP server, then manually delete the pool, copy the startuo back to flash, and then copy startup to runnning...

Andrew Khalil
Rising star

@shelly mathew, Hello again!

I have searched for you, and I have found that this problem can be happened when the configuration of this pool was done through the GUI, otherwise, it is not accepted from the CLI, even config. load to switch will not be accepted and it usually fails with an error pointing to the line in the config that has the DHCP pool name.


Now, you have 2 options more I recommend to follow:

1- Is to access the switch using it's GUI, and delete the DHCP pool directly there! if it's not accepted as well.

2- Take a backup from the GUI, then edit the name of the DHCP pool to use - instead of the spaces, and then upload it using the GUI or the CLI! 


Please, try it, I wish it works!


Please don't forget to rate any helpful responses! 

Bst Rgds!

Andrew Khalil


paul driver
VIP Mentor


Possible a ghost entry, Reload the device when applicable to see if that removes it, in the interim just remove the network scope and any options applied to it.

kind regards

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

How do i modify the pool? i cannot enter the pool name to modify it.