02-27-2019 02:35 AM
Hi all, I am attempting to connect 3 routers to a main router as part of a larger setup.
the relevant IP addressing table is :
Router1 (on F0/0/1) 192.168.3.2/26
Router2 (on F0/0/2 192.168.3.66/26
Router3 (on F0/0/3) 192.168.3.130/26
Main Router F0/0/1 - 192.168.3.1/26 F0/0/2 -192.168.3.65/26 F0/0/3 192.168.3.129/26
As they are on Layer 2 ports I have tried to assign Vlans ( R1- vlan10, R2-vlan20 & R3 vlan30) for the IP addressing but because they are all on the same subnet, I get a vlan overlapping error. Is there another way to assign Vlan IP's that wont get this error?
Any assistance appreciated.
Thanks
Darrinmc
02-27-2019 02:48 AM
02-27-2019 03:44 AM
I am not following, they are not all on the same subnet ie. the only devices on the same subnet are the two on 192.168.3.0/26.
Jon
02-28-2019 01:09 AM
I must be misunderstanding subnets ? I would think these are all on the same subnet ?
192.168.3.2/26
192.168.3.66/26
192.168.3.130/26
192.168.3.1/26
192.168.3.65/26
192.168.3.129/26
You said only 2 are on subnet 192.168.3.0/26 ? Which would they be?
02-28-2019 01:16 AM
Sorry my mistake, you have 3 different subnets -
192.168.3.0 255.255.255.192 -> which includes 192.168.3.1 and 192.168.3.2
192.168.3.64 255.255.255.192 -> which includes 192.168.3.65 and 192.168.3.66
192.168.3.128 255.255.255.192 -> which includes 192.168.3.129 and 192.168.3.130
Jon
02-27-2019 03:56 AM
Make sure no other VLAN interface already configured in the main router before you configure this.
post main router configuration to look.
02-28-2019 01:09 AM
ERROR MESSAGE
HQ(config)#int vlan 20
HQ(config-if)#
%LINK-5-CHANGED: Interface Vlan20, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up
HQ(config-if)#ip address 192.168.3.65 255.255.255.192
% 192.168.3.64 overlaps with Vlan10
HQ(config-if)#
hostname HQ
!
ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX15243FH3
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/0/0
switchport mode access
!
interface FastEthernet0/0/1
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/0/2
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/0/3
switchport access vlan 30
switchport mode access
!
interface Serial0/1/0
ip address 10.20.20.1 255.255.255.252
clock rate 2000000
!
interface Serial0/1/1
ip address 10.10.10.2 255.255.255.252
clock rate 2000000
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
mac-address 0030.f25c.4d01
ip address 192.168.3.1 255.255.255.128
!
interface Vlan20
mac-address 0030.f25c.4d02
no ip address
hostname R1
!
no ip cef
no ipv6 cef
!
spanning-tree mode pvst
!
interface Loopback1
ip address 172.16.0.1 255.255.255.0
!
interface Loopback2
ip address 172.16.1.1 255.255.255.0
!
interface Loopback3
ip address 172.16.2.1 255.255.255.0
!
interface Loopback4
ip address 172.16.3.1 255.255.255.0
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/0/0
switchport mode access
!
interface FastEthernet0/0/1
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/0/2
switchport mode access
!
interface FastEthernet0/0/3
switchport mode access
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
mac-address 0002.4a21.0d01
ip address 192.168.3.2 255.255.255.192
!
router ospf 10
router-id 1.1.1.1
log-adjacency-changes
network 192.168.3.0 0.0.0.63 area 10
network 172.16.0.0 0.0.0.255 area 10
network 172.16.1.0 0.0.0.255 area 10
network 172.16.2.0 0.0.0.255 area 10
network 172.16.3.0 0.0.0.255 area 10
!
ip classless
02-28-2019 01:52 AM
Thanks for taking the time to review.
ERROR MESSAGE
HQ(config)#int vlan 20
HQ(config-if)#
%LINK-5-CHANGED: Interface Vlan20, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up
HQ(config-if)#ip address 192.168.3.65 255.255.255.192
% 192.168.3.64 overlaps with Vlan10
HQ(config-if)#
hostname HQ
!
ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX15243FH3
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/0/0
switchport mode access
!
interface FastEthernet0/0/1
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/0/2
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/0/3
switchport access vlan 30
switchport mode access
!
interface Serial0/1/0
ip address 10.20.20.1 255.255.255.252
clock rate 2000000
!
interface Serial0/1/1
ip address 10.10.10.2 255.255.255.252
clock rate 2000000
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
mac-address 0030.f25c.4d01
ip address 192.168.3.1 255.255.255.128
!
interface Vlan20
mac-address 0030.f25c.4d02
no ip address
hostname R1
!
no ip cef
no ipv6 cef
!
spanning-tree mode pvst
!
interface Loopback1
ip address 172.16.0.1 255.255.255.0
!
interface Loopback2
ip address 172.16.1.1 255.255.255.0
!
interface Loopback3
ip address 172.16.2.1 255.255.255.0
!
interface Loopback4
ip address 172.16.3.1 255.255.255.0
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/0/0
switchport mode access
!
interface FastEthernet0/0/1
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/0/2
switchport mode access
!
interface FastEthernet0/0/3
switchport mode access
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
mac-address 0002.4a21.0d01
ip address 192.168.3.2 255.255.255.192
!
router ospf 10
router-id 1.1.1.1
log-adjacency-changes
network 192.168.3.0 0.0.0.63 area 10
network 172.16.0.0 0.0.0.255 area 10
network 172.16.1.0 0.0.0.255 area 10
network 172.16.2.0 0.0.0.255 area 10
network 172.16.3.0 0.0.0.255 area 10
!
ip classless
02-27-2019 06:01 AM
02-28-2019 01:04 AM
Thanks for taking the time to review.
This is the error message when I try to assign IP to VLAN 20, and then config for HQ and R1. both connected via F0/0/1. The same happens when I do the same for R2 and R3,
ERROR MESSAGE
HQ(config)#int vlan 20
HQ(config-if)#
%LINK-5-CHANGED: Interface Vlan20, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up
HQ(config-if)#ip address 192.168.3.65 255.255.255.192
% 192.168.3.64 overlaps with Vlan10
HQ(config-if)#
hostname HQ
ip cef
no ipv6 cef
license udi pid CISCO1941/K9 sn FTX15243FH3
spanning-tree mode pvst
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/0/0
switchport mode access
!
interface FastEthernet0/0/1
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/0/2
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/0/3
switchport access vlan 30
switchport mode access
!
interface Serial0/1/0
ip address 10.20.20.1 255.255.255.252
clock rate 2000000
!
interface Serial0/1/1
ip address 10.10.10.2 255.255.255.252
clock rate 2000000
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
mac-address 0030.f25c.4d01
ip address 192.168.3.1 255.255.255.128
!
interface Vlan20
mac-address 0030.f25c.4d02
no ip address
hostname R1
!
no ip cef
no ipv6 cef
!
spanning-tree mode pvst
!
interface Loopback1
ip address 172.16.0.1 255.255.255.0
!
interface Loopback2
ip address 172.16.1.1 255.255.255.0
!
interface Loopback3
ip address 172.16.2.1 255.255.255.0
!
interface Loopback4
ip address 172.16.3.1 255.255.255.0
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/0/0
switchport mode access
!
interface FastEthernet0/0/1
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/0/2
switchport mode access
!
interface FastEthernet0/0/3
switchport mode access
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
mac-address 0002.4a21.0d01
ip address 192.168.3.2 255.255.255.192
!
router ospf 10
router-id 1.1.1.1
log-adjacency-changes
network 192.168.3.0 0.0.0.63 area 10
network 172.16.0.0 0.0.0.255 area 10
network 172.16.1.0 0.0.0.255 area 10
network 172.16.2.0 0.0.0.255 area 10
network 172.16.3.0 0.0.0.255 area 10
!
ip classless
02-28-2019 01:58 AM
02-28-2019 07:11 AM
Looking high level :
HQ(config)#int vlan 20
HQ(config-if)#
%LINK-5-CHANGED: Interface Vlan20, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up
HQ(config-if)#ip address 192.168.3.65 255.255.255.192
% 192.168.3.64 overlaps with Vlan10
HQ(config-if)#
You VLAN 10 have wrong mask, dont you think so ?
interface Vlan10
mac-address 0030.f25c.4d01
ip address 192.168.3.1 255.255.255.128 (192 /26, as per your original email)
03-01-2019 10:04 AM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide