cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
27848
Views
5
Helpful
6
Replies
JAYESH RAMAIYA
Beginner

ip vlan overlapping

Hi

I need to enter the config below on one of our core switches -

interface vlan 602

description *** HOTEL_TRANS ***

ip address 10.90.202.252 255.255.255.0

ip access-group ACL_HOTEL_TRANS in

standby 602 ip 10.90.202.254

standby 602 timers 1 4

standby 602 priority 100

standby 602

When I enter this I get the message that 10.90.202.0 overlaps with vlan10. The switch vlan 10 config is below -

interface Vlan10

description Hotel-User-VLAN-1

ip address 10.90.1.197 255.255.0.0

no ip redirects

standby 10 ip 10.90.0.22

standby 10 priority 105

standby 10 preempt

Any assistance would be appreciated.

Thanks

2 ACCEPTED SOLUTIONS

Accepted Solutions
glen.grant
Advisor

Unless you adjust the mask in vlan 10 you will continue to get overlapping address errors.  vlan 10 covers 10.90.0.0  thru 10.90.255.255 so youir vlan 602 will be overlapped .  So you need to adjust the vlan 10 mask or get vlan 602 completely out of the address space covered by vlan 10.  Someone made a goof using a /16 on vlan 10 .

View solution in original post

Just tried to over lap address spaces by isolating with VRFs and it worked on at 3550.  There are probably reasons why not to do that but you should be OK to do that with that understanding.

- Be sure to rate all helpful posts

View solution in original post

6 REPLIES 6
cadet alain
Advisor

Hi,

10.90.202.252 255.255.255.0 is 10.90.202.0/24 subnet which is part of  10.90.1.197 255.255.0.0( 10.90.0.0/16)

so choose a /24( 255.255.255.0) on vlan 10 so it will be in 10.90.1.0/24) which is a different subnet.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

Hi

Thanks for this.

I need to keep Vlan 10, If I use the VRF command, would this work? 

interface vlan 602

description *** HOTEL_TRANS ***

ip vrf forwarding HOTEL_TRANS

ip address 10.90.202.252 255.255.255.0

ip access-group ACL_HOTEL_TRANS in

standby 602 ip 10.90.202.254

standby 602 timers 1 4

standby 602 priority 100

standby 602

I beleive so.  You will need to have the "HOTEL_TRANS" VRF definned first of course.

Be sure to rate helpful posts.

- Be sure to rate all helpful posts

Just tried to over lap address spaces by isolating with VRFs and it worked on at 3550.  There are probably reasons why not to do that but you should be OK to do that with that understanding.

- Be sure to rate all helpful posts

View solution in original post

glen.grant
Advisor

Unless you adjust the mask in vlan 10 you will continue to get overlapping address errors.  vlan 10 covers 10.90.0.0  thru 10.90.255.255 so youir vlan 602 will be overlapped .  So you need to adjust the vlan 10 mask or get vlan 602 completely out of the address space covered by vlan 10.  Someone made a goof using a /16 on vlan 10 .

View solution in original post

Hi

I think we are going for vlan 602, 603 AND 604 completly out of the VLAN 10 network. Can you please look at the config below and advise please

interface vlan 602

description *** HOTEL_TRANS ***

ip address 192.168.1.0 255.255.255.0

ip access-group ACL_HOTEL_TRANS in

standby 602 ip 192.168.1.254

standby 602 timers 1 4

standby 602 priority 100

no shut    

interface vlan 603

description *** HOTEL_IBS ***

ip address 192.168.2.0 255.255.255.0

ip access-group ACL_HOTEL_IBS in

standby 603 ip 192.168.2.0

standby 603 timers 1 4

standby 603 priority 100

standby 603

no shut

interface vlan 604

description *** HOTEL_INVIS ***

ip address 192.168.3.0 255.255.255.0

ip access-group ACL_HOTEL_INVIS in

standby 604 ip 192.168.3.0

standby 604 timers 1 4

standby 604 priority 100

standby 604

no shut