cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

239
Views
0
Helpful
6
Replies
Highlighted
Beginner

mac flapping however the mac belongs to the switch interface

hi every,

 

I saw some mac flapping log in show logging.

 

sw-241# sho logg | in e691

Mar 21 10:20:10.559 CNT: %SW_MATM-4-MACFLAP_NOTIF: Host 5061.bf7c.e691 in vlan 2 is flapping between port Te1/1/4 and port Gi2/0/16
Mar 21 15:14:34.567 CNT: %SW_MATM-4-MACFLAP_NOTIF: Host 5061.bf7c.e691 in vlan 2 is flapping between port Te1/1/4 and port Gi2/0/16
Mar 21 15:15:16.278 CNT: %SW_MATM-4-MACFLAP_NOTIF: Host 5061.bf7c.e691 in vlan 2 is flapping between port Po100 and port Te1/1/4

 

sw-241#sho mac address-table | in e691
2 5061.bf7c.e691 DYNAMIC Gi2/0/16
5 5061.bf7c.e691 DYNAMIC Gi2/0/16
32 5061.bf7c.e691 DYNAMIC Gi2/0/16

 

 

sw-148# sho int gi 0/17
GigabitEthernet0/17 is up, line protocol is up (connected)
Hardware is Gigabit Ethernet, address is 5061.bf7c.e691 (bia 5061.bf7c.e691)
MTU 1522 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive not set
Full-duplex, 1000Mb/s, link type is auto, media type is 1000BaseLX SFP
input flow-control is off, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 27000 bits/sec, 28 packets/sec
5 minute output rate 10000 bits/sec, 4 packets/sec
13476997 packets input, 1891774581 bytes, 0 no buffer
Received 12446655 broadcasts (6835168 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 6835168 multicast, 0 pause input
0 input packets with dribble condition detected
1097209 packets output, 266277348 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out

 

 

how could this happen?and how can I fix this?

 

Thank you for any answers

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Mentor

Re: mac flapping however the mac belongs to the switch interface

Hi
whats connected to port g0/17 and what configuration is on it ?
is there any static mac entrys in global config for that mac ?

whats the show ip arp show for that mac address , is there mutiple ips?

This will stop the alerts ----no mac address-table notification mac-move
6 REPLIES 6
VIP Advisor

Re: mac flapping however the mac belongs to the switch interface

A MAC Flap is caused when switch receives packets from two different interfaces with the same source MAC address.

 

Show us the configuration of the port and port-channel information.

 

BB
*** Rate All Helpful Responses ***
Beginner

Re: mac flapping however the mac belongs to the switch interface

Thank you for your reply.

The configuration of the port is :
sw-241#sho run int gi 2/0/16
Building configuration...

Current configuration : 245 bytes
!
interface GigabitEthernet2/0/16
switchport mode trunk
storm-control broadcast level 2.00
storm-control multicast level 2.00
macro description cisco-switch | cisco-switch
spanning-tree link-type point-to-point
ip dhcp snooping trust
end

sw-241#sho run interface tenGigabitEthernet 1/1/4
Building configuration...

Current configuration : 140 bytes
!
interface TenGigabitEthernet1/1/4
switchport mode trunk
spanning-tree link-type point-to-point
end


sw-241#sho run interface port-channel 100
Building configuration...

Current configuration : 118 bytes
!
interface Port-channel100
switchport mode trunk
ip dhcp snooping trust
end

Thank you
VIP Advisor

Re: mac flapping however the mac belongs to the switch interface

what is the device connected to interface GigabitEthernet0/17   <<- if this host why not setup as access-port ?

BB
*** Rate All Helpful Responses ***
VIP Advisor

Re: mac flapping however the mac belongs to the switch interface

what is the device connected to interface GigabitEthernet0/17   <<- if this host why not setup as access-port ?
BB
*** Rate All Helpful Responses ***
VIP Mentor

Re: mac flapping however the mac belongs to the switch interface

Hi
whats connected to port g0/17 and what configuration is on it ?
is there any static mac entrys in global config for that mac ?

whats the show ip arp show for that mac address , is there mutiple ips?

This will stop the alerts ----no mac address-table notification mac-move
Beginner

Re: mac flapping however the mac belongs to the switch interface

Thank you for your reply.

sw-148#sho run int gi 0/17
Building configuration...

Current configuration : 196 bytes
!
interface GigabitEthernet0/17
switchport trunk allowed vlan 1,2,5,32
switchport mode trunk
storm-control broadcast level 2.00
storm-control multicast level 2.00
ip dhcp snooping trust
end

There is no static mac entrys in global config for that mac

show arp is no ip for that MAC
sw-241# sho arp | in e691

I don't want to disable the alert....I just want to find out what the problem is..

Thank you
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards