cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2079
Views
0
Helpful
11
Replies

MPLS PE cannot ping CE

Hey guys,

 

I'm trying to setup an MPLS L3 using GNS3 and C3745E routers.

 

Everything is up, BGP neighbors are up and running, routes are propaganded.

Problem is, when I try to trace a ping from one end of the customer to the other end, it doesn't work.

I found out that the PE router cannot ping the CE router, but the other way around works.

 

If I remove:  ip vrf forwarding CUST-A  in the interface and bring back the IP Address, it works, but as soon as I put back the IP vrf forwarding, the ping does not work

 

Anyone have any idea what I'm missing here?

 

Thanks!

 

 

CE Configuration:

 


Building configuration...

Current configuration : 1353 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CUSTA-R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface Loopback100
ip address 55.55.55.55 255.255.255.255
!
interface FastEthernet0/0
ip address 15.15.15.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 192.168.3.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet3/0
no ip address
shutdown
duplex auto
speed auto
!
router bgp 65002
no synchronization
bgp log-neighbor-changes
network 5.5.5.5 mask 255.255.255.255
network 55.55.55.55 mask 255.255.255.255
network 192.168.1.0
network 192.168.3.0
neighbor 15.15.15.1 remote-as 65001
no auto-summary
!
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end

 

PE Configuration:

 


Building configuration...

Current configuration : 2231 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
ip tcp synwait-time 5
!
!
!
!
ip vrf CUST-A
rd 65002:1
route-target export 65002:1
route-target import 65002:1
!
no ip domain lookup
!
mpls label range 1000 1999
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
ip vrf forwarding CUST-A
ip address 15.15.15.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet4/0
no ip address
shutdown
duplex auto
speed auto
!
router bgp 65001
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 65001
neighbor 4.4.4.4 update-source Loopback0
!
address-family ipv4
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 next-hop-self
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-community extended
exit-address-family
!
address-family ipv4 vrf CUST-A
neighbor 15.15.15.2 remote-as 65002
neighbor 15.15.15.2 activate
neighbor 15.15.15.2 as-override
no synchronization
exit-address-family
!
ip route 2.2.2.2 255.255.255.255 12.12.12.2
ip route 4.4.4.4 255.255.255.255 12.12.12.2
ip route 34.34.34.0 255.255.255.0 12.12.12.2
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
!
mpls ldp router-id Loopback0 force
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
webvpn context Default_context
ssl authenticate verify all
!
no inservice
!
!
end

 

11 Replies 11

Hi

The PE will be able to make ping to the CE through the VRF for example

ping vrf CUST-A 15.15.15.2

Now if the ping or traceroute from CE to CE you must verify if the network has added a tag, could you please share your config? At simple sight your configuration looks fine, check the ldp neighbors:

 

show mpls ldp neighbor

check the forwarding table

show mpls forwarding-table 

 

Also check if CEF is enabled.

show ip cef.

 

Thank you

 

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<


R1#show mpls forwarding-table
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
1000 Pop tag 2.2.2.2/32 0 Fa0/0 12.12.12.2
1001 2002 4.4.4.4/32 0 Fa0/0 12.12.12.2

1002 2003 34.34.34.0/24 0 Fa0/0 12.12.12.2
1003 Untagged 5.5.5.5/32[V] 0 Fa0/1 15.15.15.2
1004 Untagged 55.55.55.55/32[V] 0 Fa0/1 15.15.15.2
1005 Untagged 192.168.1.0/24[V] 0 Fa0/1 15.15.15.2
1006 Untagged 192.168.3.0/24[V] 0 Fa0/1 15.15.15.2

 

 

But there seems to be a problem with the other side:

 

When I try to add the vrf inside BGP, it accepts the commands but its not shwing into the run config


address-family ipv4 vrf CUST-A
neighbor 46.46.46.6 remote-as 65002
neighbor 46.46.46.6 activate
neighbor 46.46.46.6 as-override
no synchronization
exit-address-family

 


R4#show mpls forwarding-table
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
4000 3000 1.1.1.1/32 0 Fa0/0 34.34.34.1
4001 Pop tag 3.3.3.3/32 0 Fa0/0 34.34.34.1
4002 3003 12.12.12.0/24 0 Fa0/0 34.34.34.1

 

 

Here's the config


Current configuration : 2043 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
ip tcp synwait-time 5
!
!
!
!
ip vrf CUST-A
route-target export 65002:1
route-target import 65002:1
!
no ip domain lookup
!
mpls label range 4000 4999
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 34.34.34.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
ip vrf forwarding CUST-A
ip address 46.46.46.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet4/0
no ip address
shutdown
duplex auto
speed auto
!
router bgp 65001
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 65001
neighbor 1.1.1.1 update-source Loopback0
!
address-family ipv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 next-hop-self
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community extended
exit-address-family
!
ip route 1.1.1.1 255.255.255.255 34.34.34.1
ip route 3.3.3.3 255.255.255.255 34.34.34.1
ip route 12.12.12.0 255.255.255.0 34.34.34.1
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
!
mpls ldp router-id Loopback0 force
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
webvpn context Default_context
ssl authenticate verify all
!
no inservice
!
!
end

 

 

 

Hi 

You have not configured any address family with VRF on R4. 

 

Also LDP protocol is not running on the routers, you need to configure OSPF on the PE to interconnect with the P routers, for example I sugget remove static routing and use OSPF or ISIS

 

Example:

CE-Router1  ------ PE-Router2 ------ P-Router3------ PE-router4 -------CE-router5

 

CE-Router 1

 

interface loopback 0
ip address 1.1.1.1 255.255.255.255

 

interface loopbak 1
ip address 11.11.11.1 255.255.255.0

 

interface fa0/0
description TO-PE-ROUTER-2
ip address 15.15.15.2 255.255.255.0
no shutdown

 

router bgp 100
no sync
no au
neighbor 15.15.15.1 remote 777
network 1.1.1.1 mask 255.255.255.255
network 11.11.11.0 mask 255.255.255.0

 

PE-Router-2

 

ip vrf CUST-A
rd 65002:1
route-target export 65002:1
route-target import 65002:1

 

interface loopback 0
ip address 2.2.2.2 255.255.255.255

 

mpls ldp router-id loopback 0

 

interface fa0/0
description TO-CE-ROUTER-1
ip vrf forward CUST-A
ip address 15.15.15.1 255.255.255.0
no shutdown

 

interface fa0/1
description TO-P-ROUTER-3
ip address 10.23.0.2 255.255.255.0
no shutdown

 

router ospf 100
mpls ldp auto
network 2.2.2.2 0.0.0.0 area 0
network 10.23.0.2 0.0.0.255 area 0

 

router bgp 777
no sync
no au
neighbor 4.4.4.4 remote 777
neighbor 4.4.4.4 update-source loopback0
address-family vpnv4
neighbor 4.4.4.4 activate
address-family vrf CUST-A
neighbor 15.15.15.2 remote 100
neighbor 15.15.15.2 activate
neighbor 15.15.15.2 as-overide (If the other CE is using AS 100 as well)

 

 

 

P-Router 3


interface loopback 0
ip address 3.3.3.3 255.255.255.255

 

mpls ldp router-id loopback 0

 

interface fa0/1
description TO-PE-ROUTER2
ip address 10.23.0.3 255.255.255.0
no shutdown

 

interface fa0/0
description TO-PE-ROUTER4
ip address 10.34.0.3 255.255.255.0
no shutdown

 

router ospf 100
mpls ldp auto
network 3.3.3.3 0.0.0.0 area 0
network 10.23.0.3 0.0.0.255 area 0
network 10.34.0.3 0.0.0.255 area 0

 

Now PE-router4 and CE-router5 must similar to CE-router1 and PE-router2 with specific addressing. 

 

Hope it is useful

:-)

 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Here's the config of my P routers

I agree I should use something more dyunamic but MPLS is still configured in them

If I use OSPF , should I remove MPLS IP in the interface?

 


R2#show run
Building configuration...

Current configuration : 1619 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
ip tcp synwait-time 5
!
!
!
!
no ip domain lookup
!
mpls label range 2000 2999
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
ip address 23.23.23.1 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet4/0
no ip address
shutdown
duplex auto
speed auto
!
ip route 1.1.1.1 255.255.255.255 12.12.12.1
ip route 3.3.3.3 255.255.255.255 23.23.23.2
ip route 4.4.4.4 255.255.255.255 23.23.23.2
ip route 34.34.34.0 255.255.255.0 23.23.23.2
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
!
mpls ldp router-id Loopback0 force
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
webvpn context Default_context
ssl authenticate verify all
!
no inservice
!
!
end

 

----------------

 

 

 

 

Current configuration : 1619 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
ip tcp synwait-time 5
!
!
!
!
no ip domain lookup
!
mpls label range 3000 3999
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 23.23.23.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
ip address 34.34.34.1 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet4/0
no ip address
shutdown
duplex auto
speed auto
!
ip route 1.1.1.1 255.255.255.255 23.23.23.1
ip route 2.2.2.2 255.255.255.255 23.23.23.1
ip route 4.4.4.4 255.255.255.255 34.34.34.2
ip route 12.12.12.0 255.255.255.0 23.23.23.1
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
!
mpls ldp router-id Loopback0 force
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
webvpn context Default_context
ssl authenticate verify all
!
no inservice
!
!
end

 

 

 

 

 

 

Hi

The inconvenience is that LDP protocol is not being enabled on the PE and P routers, you need this protocol to enable the tagging. Please provide me your topology with the addressing in order to provide the configuration. 

 

Also the suggestion is use OSPF or ISIS into the Service Provider Infraestructure to deliver MPLS services. So the static routing should be removed.

 

 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Thanks for helping me out! 

Here's where I actually took this exemple:

http://resources.intenseschool.com/gns3-lab-introduction-to-mpls-layer-3-vpn-part-1/

 

Topology

CE ---(PE)R1-Fa0/0 --- Fa0/0- R2 -fa0/1  -----  fa0/0-R3- fa0/1 ------  fa0/0- R4 (PE) -Fa0/1 --- CE 

 

R1::
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0  (to R2)
ip address 12.12.12.1 255.255.255.0


interface FastEthernet0/1
ip vrf forwarding CUST-A
ip address 15.15.15.1 255.255.255.0

 

 

R2::

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0 (to R1)
ip address 12.12.12.2 255.255.255.0
mpls ip
!!
interface FastEthernet0/1 (to R3)
ip address 23.23.23.1 255.255.255.0

 

 

R3::


interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0 (to R2)
ip address 23.23.23.2 255.255.255.0
mpls ip
!

!
interface FastEthernet0/1 (to R4)
ip address 34.34.34.1 255.255.255.0

 

 

R4::


interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0 (to R3)
ip address 34.34.34.2 255.255.255.0
mpls ip
!

interface FastEthernet0/1
ip vrf forwarding CUST-A
ip address 46.46.46.1 255.255.255.0

 

Thank you Jean,

Im going to work on this and share the configuration.




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Bonjour Jean-François,

 

In addition to the things Julio pointed out, you are also missing a route distinguisher (RD) under vrf CUST-A on the PE R4.

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México


R1#show mpls forwarding-table
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
1000 Pop tag 2.2.2.2/32 0 Fa0/0 12.12.12.2
1001 2002 4.4.4.4/32 0 Fa0/0 12.12.12.2

1002 2003 34.34.34.0/24 0 Fa0/0 12.12.12.2
1003 Untagged 5.5.5.5/32[V] 0 Fa0/1 15.15.15.2
1004 Untagged 55.55.55.55/32[V] 0 Fa0/1 15.15.15.2
1005 Untagged 192.168.1.0/24[V] 0 Fa0/1 15.15.15.2
1006 Untagged 192.168.3.0/24[V] 0 Fa0/1 15.15.15.2

 

 

But there seems to be a problem with the other side:

 

When I try to add the vrf inside BGP, it accepts the commands but its not shwing into the run config


address-family ipv4 vrf CUST-A
neighbor 46.46.46.6 remote-as 65002
neighbor 46.46.46.6 activate
neighbor 46.46.46.6 as-override
no synchronization
exit-address-family

 


R4#show mpls forwarding-table
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
4000 3000 1.1.1.1/32 0 Fa0/0 34.34.34.1
4001 Pop tag 3.3.3.3/32 0 Fa0/0 34.34.34.1
4002 3003 12.12.12.0/24 0 Fa0/0 34.34.34.1

 

 

Here's the config


Current configuration : 2043 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
ip tcp synwait-time 5
!
!
!
!
ip vrf CUST-A
route-target export 65002:1
route-target import 65002:1
!
no ip domain lookup
!
mpls label range 4000 4999
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 34.34.34.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
ip vrf forwarding CUST-A
ip address 46.46.46.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet4/0
no ip address
shutdown
duplex auto
speed auto
!
router bgp 65001
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 65001
neighbor 1.1.1.1 update-source Loopback0
!
address-family ipv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 next-hop-self
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community extended
exit-address-family
!
ip route 1.1.1.1 255.255.255.255 34.34.34.1
ip route 3.3.3.3 255.255.255.255 34.34.34.1
ip route 12.12.12.0 255.255.255.0 34.34.34.1
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
!
mpls ldp router-id Loopback0 force
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
webvpn context Default_context
ssl authenticate verify all
!
no inservice
!
!
end

 

 

 

Hi

Your config should be like:

CE-Router1  ------ PE-Router2 ------ P-Router3------ PE-router4 -------CE-router5

 

CE-Router 1

 

interface loopback 0
ip address 1.1.1.1 255.255.255.255

 

interface loopbak 1
ip address 11.11.11.1 255.255.255.0

 

interface fa0/0
description TO-PE-ROUTER-2
ip address 15.15.15.2 255.255.255.0
no shutdown

 

router bgp 100
no sync
no au
neighbor 15.15.15.1 remote 777
network 1.1.1.1 mask 255.255.255.255
network 11.11.11.0 mask 255.255.255.0

 

PE-Router-2

 

ip vrf CUST-A
rd 65002:1
route-target export 65002:1
route-target import 65002:1

 

interface loopback 0
ip address 2.2.2.2 255.255.255.255

 

mpls ldp router-id loopback 0

 

interface fa0/0
description TO-CE-ROUTER-1
ip vrf forward CUST-A
ip address 15.15.15.1 255.255.255.0
no shutdown

 

interface fa0/1
description TO-P-ROUTER-3
ip address 10.23.0.2 255.255.255.0
no shutdown

 

router ospf 100
mpls ldp auto
network 2.2.2.2 0.0.0.0 area 0
network 10.23.0.2 0.0.0.255 area 0

 

router bgp 777
no sync
no au
neighbor 4.4.4.4 remote 777
neighbor 4.4.4.4 update-source loopback0
address-family vpnv4 
neighbor 4.4.4.4 activate
address-family vrf CUST-A
neighbor 15.15.15.2 remote 100
neighbor 15.15.15.2 activate
neighbor 15.15.15.2 as-overide (If the other CE is using AS 100 as well)

 

 

 

P-Router 3


interface loopback 0
ip address 3.3.3.3 255.255.255.255

 

mpls ldp router-id loopback 0

 

interface fa0/1
description TO-PE-ROUTER2
ip address 10.23.0.3 255.255.255.0
no shutdown

 

interface fa0/0
description TO-PE-ROUTER4
ip address 10.34.0.3 255.255.255.0
no shutdown

 

router ospf 100
mpls ldp auto
network 3.3.3.3 0.0.0.0 area 0
network 10.23.0.3 0.0.0.255 area 0
network 10.34.0.3 0.0.0.255 area 0

 

Now PE-router4 and CE-router5 must similar to CE-router1 and PE-router2 with specific addressing. 

 

Hope it is useful

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Jean-François,

 

You are still missing the RD under the VRF config.

 

ip vrf CUST-A

rd xxx:xxx
route-target export 65002:1
route-target import 65002:1
!

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card