cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
11204
Views
0
Helpful
2
Replies

NAT using loopback interface

kenneth-goh
Level 1
Level 1

I have a requirement as shown in the diagram. When R1ping to loopback0 on R2 and R3 will reply to the ping.

I am not allow to change the ip nat inside (on Fa0/0) and ip nat outside (on Fa1/0) on R2. Thanks in advanced.

screenshot - Copy.png

 

2 Replies 2

Hi

If you want to use the R2's loopback to translate your R1's LANs try with

 

R2

 

ip access-list standard MY-NETS

permit 192.168.0.0 0.0.0.255  <-- example R1's LAN

 

interface loopback 0

ip address 10.247.254.56 255.255.255.255 

 

int fa0/0

description P2P-R1

ip nat inside

 

interface f1/0

description TO-R2-R3

ip nat outside

 

ip nat inside source list MY-NETS interface loopback 0 overload

 

ip route 0.0.0.0 0.0.0.0 fa1/0 name INTERNET   <--- Example

 

R3 & R4

 

configure:

ip route 10.247.254.56 255.255.255.255 10.245.16.1

 

 

Now you can verify the translations on R2 using a debug: debug ip nat or using show ip nat translations

 

Hope it is useful

:-)

 

 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

 

On R1

R1# ping 10.247.254.56 <-- R2's loopback is not translating to R3's 10.245.16.20

On R2

interface Loopback1
 ip address 10.247.254.56 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.250.21.21 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface FastEthernet1/0
 ip address 10.245.16.1 255.255.255.0
 ip nat outside
 ip virtual-reassembly

 

ip nat inside source list NAT interface Loopback1 overload
!
ip access-list standard NAT
 permit 10.250.21.20

 

Review Cisco Networking for a $25 gift card