cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
613
Views
0
Helpful
7
Replies

New connections ICMP - ARP

CobbyJ
Beginner
Beginner

Hello All.

 

There seems to be some strange things going on, when we connect a new device such as a laptop or server to our 3750 we cant ping it for a while from another device, but as soon as we try to ping it direct from the 3750 it starts to work.

 

I think it has something to do with an ARP table but not sure.

 

Any advice?

 

Kind Regards,

Chris

 

 

7 Replies 7

Jaderson Pessoa
VIP Alumni
VIP Alumni
Hello,

What address from both end devices? It is on the same Network? The firewall at both ends are disabled? What configuration under port that connect both device?

since you answer these simple question we can provide a solution or explanation for you :)
Jaderson Pessoa
*** Rate All Helpful Responses ***

balaji.bandi
Hall of Fame
Hall of Fame

Can you provide more information, where this device connected has lag of ping - what port and switch it was connected and show ip arp table on both the switches ?

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Yes so for example i have a 3750 switch and i connect a laptop to port 1 and another to port 2 and they cant ping each each other for a good while until i try to ping them from the 3750 directly and then they can communicate.

 

they are using 10.20.30.0/24 subnet on the same vlan.

 

I think its to do with the ARP table. once they start to ping each other its fine.

 

Im wondering if there is some kind of ARP update interval settings i need?

we have requested to provide the Switch configuration, since we are not sure what kind of config you have implemented.

 

Other suggestion, is the port  configured PVST (i mean portfast)?

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

 

What is a “good while” ?

 

If you are talking around a minute or so have you enabled portfast on the ports ?

 

Jon

It can take around 5 minutes to start to ping or even longer until i entiate a ping from the switch

 

Attaches my config - nothing overly special - not using portfast because it does the same if i put LAPTOP-2 in a access switch.

 

Never seen this before.

 

Building configuration...

Current configuration : 3102 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log datetime
no service password-encryption
service sequence-numbers
!
hostname 3750-12
!
!
no aaa new-model
switch 1 provision ws-c3750g-24ts
ip subnet-zero
!
!
!
!
!
!
no errdisable detect cause loopback
errdisable recovery cause loopback
errdisable recovery interval 60
port-channel load-balance src-dst-mac
no file verify auto
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
interface Port-channel1
 description HSRP-3750-13
 no switchport
 ip address 10.0.0.1 255.255.255.0
 standby 1 ip 10.0.0.3
 standby 1 priority 110
 standby 1 preempt
 standby 2 ip 10.0.0.4
 standby 2 preempt
!
interface Port-channel2
 description 3750-13
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree portfast trunk
!
interface GigabitEthernet1/0/1
 description HSRP-3750-13-P1
 no switchport
 no ip address
 channel-group 1 mode active
!
interface GigabitEthernet1/0/2
 description HSRP-3750-13-P2
 no switchport
 no ip address
 channel-group 1 mode active
!
interface GigabitEthernet1/0/3
 description 3750-13-P3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 2 mode active
 spanning-tree portfast trunk
!
interface GigabitEthernet1/0/4
 description 3750-13-P4
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 2 mode active
 spanning-tree portfast trunk
!
interface GigabitEthernet1/0/5
 description 2950-LAB-P1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/6
 description LAPTOP-1
 switchport access vlan 10
 switchport mode access
!
interface GigabitEthernet1/0/7
 description LAPTOP-2
 switchport access vlan 10
 switchport mode access
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
 switchport access vlan 99
 switchport trunk encapsulation dot1q
 switchport mode access
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address 10.20.40.252 255.255.255.0 secondary
 ip address 10.20.30.252 255.255.255.0
 standby 10 ip 10.20.30.1
 standby 10 timers msec 333 1
 standby 10 priority 200
 standby 10 preempt
 standby 40 ip 10.20.40.1
 standby 40 timers msec 333 1
 standby 40 priority 200
 standby 40 preempt
!
interface Vlan99
 ip address 10.10.10.2 255.255.255.0
!
ip classless
ip http server
ip http secure-server
!
!
!
control-plane

Hello,

Can you please provide additional information:

1. In "broken" state, where laptops are connected, but ping doesn't work, can you check following:

a) do you see MAC addresses of both Laptops on respective interfaces on switch?

b) do you try to ping only from one laptop to another, or vice-versa as well?

c) do you see ARP entries for "peer laptop" on both LAPTOPS or not?

d) Can you check, where exactly packets are dropped (ICMP requests or replies)? By performing capture on laptops, or SPAN from switch and also by checking interface counters.

 

In general, if everything is configured correctly, this behavior looks weird. Could be a bug, or transient issue.

 

There was a bug CSCvb78700 with similar symptoms, but for 4500 platform, related to incorrect hardware unknown unicast floodset. If one of the Laptops is "silent" before ping - doesn't generate any traffic, than switch doesn't know it's MAC. If you initiate ping from another Laptop, switch should flood this packet to all the ports in this VLAN, except receiving port. This operation is done in hardware (ASIC). List of such ports is programmed into hardware (ASIC). If, for some reason, this list is not correct, that unknown unicast traffic will not be flooded.

 

When you initiate ping from switch, this traffic is generated in software (by CPU), and it uses unknown unicast floodset list on it's own, software layer. Once Laptop replies, MAC address is learned and subsequent pings between laptops work. 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: