cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
699
Views
3
Helpful
4
Replies
Highlighted

OSPF-RIP redistribution limited

Hello! I have just configured three cisco routers with OSPF areas 0 and 1. One router in area 0 also has a RIP link to a soho router for WAN access. I have interconnectivity between all three routers through OSPF. I can also reach the soho through the RIP link from all three routers. My problem is that the router running RIP shows the public IP from my soho on RIP, has the default-gateway set properly, but my other two routers are not picking up the default gateway and they can't reach the public IP even though they can reach the soho. With a previous eigrp setup, the default gateway was inherited by router 2 and 1. I have pasted my run configs and some extra info. Any enlightenment is appreciated!

R3 - directly connected to a soho e1000 through an AUI for e0

ip subnet-zero

ip domain-name white.com

ip name-server 68.105.28.11

!

interface Loopback0

ip address 3.3.3.3 255.255.255.255

!

interface Ethernet0

ip address 192.168.2.2 255.255.255.0

ip rip send version 2

ip rip receive version 2

bandwidth 10000000

!

interface Serial0

ip address 192.168.0.2 255.255.255.252

no fair-queue

!

interface Serial1

no ip address

shutdown

!

router ospf 100

redistribute rip

network 192.168.0.0 0.0.0.3 area 0

!

router rip

version 2

redistribute static

redistribute ospf 100

network 192.168.2.0

default-metric 1

!

no ip classles

Gateway of last resort is 192.168.2.1 to network 0.0.0.0

     3.0.0.0/32 is subnetted, 1 subnets

C       3.3.3.3 is directly connected, Loopback0

     10.0.0.0/24 is subnetted, 1 subnets

O IA    10.0.0.0 [110/66] via 192.168.0.1, 00:24:48, Serial0

     98.0.0.0/22 is subnetted, 1 subnets

R       98.164.4.0 [120/1] via 192.168.2.1, 00:00:13, Ethernet0

     192.168.0.0/30 is subnetted, 2 subnets

C       192.168.0.0 is directly connected, Serial0

O       192.168.0.4 [110/65] via 192.168.0.1, 00:24:49, Serial0

C    192.168.2.0/24 is directly connected, Ethernet0

R*   0.0.0.0/0 [120/1] via 192.168.2.1, 00:00:13, Ethernet0

R2 - direct serial connection to R3, FA to R1

ip domain name white.com

ip name-server 68.105.28.11

!

ip cef

!

!

interface FastEthernet0/0

ip address 192.168.0.6 255.255.255.252

duplex auto

speed auto

!

interface Serial1/0

bandwidth 10000000

ip address 192.168.0.1 255.255.255.252

clockrate 64000

!

interface Serial1/1

no ip address

shutdown

!

interface Serial1/2

no ip address

shutdown

!

interface Serial1/3

no ip address

shutdown

!

router ospf 100

router-id 2.2.2.2

log-adjacency-changes

network 192.168.0.0 0.0.0.3 area 0

network 192.168.0.4 0.0.0.3 area 0

!

ip http server

no ip http secure-server

ip classless

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets

O IA    10.0.0.0 [110/2] via 192.168.0.5, 00:27:00, FastEthernet0/0

     192.168.0.0/30 is subnetted, 2 subnets

C       192.168.0.0 is directly connected, Serial1/0

C       192.168.0.4 is directly connected, FastEthernet0/0

O E2 192.168.2.0/24 [110/20] via 192.168.0.2, 00:27:00, Serial1/0

R1 - running area 0 to R2, and an area 1 for a switch group - just for experimentation

ip domain name white.com

ip name-server 68.105.28.11

ip dhcp excluded-address 10.0.0.1 10.0.0.4

!

ip dhcp pool home

   network 10.0.0.0 255.255.255.0

   default-router 10.0.0.1

   dns-server 68.105.29.12

!

interface FastEthernet0/0

ip address 192.168.0.5 255.255.255.252

duplex auto

speed auto

!

interface Serial0/0

no ip address

shutdown

no fair-queue

!

interface FastEthernet0/1

ip address 10.0.0.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1.1

!

interface FastEthernet0/1.2

!        

router ospf 100

router-id 1.1.1.1

log-adjacency-changes

network 10.0.0.0 0.0.0.255 area 1

network 192.168.0.4 0.0.0.3 area 0

!

ip http server

ip classless

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets

C       10.0.0.0 is directly connected, FastEthernet0/1

     192.168.0.0/30 is subnetted, 2 subnets

O       192.168.0.0 [110/2] via 192.168.0.6, 00:29:27, FastEthernet0/0

C       192.168.0.4 is directly connected, FastEthernet0/0

O E2 192.168.2.0/24 [110/20] via 192.168.0.6, 00:29:27, FastEthernet0/0

**********Ping tests end to end*************

R1#ping 192.168.2.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/32/36 ms

R1#ping 98.164.4.240

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 98.164.4.240, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

R3#ping 98.164.4.240

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 98.164.4.240, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/8 ms

R3#ping 68.105.28.11

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 68.105.28.11, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 16/17/20 ms

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Hi,

yes you will have to propagate the default-route into OSPF on the ASBR with the OSPF procees command:

default-information originate

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

View solution in original post

4 REPLIES 4
Highlighted
Beginner

I'm an EIGRP guy by trade, but I have a theory. Is OSPF happy with redistribution without specifying a metric?

Sent from Cisco Technical Support iPad App

Highlighted

Thank you for the suggestion -- I looked up the specs and ospf uses a default metric of 20 and assigns a type 2 when not designated. I went back and assigned a metric of 1 and it still didn't make a different.

What is confusing me is that I can ping from my ospf interface on r3 to the public IP, so the redistribution from RIP to OSPF is working. Plus, the other OSPF routers are finding the soho that connects to the public IP, so the redistribute is reaching them.

I'm wondering if I have to manually set the default-gateway on area-border routers -- which wouldn't make OSPF as easy as EIGRP to manage.

Highlighted

Hi,

yes you will have to propagate the default-route into OSPF on the ASBR with the OSPF procees command:

default-information originate

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

View solution in original post

Highlighted

Thank you Alain, that definitely did the trick. I take the CCNA composite tomorrow and there is no way I could have focused on the fundamentals with that mystery hanging in my brain.

Content for Community-Ad