cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2508
Views
0
Helpful
12
Replies
Highlighted
Beginner

Packet loss on sub interface

Hi guys,

I have a serious problem (see attached topology)

From R1 and R2 i can ping subunterface 10.222.180.1 on R3 but with packet losses ,but i can ping the rest subinterfaces 100%.

Also from R3 i receive packet losses when i ping 10.222.180.1( which is a subinterface on it).

I tried to isolate the problem as follows;

i did put laptops on both ends of the transmission equipment and the pings were going 100% ,but with laptop on site A ,i get losses reaching 10.222.180.1 ,but with laptop on site B ,i can reach 100% on site A (10.222.180.4 and .3).

I have checked interfaces for errors ,routing issues without success.

Does any of you have an ideal what this could be?

12 REPLIES 12
Highlighted
Advisor

   I would check your trunking setup on both the  router and the switch it goes thru, sounds like something isn't quite right.  If you can post both setups we could take a look at it   along with a show vlan from the switch.

Highlighted

The switch on SITE A has no vlan configured.

configs of switch on SITE B are down below;

##############################################################################

R3#show interfaces gigabitEthernet 0/0
GigabitEthernet0/0 is up, line protocol is up
  Hardware is MV96340 Ethernet, address is 0026.0b58.1f80 (bia 0026.0b58.1f80)
  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
     reliability 255/255, txload 12/255, rxload 2/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  1., loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is T
  output flow-control is XON, input flow-control is XON
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 2/150/18816/0 (size/max/drops/flushes); Total output drops: 23192149
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 8215000 bits/sec, 7761 packets/sec
  5 minute output rate 47727000 bits/sec, 9473 packets/sec
     2610227509 packets input, 2916520944 bytes, 7 no buffer
     Received 39744221 broadcasts, 1 runts, 0 giants, 1219 throttles
     300234 input errors, 1 CRC, 0 frame, 0 overrun, 300232 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     1486910548 packets output, 365181245 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     81003 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 151 pause output
     0 output buffer failures, 0 output buffers swapped out
R3

############################################################################################

R3#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         unassigned      YES NVRAM  up                    up     
GigabitEthernet0/0.178     10.222.178.1    YES NVRAM  up                    up     
GigabitEthernet0/0.179     10.222.179.1    YES NVRAM  up                    up     
GigabitEthernet0/0.180     10.222.180.1    YES manual up                    up     
GigabitEthernet0/0.181     10.222.181.1    YES NVRAM  up                    up     
GigabitEthernet0/0.183     10.1.32.82      YES NVRAM  up                    up     
GigabitEthernet0/0.190     unassigned      YES unset  deleted               down   
GigabitEthernet0/1         10.77.231.10    YES NVRAM  up                    up     
FastEthernet0/1/0          10.1.32.86      YES manual up                    up     
SSLVPN-VIF0                unassigned      NO  unset  up                    up     
R3#

############################################################################################

R3#show interfaces switchport ?
  module  Limit display to interfaces on module
  |       Output modifiers
 

R3#show interfaces switchport

############################################################################################

Switch configs

SITE B_switch#show interfaces switchport

----output cut----

#########################################################################################
Name: Gi1/0/21
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: On
Access Mode VLAN: 180 (VLAN0180)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

Name: Gi1/0/22
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: down
Administrative Trunking Encapsulation: negotiate
Negotiation of Trunking: On
Access Mode VLAN: 180 (VLAN0180)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

Name: Gi1/0/23
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: On
Access Mode VLAN: 180 (VLAN0180)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

Name: Gi1/0/24
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: down
Administrative Trunking Encapsulation: negotiate
Negotiation of Trunking: On
Access Mode VLAN: 180 (VLAN0180)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

Name: Gi1/0/25
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: down
Administrative Trunking Encapsulation: negotiate
Negotiation of Trunking: On
Access Mode VLAN: 180 (VLAN0180)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

Name: Gi1/0/26
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: down
Administrative Trunking Encapsulation: negotiate
Negotiation of Trunking: On
Access Mode VLAN: 180 (VLAN0180)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

Name: Gi1/0/27
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: down
Administrative Trunking Encapsulation: negotiate
Negotiation of Trunking: On
Access Mode VLAN: 180 (VLAN0180)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

Name: Gi1/0/28
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: down
Administrative Trunking Encapsulation: negotiate
Negotiation of Trunking: On
Access Mode VLAN: 180 (VLAN0180)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

Name: Gi1/0/29
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: down
Administrative Trunking Encapsulation: negotiate
Negotiation of Trunking: On
Access Mode VLAN: 180 (VLAN0180)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

Name: Gi1/0/30
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: down
Administrative Trunking Encapsulation: negotiate
Negotiation of Trunking: On
Access Mode VLAN: 180 (VLAN0180)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none
#########################################################################################

SITEB_switch#show ip interface brief

GigabitEthernet1/0/21  unassigned      YES unset  up                    up     
GigabitEthernet1/0/22  unassigned      YES unset  down                  down   
GigabitEthernet1/0/23  unassigned      YES unset  up                    up     
GigabitEthernet1/0/24  unassigned      YES unset  down                  down   
GigabitEthernet1/0/25  unassigned      YES unset  down                  down   
GigabitEthernet1/0/26  unassigned      YES unset  down                  down   
GigabitEthernet1/0/27  unassigned      YES unset  down                  down   
GigabitEthernet1/0/28  unassigned      YES unset  down                  down   
GigabitEthernet1/0/29  unassigned      YES unset  down                  down   
GigabitEthernet1/0/30  unassigned      YES unset  down                  down   
#######################################################################################

SITEB_switch#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi1/0/2, Gi1/0/47, Gi1/0/48, Gi1/0/49, Gi1/0/50, Gi1/0/51, Gi1/0/52
2    VLAN0002                         active   
178  VLAN0178                         active    Gi1/0/3, Gi1/0/4, Gi1/0/5, Gi1/0/6, Gi1/0/7, Gi1/0/8, Gi1/0/9, Gi1/0/10
179  VLAN0179                         active    Gi1/0/11, Gi1/0/12, Gi1/0/13, Gi1/0/14, Gi1/0/15, Gi1/0/16, Gi1/0/17, Gi1/0/18, Gi1/0/19

180  VLAN0180                         active    Gi1/0/21, Gi1/0/22, Gi1/0/23, Gi1/0/24, Gi1/0/25, Gi1/0/26, Gi1/0/27, Gi1/0/28, Gi1/0/29, Gi1/0/30

181  VLAN0181                         active    Gi1/0/31, Gi1/0/32, Gi1/0/33, Gi1/0/34, Gi1/0/35, Gi1/0/36, Gi1/0/37, Gi1/0/38, Gi1/0/39, Gi1/0/40
183  SBG-VOIP                         active    Gi1/0/20
441  VLAN0441                         active    Gi1/0/41, Gi1/0/42
443  VLAN0443                         active    Gi1/0/43, Gi1/0/44
445  VLAN0445                         active    Gi1/0/45, Gi1/0/46
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0  
2    enet  100002     1500  -      -      -        -    -        0      0  
178  enet  100178     1500  -      -      -        -    -        0      0  
179  enet  100179     1500  -      -      -        -    -        0      0  
180  enet  100180     1500  -      -      -        -    -        0      0  
181  enet  100181     1500  -      -      -        -    -        0      0  
183  enet  100183     1500  -      -      -        -    -        0      0  
441  enet  100441     1500  -      -      -        -    -        0      0  
443  enet  100443     1500  -      -      -        -    -        0      0  
445  enet  100445     1500  -      -      -        -    -        0      0  
1002 fddi  101002     1500  -      -      -        -    -        0      0  
1003 tr    101003     1500  -      -      -        -    srb      0      0  
1004 fdnet 101004     1500  -      -      1        ieee -        0      0  
1005 trnet 101005     1500  -      -      1        ibm  -        0      0 

Remote SPAN VLANs
------------------------------------------------------------------------------

Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

####################################################################################################

ping results

from site A R1 to R3

R1#ping 10.222.180.1 repeat 100

Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 41.222.180.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!..!!.!!!!!!!!!!!!!!!!!!!!!!!!!!.!!!!!!..!!!!!!.!..!!
!!!!!!!.!!.!!!!!!!!!!!!!!!!!!!
Success rate is 89 percent (89/100), round-trip min/avg/max = 1/3/8 ms

from R2 to R3

R2#ping 10.222.180.1 repeat 100

Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 41.222.180.1, timeout is 2 seconds:
..!!!.!!!.!.!!!!!..!!!!.!!!.!!!!!!!!!!!!!!!!!!!!.!!!!!!!!!!!!!!!!!!!!!
.!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 89 percent (89/100), round-trip min/avg/max = 1/3/4 ms
R2#

from R2 to R3


Tigo-FranceTel#ping 41.222.180.3 repeat 100

Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 41.222.180.3, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 1/1/4 ms

from R3 to R1

R3#ping 10.222.180.3 repeat 100

Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 41.222.180.3, timeout is 2 seconds:
!!..!!!!!!!!!!!!!!!.!!!!!!!!!!!!!!!!!.!!!!!!!!.!!!!!!!!!!!!!!!!!!!!!!!
!!!!.!!!!.!.!!!!!!!!!!!!!!!!!!
Success rate is 92 percent (92/100), round-trip min/avg/max = 1/3/4 ms

from R3 to R2

R3#ping 10.222.180.4 repeat 100

Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 41.222.180.4, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 1/3/8 ms
R3#ping 41.222.180.4 repeat 100

Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 41.222.180.4, timeout is 2 seconds:
!!!!!!!!.!.!.!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 97 percent (97/100), round-trip min/avg/max = 1/3/20 ms

whew!

Highlighted

Hi,

configure this:

ip access-list extended ICMP_ECHO

permit icmp any host 10.222.180.1 echo

ip access-list extended ICMP_ECHOREPLY

permit icmp host 10.222.180.1 any  echo-reply

class-map ICMP_RECEIVED

match access-group  name  ICMP_ECHO

policy-map ICMP_RECEIVED

class  ICMP_RECEIVED

class-map ICMP_SENT

match access-group  name  ICMP_ECHOREPLY

policy-map ICMP_SENT

class  ICMP_SENT

int g0/0.180

service-policy input  ICMP_RECEIVED

service-policy output ICMP_SENT

do your ping to R3 subinterface and post output of show policy-map interface g0/0.180

Regards.

Alain.

Don't forget to rate helpful posts.
Highlighted

R3 out put:

R3#show policy-map interface g0/0.180
GigabitEthernet0/0.180

  Service-policy input: ICMP_RECEIVED

    Class-map: ICMP_RECEIVED (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps
      Match: access-group name ICMP_ECHO

    Class-map: class-default (match-any)
      31173 packets, 9197743 bytes
      5 minute offered rate 205000 bps, drop rate 0 bps
      Match: any

  Service-policy output: ICMP_SENT

    Class-map: ICMP_SENT (match-all)
      800 packets, 91200 bytes
      5 minute offered rate 0 bps
      Match: access-group name ICMP_ECHOREPLY

    Class-map: class-default (match-any)
      38665 packets, 28136623 bytes
      5 minute offered rate 581000 bps, drop rate 0 bps
      Match: any

Highlighted

Hi,

from where you pinged ther is VLAN1 only? so apply policy-map ICMP_RECEIVED to main gig interface and clear counters command in privileged mode then ping from each router rep 100  then show same output as before but on main interface and subinterface for each router ping  and before next router ping clear counters.

Regards.

Alain.

Don't forget to rate helpful posts.
Highlighted

Here we go.

from where you pinged ther is VLAN1 only? YES

#######################################################################################
R1#ping 10.222.180.1 repeat 100

Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 41.222.180.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 1/3/4 ms


R3#show policy-map interface gigabitEthernet 0/0
GigabitEthernet0/0

  Service-policy input: ICMP_RECEIVED

    Class-map: ICMP_RECEIVED (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps
      Match: access-group name ICMP_ECHO

    Class-map: class-default (match-any)
      865312 packets, 103590590 bytes
      5 minute offered rate 4477000 bps, drop rate 0 bps
      Match: any


R3#show policy-map interface gigabitEthernet 0/0.180
GigabitEthernet0/0.180

  Service-policy output: ICMP_SENT

    Class-map: ICMP_SENT (match-all)
      100 packets, 11400 bytes
      5 minute offered rate 0 bps
      Match: access-group name ICMP_ECHOREPLY

    Class-map: class-default (match-any)
      20494 packets, 13630786 bytes
      5 minute offered rate 741000 bps, drop rate 0 bps
      Match: any


#######################################################################################
R3#clear counters gigabitEthernet 0/0              
Clear "show interface" counters on this interface [confirm]


R2#ping 41.222.180.1 repeat 100

Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 41.222.180.1, timeout is 2 seconds:
!!!!!!.!!!.!!!!!!!!!!!!!!!!!!!!!!!!!!!.!!!!!.!!!..!!!!..!.!!!!!!!!!.!!
!.!!!!!!.!!!!!!.!!.!!!!!!!!!.!
Success rate is 85 percent (85/100), round-trip min/avg/max = 1/3/8 ms

R3#show policy-map interface gigabitEthernet 0/0   
GigabitEthernet0/0

  Service-policy input: ICMP_RECEIVED

    Class-map: ICMP_RECEIVED (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps
      Match: access-group name ICMP_ECHO

    Class-map: class-default (match-any)
      858972 packets, 109679804 bytes
      5 minute offered rate 5794000 bps, drop rate 0 bps
      Match: any


R3#show policy-map interface gigabitEthernet 0/0.180
GigabitEthernet0/0.180

  Service-policy output: ICMP_SENT

    Class-map: ICMP_SENT (match-all)
      100 packets, 11400 bytes
      5 minute offered rate 0 bps
      Match: access-group name ICMP_ECHOREPLY

    Class-map: class-default (match-any)
      33717 packets, 21946418 bytes
      5 minute offered rate 964000 bps, drop rate 0 bps
      Match: any
#######################################################################################

Highlighted

Hi,

I have just added another router R4 10.222.180.7

i can ping 10.222.180.1 100% ,as well as 10.222.180.3 and 10.222.180.4

From R1(10.222.180.4) i can reach 10.222.180.7 100% (though it stucks stucks)

..............

Highlighted

new topology

Highlighted

  Please post the port config of the the switch that connects to R3 , it should look  like below.  You should also setup the switch for site a in the correct vlan it would make it a lot easier to troubleshoot if everything is in its correct vlan instead of trying to translate a switch that is all in vlan 1 connected to a port in vlan 180 etc...  If your trunking port does not look like this , try it and report back..

gx/x/x   --- port to R3

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 178,179,180,181

switchport mode trunk

switchport nonegotiate

Also can you explain the below display it says ping 10.222.180.3  but just below that it says  41.222.180.3  , assume its just a typing error or something. All your ping examples show the same thing.

R3#ping 10.222.180.3 repeat 100

Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 41.222.180.3, timeout is 2 seconds:
!!..!!!!!!!!!!!!!!!.!!!!!!!!!!!!!!!!!.!!!!!!!!.!!!!!!!!!!!!!!!!!!!!!!!
!!!!.!!!!.!.!!!!!!!!!!!!!!!!!!
Success rate is 92 percent (92/100), round-trip min/avg/max = 1/3/4 ms

Highlighted

SITEB_switch#show interfaces Gi1/0/1 switchport
Name: Gi1/0/1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none
3G_switch#

Highlighted
Advisor

Hi,

all the pings were received by the router( even though there was no match on the class-map but there was 100 matches on the replies) so there is surely something in between R3 and the routers that is dropping some packets or maybe the routers themselves.

It should be interesting to count the echo-replies on the originating routers with MQC like he did on R3.

Is there a pattern with the drops and the MQC counting ?

Regards.

Alain.

Don't forget to rate helpful posts.
Highlighted
Beginner

Hi Guys,

I got the solution,

there was a command rate-limit configured on the subinterface. It was the one causing problems, after i removed it ,everything is fine now.

Thanks for your assistance.

Content for Community-Ad