03-16-2021 05:51 PM
Hi all,
I have a network that has 1 router, 3 switches, and 3 PCs, as per the photo attached. My issue is that I have my PC-A that can ping the default gateway. that is a sub interface on the router. Whenever I ping another PC's IP address, it gets to the router but it just sits there until it runs out of time. To add to that, my PC-B and PC-C cannot ping their default gateway (sub interface) at all on the router. Whenever I try to ping the default gateway from either, the pings buffer and never go anywhere. I do have a default gateway set on the switches to their respective VLAN sub interface on the router, and those pings work. I have the PCs on all different VLANs and I have each of those connections set as access for switchport. I am just confused as to why I am not getting any traffic sent out from the PC-B and PC-C.
Any help is appreciated!
Solved! Go to Solution.
03-17-2021 08:34 AM
Hello,
you need to create all VLANs on all switches. Attached the working file...
03-16-2021 05:59 PM - edited 03-16-2021 06:00 PM
Hi,
Can you check to make sure the vlan that PC-B and PC-C are part of added to the trunk port of all switches?
If this did not help, can you post "sh run" from the s2 and s3 switch and point out the interfaces where the PCs are connected?
Also, can you make sure the firewall software on the PCs is not blocking ICMP traffic?
HTH
03-16-2021 06:09 PM
The vlan is added on all ports already. The firewall on all the PCs are already off.
The configuration from S2:
hostname S2
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface Port-channel2
switchport trunk native vlan 90
switchport trunk allowed vlan 10,20,30,90
switchport mode trunk
!
interface Port-channel3
!
interface FastEthernet0/1
switchport trunk native vlan 90
switchport trunk allowed vlan 10,20,30,90
switchport mode trunk
channel-group 2 mode active
!
interface FastEthernet0/2
switchport trunk native vlan 90
switchport trunk allowed vlan 10,20,30,90
switchport mode trunk
channel-group 2 mode active
!
interface FastEthernet0/3
channel-group 3 mode on
!
interface FastEthernet0/4
channel-group 3 mode on
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18 (PC-B connected)
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan20
no ip address
!
interface Vlan90
ip address 172.27.90.11 255.255.255.0
!
ip default-gateway 172.27.90.1
The configuration for S3:
hostname S3
!
!
!
no ip domain-lookup
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface Port-channel1
switchport trunk native vlan 90
switchport trunk allowed vlan 10,20,30,90
switchport mode trunk
!
interface Port-channel3
!
interface FastEthernet0/1
channel-group 3 mode on
!
interface FastEthernet0/2
channel-group 3 mode on
!
interface FastEthernet0/3
switchport trunk native vlan 90
switchport trunk allowed vlan 10,20,30,90
switchport mode trunk
channel-group 1 mode desirable
!
interface FastEthernet0/4
switchport trunk native vlan 90
switchport trunk allowed vlan 10,20,30,90
switchport mode trunk
channel-group 1 mode desirable
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18 (PC-C)
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan30
no ip address
!
interface Vlan90
ip address 172.27.90.12 255.255.255.0
!
ip default-gateway 172.27.90.1
03-16-2021 11:29 PM
can you post router and s1 config ?
03-17-2021 06:26 AM
The config for R1:
hostname R1
!
no ip domain-lookup!
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1.10
encapsulation dot1Q 10
ip address 172.27.10.1 255.255.255.0
!
interface GigabitEthernet0/1.20
encapsulation dot1Q 20
ip address 172.27.20.1 255.255.255.0
!
interface GigabitEthernet0/1.30
encapsulation dot1Q 30
ip address 172.27.30.1 255.255.255.0
!
interface GigabitEthernet0/1.90
encapsulation dot1Q 90
ip address 172.27.90.1 255.255.255.0
!
!
interface Vlan1
no ip address
shutdown
!
The config for S1:
hostname S1
!
no ip domain-lookup
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface Port-channel1
switchport trunk native vlan 90
switchport trunk allowed vlan 10,20,30,90
switchport mode trunk
!
interface Port-channel2
switchport trunk native vlan 90
switchport trunk allowed vlan 10,20,30,90
switchport mode trunk
!
interface FastEthernet0/1
switchport trunk native vlan 90
switchport trunk allowed vlan 10,20,30,90
switchport mode trunk
channel-group 2 mode passive
!
interface FastEthernet0/2
switchport trunk native vlan 90
switchport trunk allowed vlan 10,20,30,90
switchport mode trunk
channel-group 2 mode passive
!
interface FastEthernet0/3
switchport trunk native vlan 90
switchport trunk allowed vlan 10,20,30,90
switchport mode trunk
channel-group 1 mode auto
!
interface FastEthernet0/4
switchport trunk native vlan 90
switchport trunk allowed vlan 10,20,30,90
switchport mode trunk
channel-group 1 mode auto
!
interface FastEthernet0/5
switchport trunk allowed vlan 10,20,30,90
switchport mode trunk
!
interface FastEthernet0/6 (Connected to PC-A)
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
no ip address
!
interface Vlan90
ip address 172.27.90.10 255.255.255.0
!
ip default-gateway 172.27.90.1
03-17-2021 07:09 AM - edited 03-17-2021 07:10 AM
Since vlan 90 is your native vlan on the switches, do the same on the router and make it native.
interface GigabitEthernet0/1.90
encapsulation dot1Q 90 native
ip address 172.27.90.1 255.255.255.0
and test.
HTH
03-17-2021 07:25 AM
03-17-2021 08:34 AM
03-17-2021 08:48 AM
It works, thank you so much for the help!
03-17-2021 02:04 AM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide