cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
383
Views
0
Helpful
4
Replies

Port channel setup

wwwillster07
Beginner
Beginner

I have 2 Cisco switches connected via a two port port-channel. No issue. I’ve been tasked with connecting these to a pair of HP switches which are connected via a  two port port-channel. 
What’s the best way to do this without creating a loop?  Clearly it’s gonna be an LACP link. Can I use one port on each Cisco switch in the same linkagg and ie port in each switch on the HP side and cable them up?  Thanks 

4 Replies 4

balaji.bandi
Hall of Fame
Hall of Fame

Can you make a small diagram of how you connect each device, how is your network?

where do you think STP loops?

The Loop only happens on Layer 2 if the VLAN traverse from another port channel,  If you restrict VLAN  or split the VLAN each port-channel there is no loop, and avoided here.

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Huge delay on my end sorry about that....and thanks in advance

Po2 is the newly configured port channel since we don't have fiber, it's eight 1 gig copper connections.  Hopefully i copied and pasted all correctly.  Both switches on my side show the Po2 up and 33/34 are up but:

GigabitEthernet0/35 unassigned YES unset up down
GigabitEthernet0/36 unassigned YES unset up down

SW1

interface Port-channel1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1-899,901-4094
switchport mode trunk
!
interface Port-channel2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 4
switchport mode trunk

interface GigabitEthernet0/33
description Uplink to HP Top switch port 33
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 4
switchport mode trunk
channel-group 2 mode active
!
interface GigabitEthernet0/34
description Uplink to HP Top switch port 34
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 4
switchport mode trunk
channel-group 2 mode active
!
interface GigabitEthernet0/35
description Uplink to HP Bottom switch port 35
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 4
switchport mode trunk
channel-group 2 mode active
!
interface GigabitEthernet0/36
description Uplink to HP Bottom switch port 36
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 4
switchport mode trunk
channel-group 2 mode active

SW2 is the same port channel config here's the 4 ports:

interface GigabitEthernet0/33
description Uplink to Bottom switch port 33

switchport trunk encapsulation dot1q
switchport trunk allowed vlan 4
switchport mode trunk
channel-group 2 mode active
!
interface GigabitEthernet0/34
description Uplink to Bottom switch port 34
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 4
switchport mode trunk
channel-group 2 mode active
!
Interface GigabitEthernet0/35
description Uplink to Top switch port 35
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 4
switchport mode trunk
channel-group 2 mode active
!
interface GigabitEthernet0/36
description Uplink to Top switch port 36
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 4
switchport mode trunk
channel-group 2 mode active

As per the diagram your side switches are standalone, you have PO1 between switches.

what are the other side switches? (other side HP I think)  - I don't know if MEC is supported here.

is the same case with SW1 and SW2 ? 33and 34 come up on both switches ?

 

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

yes the result is the same on both cisco switches, i'm able to get ports 33/34 up up on both sw1 and sw2, and both switches 35/36 are up down.  So my port channel is up passing traffic just on half the links.  This set up simply mimics what we had when this setup was in our datacenter, sw1 and sw2 were Nexus 5K and connected over fiber to these exact switches with no issue.

We then moved the rack containing the HP switches to a new office, which didn't have a Nexus to hook up to, it only had two older 3560's hence the gig copper connections instead.  But this config on the Nexus pair worked, the only real difference it was vPC...?

 

But the fact half my links are coming up is what's throwing me.  But it's passing traffic and I can get to the hosts plugged into the HP switches so it's not down...just not optimal...

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: