cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
350
Views
0
Helpful
4
Replies
Beginner

Port-channel Trunk not showing allowed vlans? C9407

I have a port-channel setup as a trunk with allowed vlans, however when i do a show interface trunk it shows no allowed vlans can someone tell me why ?

 

!
interface Port-channel128
description 
switchport trunk allowed vlan 2,201,208,253-255,705
switchport mode trunk

!
!
interface GigabitEthernet7/0/1
description 
switchport trunk allowed vlan 2,201,208,253-255,705
switchport mode trunk
channel-group 128 mode active
!
interface GigabitEthernet7/0/2
description 
switchport trunk allowed vlan 2,201,208,253-255,705
switchport mode trunk
channel-group 128 mode active
!

 

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@

 

output of show int trunk showing no allowed vlans?????

#sho int port-channel 128 trunk

Port Mode Encapsulation Status Native vlan
Po128 on 802.1q other 0

Port Vlans allowed on trunk
Po128 none

Port Vlans allowed and active in management domain
Po128 none

Port Vlans in spanning tree forwarding state and not pruned
Po128 none
!
!

#sho int GigabitEthernet7/0/1 trunk

Port Mode Encapsulation Status Native vlan
Gi7/0/1 on 802.1q other 1

Port Vlans allowed on trunk
Gi7/0/1 none

Port Vlans allowed and active in management domain
Gi7/0/1 none

Port Vlans in spanning tree forwarding state and not pruned
Gi7/0/1 none

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Engager

Re: Port-channel Trunk not showing allowed vlans? C9407

Hi,

 

#sho int port-channel 128 trunk
Port Mode Encapsulation Status Native vlan
Po128 on 802.1q            other      0

Check the port status Other and Native VLAN 0. The classified reason will be configuration mismatch at another end. Please check remote end device 

 

 

 

Regards,
Deepak Kumar,
Resume duty after a long holiday
4 REPLIES 4
Beginner

Re: Port-channel Trunk not showing allowed vlans? C9407

Dear lowfell,

 

Add these to your configuration

 

interface Port-channel128
description

switchport trunk encapsulation dot1q    <--- Add tagging if you want your VLANS to be tagged !!
switchport trunk allowed vlan 2,201,208,253-255,705
switchport mode trunk

 

interface GigabitEthernet7/0/1
description 

switchport trunk encapsulation dot1q    <--- Add tagging if you want your VLANS to be tagged !!
switchport trunk allowed vlan 2,201,208,253-255,705
switchport mode trunk

channel-protocol lacp   <--- Define channel protocol i.e LACP or PAgP
channel-group 128 mode active
!
interface GigabitEthernet7/0/2
description 

switchport trunk encapsulation dot1q     <--- Add tagging if you want your VLANS to be tagged !!
switchport trunk allowed vlan 2,201,208,253-255,705
switchport mode trunk

channel-protocol lacp    <--- Define channel protocol i.e LACP or PAgP
channel-group 128 mode active

 

HTH

Regards,

Talha

VIP Engager

Re: Port-channel Trunk not showing allowed vlans? C9407

Hi,

 

#sho int port-channel 128 trunk
Port Mode Encapsulation Status Native vlan
Po128 on 802.1q            other      0

Check the port status Other and Native VLAN 0. The classified reason will be configuration mismatch at another end. Please check remote end device 

 

 

 

Regards,
Deepak Kumar,
Resume duty after a long holiday
Beginner

Re: Port-channel Trunk not showing allowed vlans? C9407

We did have the other end connected, but now those switches are gone and i'm tidying up the config on the 9407, so, to cut a long story short, if the portchannel had been up, i could have seen my allowed vlans, yes?

Highlighted
Beginner

Re: Port-channel Trunk not showing allowed vlans? C9407

Thanks for your help Deepak. i wrongly assumed because i had the allowed vlans in the config then i should be able to see them when I did show int trunk. Obviously I need thetrunk to be up first! 'll remember now.
thanks again.
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards