cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1062
Views
10
Helpful
3
Replies

QoS for Beginners

Patrick McHenry
Level 3
Level 3

Hey -

I want to enable some real QoS at a new site as opposed to auto-qos. The site is going to have a 1002 router and 2, 3750X switches. The phone are going to be Nortel. I'm thinking of enabling VLAN-based QoS. I'm referring to a Nortel document for QoS to a Cisco 3750.

Here is my config related to QoS on the 3750X

mls qos srr-queue input buffers 70 30

mls qos

!

class-map match-all voice

  match access-group name voice-traffic

!

policy-map voice-policy

class voice

  trust dscp

!

interface GigabitEthernet1/0/1

switchport mode access

switchport access vlan 2

switchport voice vlan 10

mls qos vlan-based

spanning-tree portfast

spanning-tree bpduguard enable

!

interface Vlan10

ip addr 10.10.10.1 255.255.255.0

service-policy input voice-policy

!

ip access-list extended voice-traffic

permit ip 10.10.10.0 0.0.0.255 any

!

On the router:

class-map match-any IN

match ip dscp ef

class-map match-any VOICE

match ip dscp ef

!

policy-map IN

class IN

  set ip dscp ef

policy-map QoS

class VOICE

  priority percent 30

!

interface GigabitEthernet0/0/0

description CONNECTION TO CORE SWITCH

ip address 172.20.1.138 255.255.255.252

negotiation auto

service-policy input IN

service-policy output QoS

!

interface Serial0/1/0

description WAN CIRCUIT FROM SITE 2 TO SITE 1

ip address 172.20.1.114 255.255.255.252

ip flow ingress

dsu bandwidth 44210

framing c-bit

cablelength 10

service-policy output QoS

!

First off, This is a call center with 30 or so people - is VLAN-based QoS the way to go in this situation.

Must I also apply the "mls qos vlan-based" command on the trunk ports between the switches and the L3 port connecting to the router?

Like I said - I'm taking a stab at this - does it appear correct?

Thank you.

3 Replies 3

Edison Ortiz
Hall of Fame
Hall of Fame

If you are doing classification on packets entering the trunk, yes - vlan-based qos is needed there - else you must enable trust or QoS marking will be removed as port is deemed untrusted.

Regards,

Thanks Edison.

Do,you think I should use VLAN based Qos?

Also, these phones that will attach to this switch will be Nortel phones. Must I enable LLDP to communicate the proper voice VLAN and tagging?

Thank you, Pat.

Yes and Yes.

Vlan Based Qos is more scalable on TCAM resources (specially on 6500 switches).

LLDP is useful for discovery process on non-cisco phones.

Some phones provide information to switches via LLDP and switches can adjust power consumption based on this information. You will also be able to see the phone product ID information just like CDP.

Keep in mind, this behavior varies among phone manufacturers, please test beforehand.

Regards,

Review Cisco Networking products for a $25 gift card