cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

479
Views
0
Helpful
4
Replies
Highlighted

Quality of Service (QoS) mapping

Hello,

I have a customer who wishes to implment QoS on a 2821 router with ios 12.4(15).T8.  They want to prioritize outbound and inbound Citrix traffic up to 128 kbps out the Internet interface.  I have ben given the Citrix server IP address and have the  application ports as well. If Citrix is not using this bandwidth, other applications need to be able to use it.  What would be the simplest approach to implement this?

thanks in advance                  

Everyone's tags (3)
4 REPLIES 4
Beginner

Quality of Service (QoS) mapping

you can modify this configuration as per your reqirement.. you can define ip precedence value 5 to your citrix traffic and for any other traffic just give ip precedence value of 0

access-list 100 permit tcp any any eq 1720

!
class-map voip 
 match access-group 100
!
policy-map MQC
 class voip
  set ip precedence 5 
 class class-default 
  set ip precedence 0 
!

interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 service-policy input MQC


Quality of Service (QoS) mapping

Thank you for the very quick response and feedback, much appreciated.

This was the road I was going down, and wanted to be sure I was going with the most efficient method.

So, to allocate a percentage of the total bandwidth to the citrix class, could I then add the following lines (I assumed the total bandwidth was 1 Mbps, so 13% is roughly 128 kbps)?:

!
class-map citrix 
 match access-group 100
!
policy-map MQC
 class citrix
  set ip precedence 5
 bandwidth percent 13 
 class class-default 
  set ip precedence 0
 fair-queue  

Again, thank you very much.

Andrew

Participant

Quality of Service (QoS) mapping

Hi Andrew,

You can also look at NBAR by matching the ICA protocol directly.  I've looked at a 2821 running 12.4(25f) to get this config.

Something like:

 

class-map citrix

  match protocol citrix

!

policy-map citrix-map

  class citrix

    bandwidth 128

  class class-default

    fair-queue

!

If you want to get more specific, you can stipulate the IP of the server as well.

!

access-list 100 permit tcp eq citrix

!or depending on traffic direction

access-list 100 permit tcp eq citrix

!

!

class-map match-all citrix

  match protocol citrix

  match access-group 100

!

Also, if this is on the Internet interface, you needn't worry about marking the packets.  As far as I know the Internet doesn't listen to TOS.  Certainly the providers i've used in the past don't.

If you use the percentage key-word rather than bandwidth in the policy-map, don't forget to put the bandwidth statement on the Interface.  Also ensure the service-policy is applied.

Enjoy.

Brad

VIP Expert

Re: Quality of Service (QoS) mapping

Disclaimer

The   Author of this posting offers the information contained within this   posting without consideration and with the reader's understanding that   there's no implied or expressed suitability or fitness for any purpose.   Information provided is for informational purposes only and should not   be construed as rendering professional advice of any kind. Usage of  this  posting's information is solely at reader's own risk.

Liability Disclaimer

In   no event shall Author be liable for any damages whatsoever (including,   without limitation, damages for loss of use, data or profit) arising  out  of the use or inability to use the posting's information even if  Author  has been advised of the possibility of such damage.

Posting

You cannot really prioritize inbound.  You might police non-Citrix traffic to allow Citrix 128 Kbps, but then when Citrix is not using its bandwidth, that bandwidth is unavailable.  Also, even thought other traffic might be policed to provide 128 Kbps, you really cannot guarantee that because the policing is after the traffic ingresses.

Outbound, it's pretty easy.  For example, perhaps:

class-map match-any Citrix

match protocol Citrix

policy-map Sample

class Citrix

priority 128 (or it might be 128000; don't recall if parameter is bps or Kbps)

Instead of using LLQ, you might use a high % bandwidth statement with a shaper, e.g.:

policy-map Sample2

class Citrix

bandwidth percentage 99

shape average 128000

You also might want to consider using NBAR with Citrix subtypes, so you don't give the same high priority to Citrix printing or disk copying.

CreatePlease to create content
Content for Community-Ad