10-30-2018 07:46 AM - edited 03-08-2019 04:30 PM
We had a trunk port set up with the following config:
interface GigabitEthernet1/0/2
switchport access vlan 200
switchport mode trunk
switchport nonegotiate
no snmp trap link-status
spanning-tree portfast
end
A second admin came in and wanted to add vlan 1100 to that list so he just did "switchport trunk allowed vlan 200,1100" and we noticed there is only intermittent access to the devices on the 1100 network. Now the config looks like this:
interface GigabitEthernet1/0/2
switchport access vlan 200
switchport trunk allowed vlan 200,1100
switchport mode trunk
switchport nonegotiate
no snmp trap link-status
spanning-tree portfast
end
Every so often it will work and then traffic to and from those devices will stop. I am assuming it has something to do with the access and the trunk allowed being there at the same time. Should I just remove the access vlan line?
Solved! Go to Solution.
10-30-2018 08:57 AM
Hi,
You cant make a switch port in Access mode and Trunk mobe both at a time. You have to delete access mode command or trunk mode command from the switch.
If you want to use this interface as a trunk than change configuration as below (Highlighted commands needs to run on both switches)
Interface GigabitEthernet1/0/2
no switchport access vlan 200
switchport trunk allowed vlan 200,1100
switchport mode trunk
switchport nonegotiate
no snmp trap link-status
no spanning-tree portfast
end
Regards,
Deepak Kumar
10-30-2018 07:57 AM
Hello,
the 'switchport access vlan 200' has no bearing on anything, since the switchport mode is trunk. Only when you change the switchport mode to access would that line become important.
Either way, what does the rest of the network look like ? Which is the root switch for Vlans 200 and 1100 ?
10-30-2018 08:18 AM
10-30-2018 08:57 AM
Hi,
You cant make a switch port in Access mode and Trunk mobe both at a time. You have to delete access mode command or trunk mode command from the switch.
If you want to use this interface as a trunk than change configuration as below (Highlighted commands needs to run on both switches)
Interface GigabitEthernet1/0/2
no switchport access vlan 200
switchport trunk allowed vlan 200,1100
switchport mode trunk
switchport nonegotiate
no snmp trap link-status
no spanning-tree portfast
end
Regards,
Deepak Kumar
10-30-2018 09:55 AM
10-30-2018 07:36 PM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide