02-03-2015 09:46 PM - edited 03-07-2019 10:30 PM
I have 2600 router.
int FastEthernett 0/0 retrieve IP from DHCP.
How can internal IP from VLAN 10,20,30 access Internet through Int FastEthernet 0/0
i try ip route to FastEthernet 0/0 but can't internet
Below is the config,
interface FastEthernet0/0
ip address dhcp hostname DHCP
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.1
description VLAN10
encapsulation dot1Q 10
ip address 192.168.10.254 255.255.255.0
!
interface FastEthernet0/1.2
description VLAN 20
encapsulation dot1Q 20
ip address 192.168.20.254 255.255.255.0
!
interface FastEthernet0/1.3
description VLAN 30
encapsulation dot1Q 30
ip address 192.168.30.254 255.255.255.0
!
!
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
02-03-2015 11:15 PM
Hello,
What is connected on F0/0 ? Can you send us information about your interface F0/0 (show interface f0/0)?
Thanks
02-03-2015 11:54 PM
below is the fa0/0
Cisco#sh int fa0/0
FastEthernet0/0 is up, line protocol is up
Hardware is AmdFE, address is 000f.2360.4dc0 (bia 000f.2360.4dc0)
Internet address is 172.28.7.158/16
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s, 100BaseTX/FX
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:00:07, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 3000 bits/sec, 5 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
1016 packets input, 84709 bytes
Received 851 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog
0 input packets with dribble condition detected
36 packets output, 4227 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
29 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
02-04-2015 12:05 AM
Can you ping this IP address 172.28.7.158 with clients behind VLAN's ? Can you ping the device behind F0/0 from your cisco device?
02-04-2015 12:18 AM
vlan client able to ping up to Fa0/0. (172.28.7.158) & vice versa.
02-04-2015 12:23 AM
Can you ping device behind F0/0 from your cisco device? what is behind this interface ?
02-04-2015 01:31 AM
behind Fa0/0 is a face plate (network port) connecting to my office local LAN.
let say if i plug my notebook to the face plate, my nb will get dhcp and i can browse internet.
02-04-2015 04:30 AM
The device your router gets an IP from needs -
1) routes back to your router for your LAN subnets
2) it needs to NAT for those subnets
However if this is just a cable modem type device it may not support the above.
You can try doing the above but if it's not possible then just add this configuration to your router -
int fa0/0
ip nat outside
int fa0/1.1
ip nat inside
int fa0/1.2
ip nat inside
int fa0/1.3
ip nat inside
access-list 101 permit ip 192.168.10.0 0.0.0.255 any
access-list 101 permit ip 192.168.20.0 0.0.0.255 any
access-list 101 permit ip 192.168.30.0 0.0.0.255 any
ip nat inside source list 101 interface fa0/0 overload
Jon
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide