Showing results for 
Search instead for 
Did you mean: 

[Solved] Cisco UC520 Unable to connect to internet

Level 1
Level 1


I am a student and next year we get the subject Cisco. So, I was allowed to take an old Cisco router from my work and use it to practise my command line skills and learn some stuff so that next year would be easier.

Because I don't have any experience with the command line, I decided to configure the router first with the Cisco Configuration Assistant and safe a back-up from the settings and then go learning the command line and practise the command line.

So, I configured the router perfectly. a couple of vlans, wifi networks, every single thing works. If I connect a computer to it, it get's an IP adress and everything works nicely. Except for one thing, I don't have internet access.

I have the following network setup:

Modem -> Sitecom Router (this one works) -> Cisco router

I hooked up one of the lan ports from the Sitecom router to the WAN port of the Cisco router, this should work, but it doesn't.

Then I tried connecting the WAN port of the Cisco router directly to the modem, as described in the Quick Start Guide, but that doesn't work either.

Yes, the WAN Port is active and configured as DHCP not Static or PPPoE.

NAT is turned off, but that should make a difference according to my collegue (if we are wrong feel free to tell).

If I look in the Sitecom router connected computers list, I don't see the Cisco router either. It looks like it doesn't have a MAC adress. But if I go to the command line and go to the interfaces bit. I see the "$FW_OUT" or something like that with an MAC address. I put that address with a static ip in my Sitecom router, but it doesn't recognize my Cisco router, so it can't give that ip.

Does anyone know how to fix this???

It should be possible to get it working right?

Kind Regards,

38 Replies 38

My laptop is currently on vlan1, default, with the ip

Probably not showing in the show run, because it is in standby, but I can connect to the router from my laptop as I can access it for example from the Configuration Assistant.

Can you ping from your PC?

It could be a DNS issue you are facing that means you can't resolve IP addresses. Have you configured your PC IP address manually or picked it up from the DHCP scope on the router?

I have dhcp from the dhcp scope, I can ping

But I don't have any dns servers, I checked it in the GUI because I don't know the commands (yet).

If not having any dns servers is the problem, how do I add a dns server from the command line, I know how it works in the GUI but I want to learn CLI.

And which dns server do I add, my sitecom router I think?

Because that is linked to the dns server from my internet service provider and if I want I can manually connect to Google's dns server in windows.

In your DHCP scope you are telling your PC's that they should use the router for DNS queries - this won't work. You can either change your DNS servers to public google ones, something like:

ip dhcp pool data

   import all




Or you can use your ISP assigned DNS servers.

Change that and renew your IP address and you should be on the internet!

What are the CLI commands?

Because #ip dhcp pool data doesn't work.

I'm running IOS 12.4 or something.

It did it anyway via the GUI, but I really want to know the right commands, so I can do it via the console.

And that access-list thing how does that work?

You said something about changing the settings for the access list.

By the way, THANK YOU SO MUCH!

It works!

I assigned every vlan's dns with the ip from my Sitecom router, and it just works nicely.

Now it's time for me to get ftp working and save a back-up from the settings and then I go messing with the CLI!

And if I want to put my Sitecom router behind the Cisco one, I have to do all that static ip stuff again I think?

I also want MAC address filtering, but I can figure that out myself... I think...

I just wanted to get it working and it works!

Thank you very very much for helping, I really appreciated it.


Just put:

#conf t

#ip dhcp pool data

#import all




You have to go into configuration mode before you can enter configuration commands. If your Sitecom router just connects via ethernet to your modem then there is no reason why you can't just get rid of it and change the Cisco router WAN interface address to 192.168.42.x and then modify your default route.

Glad you got it working - persevere with the CLI - it is complex but it pays off in the long run. GUI access is good to get started but understanding the CLI will pay in the long run.

Configuration mode.... right.

Sounds logical for configuration commands.

I only use GUI for get it working, but I noticed a lot of things that you can do with CLI you can't do with GUI. For school we have to learn it with the CLI, that's why I want to practice this summer vacation, so learning all the commands and getting used to the CLI would be easier.

Thank you again for all the help, I really appreciate it.

Euhm... mfurnival? The normal lan networks seem to work, but the wlan not. I can connect, get an ip, but then I get dns errors.

How do I fix this?

The wifi networks are connected to the correct vlan, so it should work, I think?

You need to add the DNS server entries under the wireless vlan dhcp pool.

I use three vlans for both lan as wlan, can that cause conflicts?

Because the dns servers are set correctly and exactly the same as vlan1.

The only difference between the settings of the vlans are the ip's that the dhcp gives out.

I even added the excluded ip's, because those where on the default vlan, and now they all should be exactly the same

OK, I just looked at your config again. You need to add your wireless subnets to acl 1 to tell the router to nat them.

Commands? Please?

Seriously, the GUI helps with basic functions, but I can't find the acces-list or nat stuff.

Do you by any chance now how to configure smartports by using the CLI?

Because I think I kinda fucked up when I did it with the GUI...

I did it!!!

I changed the NAT settings for the vlans all by myself!!! jeeeeeeeej!

Now how does that ACL thingy work with commands?

I said that ACL2 to ACL6 should allow any ip. don't know why I did that, but it was worth a try.

So, how do I add all of the vlans to ACL1? or ACL2? or whatever I have to do to get it working?

And how do you save all the settings with the CLI?
I know how to do it in the GUI, but how do you do it in the CLI, so that when I turn the router off it has stored all the changes?

I changed wlan1 back to vlan3 instead of vlan1, but now I can't get to the internet anymore on vlan1.

Then I checked the nat settings, FastEthernet0/0 was still on outside, vlan1 was on "outside", while the rest was on "inside".
I don't know if this is good or bad, so maybe you know?

And now I can't connect to the internet on any vlan.

For vlan1 I think the problem is that the nat settings are on outside?

But I can't get it to inside weirdly, I tried your commands but that didn't help.

I tried adding the to acl1, but that didn't help either.

Even worse, vlan1 doesn't generate ip addresses anymore (maybe because it's nat setting is on outside?).

I've uploaded a new show run log, because I don't know where to look and you do.

Hopefully we can fix this... again...

The dns is still good and untouched!

Maurice, wow you have made quite a mess

There are a few things wrong that I can see.

First, in each of your DHCP pools you have specified two DNS servers but they are in the wrong order. Anyway, to correct it do this:

#conf t

#ip dhcp pool data1


#ip dhcp pool psp


#ip dhcp pool gasten


Also do this:

#no access-list 1 permit any

Also do this:

#no ip nat inside source list 1 interface BVI1 overload

and then type this:

#ip nat inside source list 1 interface fa0/0 overload

and this:

#int BVI1

#ip nat inside

And let me know how you get on.

Review Cisco Networking for a $25 gift card