03-08-2016 06:58 AM - edited 03-08-2019 04:52 AM
Hello guys,
Can I know the maximum number of switches to do stacking?
In fact, I am having an issue in my network migration project, I have 2 Juniper Ex 4300 in stack mode and from the ex4300 port ge-0/0/30 and ge-1/0/30 starts all the uplinks for my cisco 2960 and 2960G, they are all in redundancy mode.
SW1
Juniper EX 4300 (Core SW) Port ge-0/0/30 => Cisco 2960G (Access SW) Port Gi0/23
Juniper EX 4300 (Core SW) Port ge-1/0/30 => Cisco 2960G (Access SW)Port Gi0/24
SW2
Juniper EX 4300 (Core SW) Port ge-0/0/31 => Cisco 2960G (Access SW) Port Gi0/23
Juniper EX 4300 (Core SW) Port ge-1/0/31 => Cisco 2960G (Access SW) Port Gi0/24
SW3
Juniper EX 4300 (Core SW) Port ge-0/0/32 => Cisco 2960 (Access SW) Port Gi0/1
Juniper EX 4300 (Core SW) Port ge-1/0/32 => Cisco 2960 (Access SW) Port Gi0/2
I need to connect 17 Cisco SW to the Juniper but as soon as I connect a fourth SW, the up-link ports of the other Cisco switches shutdown.
Here is a sample of my Juniper EX 4300 Port Conf
set interfaces ge-0/0/30 description "SW_EBE1-mu Gi0/23"
set interfaces ge-0/0/30 ether-options 802.3ad ae1
set interfaces ge-1/0/30 description "SW_EBE1-mu Gi0/24"
set interfaces ge-1/0/30 ether-options 802.3ad ae1
set groups vstp_per_vlan protocols vstp vlan <*> interface ae1
set interfaces ge-0/0/30 ether-options 802.3ad ae1
set interfaces ge-1/0/30 ether-options 802.3ad ae1
set interfaces ae1 description "SW_EBE1-mu Po1"
set interfaces ae1 native-vlan-id 1
set interfaces ae1 aggregated-ether-options link-speed 1g
set interfaces ae1 aggregated-ether-options lacp active
set interfaces ae1 aggregated-ether-options lacp periodic slow
set interfaces ae1 unit 0 family ethernet-switching interface-mode trunk
set interfaces ae1 unit 0 family ethernet-switching vlan members 1
set interfaces ae1 unit 0 family ethernet-switching vlan members 10-16
set interfaces ae1 unit 0 family ethernet-switching vlan members 18-23
set interfaces ae1 unit 0 family ethernet-switching vlan members 30-33
set interfaces ae1 unit 0 family ethernet-switching vlan members 71
set interfaces ae1 unit 0 family ethernet-switching vlan members 75
set interfaces ae1 unit 0 family ethernet-switching vlan members 99
set interfaces ae1 unit 0 family ethernet-switching vlan members 101-104
set interfaces ae1 unit 0 family ethernet-switching storm-control default
set protocols rstp interface ae1
set protocols vstp vlan 30 interface ae1 cost 100
And this one for Cisco Catalyst 2960G
interface Port-channel1
description to ae1
switchport trunk allowed vlan 10-16,18-23,30-33,71,75,99,101-104,118-120,278
switchport trunk allowed vlan add 390,666,950,1048,1049,1300-1302
switchport mode trunk
switchport nonegotiate
spanning-tree cost 1
end
interface GigabitEthernet0/23
description to ge-0/0/30
switchport trunk allowed vlan 10-16,18-23,30-33,71,75,99,101-104,118-120,278
switchport trunk allowed vlan add 390,666,950,1048,1049,1300-1302
switchport mode trunk
switchport nonegotiate
channel-group 1 mode active
end
interface GigabitEthernet0/24
description to ge-1/0/30
switchport trunk allowed vlan 10-16,18-23,30-33,71,75,99,101-104,118-120,278
switchport trunk allowed vlan add 390,666,950,1048,1049,1300-1302
switchport mode trunk
switchport nonegotiate
channel-group 1 mode active
end
Here are the logs from my SWs
1. SW_EBE1-mu
Syslog logging: enabled (0 messages dropped, 0 messages rate-limited, 0 flushes, 0 overruns, xml disabled, filtering disabled)
No Active Message Discriminator.
No Inactive Message Discriminator.
Console logging: level debugging, 17 messages logged, xml disabled,
filtering disabled
Monitor logging: level debugging, 0 messages logged, xml disabled,
filtering disabled
Buffer logging: level debugging, 17 messages logged, xml disabled,
filtering disabled
Exception Logging: size (4096 bytes)
Count and timestamp logging messages: disabled
File logging: disabled
Persistent logging: disabled
No active filter modules.
Trap logging: level informational, 20 message lines logged
Log Buffer (4096 bytes):
*Mar 1 00:00:47.169: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to downAuth Manager registration failed
*Mar 1 00:00:48.846: %SPANTREE-5-EXTENDED_SYSID: Extended SysId enabled for type vlan
*Mar 1 00:00:53.603: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan33, changed state to down
*Mar 1 00:00:53.787: %SYS-5-CONFIG_I: Configured from memory by console
*Mar 1 00:00:54.626: %SYS-5-RESTART: System restarted --
Cisco IOS Software, C2960 Software (C2960-LANBASEK9-M), Version 12.2(58)SE1, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2011 by Cisco Systems, Inc.
Compiled Thu 05-May-11 02:53 by prod_rel_team
*Mar 1 00:00:54.651: %SSH-5-ENABLED: SSH 1.99 has been enabled
*Mar 1 00:00:55.574: %LINK-5-CHANGED: Interface Vlan1, changed state to administratively down
*Mar 1 00:25:23.220: %LINK-3-UPDOWN: Interface GigabitEthernet0/23, changed state to up
*Mar 1 00:25:25.619: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 24 on Port-channel1 VLAN75.
*Mar 1 00:25:25.619: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking Port-channel1 on VLAN0075. Inconsistent local vlan.
*Mar 1 00:25:26.265: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/23, changed state to up
*Mar 1 00:25:26.600: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan33, changed state to up
*Mar 1 00:25:27.229: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
*Mar 1 00:25:27.783: %LINK-3-UPDOWN: Interface GigabitEthernet0/24, changed state to up
*Mar 1 00:25:28.236: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up
*Mar 1 00:25:31.130: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/24, changed state to up
2. SW_EBE2-mu
Syslog logging: enabled (0 messages dropped, 0 messages rate-limited, 0 flushes, 0 overruns, xml disabled, filtering disabled)
No Active Message Discriminator.
No Inactive Message Discriminator.
Console logging: level debugging, 17 messages logged, xml disabled,
filtering disabled
Monitor logging: level debugging, 0 messages logged, xml disabled,
filtering disabled
Buffer logging: level debugging, 17 messages logged, xml disabled,
filtering disabled
Exception Logging: size (4096 bytes)
Count and timestamp logging messages: disabled
File logging: disabled
Persistent logging: disabled
No active filter modules.
Trap logging: level informational, 20 message lines logged
Log Buffer (4096 bytes):
*Mar 1 00:00:47.169: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to downAuth Manager registration failed
*Mar 1 00:00:48.846: %SPANTREE-5-EXTENDED_SYSID: Extended SysId enabled for type vlan
*Mar 1 00:00:53.603: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan33, changed state to down
*Mar 1 00:00:53.787: %SYS-5-CONFIG_I: Configured from memory by console
*Mar 1 00:00:54.626: %SYS-5-RESTART: System restarted --
Cisco IOS Software, C2960 Software (C2960-LANBASEK9-M), Version 12.2(58)SE1, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2011 by Cisco Systems, Inc.
Compiled Thu 05-May-11 02:53 by prod_rel_team
*Mar 1 00:00:54.651: %SSH-5-ENABLED: SSH 1.99 has been enabled
*Mar 1 00:00:55.574: %LINK-5-CHANGED: Interface Vlan1, changed state to administratively down
*Mar 1 00:25:23.220: %LINK-3-UPDOWN: Interface GigabitEthernet0/23, changed state to up
*Mar 1 00:25:25.619: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 24 on Port-channel1 VLAN75.
*Mar 1 00:25:25.619: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking Port-channel1 on VLAN0075. Inconsistent local vlan.
*Mar 1 00:25:26.265: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/23, changed state to up
*Mar 1 00:25:26.600: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan33, changed state to up
*Mar 1 00:25:27.229: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
*Mar 1 00:25:27.783: %LINK-3-UPDOWN: Interface GigabitEthernet0/24, changed state to up
*Mar 1 00:25:28.236: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up
*Mar 1 00:25:31.130: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/24, changed state to up
Can anyone help me to solve this issue?
I am actually working in a project of migrating a call center and the migration will be as from next week
Solved! Go to Solution.
03-08-2016 10:09 AM
Hi,
Not sure if I understand the question but just FYI, you can stack up to 10 Juniper 4300 series switches together. It is called VC (Virtual chassis). As for the 2960G, this series does not support stacking.
Can you explain your question?
HTH
03-08-2016 10:09 AM
Hi,
Not sure if I understand the question but just FYI, you can stack up to 10 Juniper 4300 series switches together. It is called VC (Virtual chassis). As for the 2960G, this series does not support stacking.
Can you explain your question?
HTH
03-08-2016 11:18 AM
03-11-2016 09:27 PM
Hello,
The problem was solved.
Issue was with vstp.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide