cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1091
Views
0
Helpful
3
Replies

Steps to Configure VLANs

jill.johnson
Level 1
Level 1

We have Cisco 6509, running IOS ver. 12.2.  We need to configure VLAN's. Are these the steps to configure Vlan's?  So, you would configure each Vlan first.  Then, associate switch ports with Vlans.  Please feel free to add any comments.  Thanks.

config t
interface Vlan70
ip address 216.131.251.70
exit

config t
interface Vlan65
ip address 216.131.251.65
exit

config t
interface Vlan120
ip address 216.131.251.120
exit

config t
int g1/1
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 200
switchport trunk allowed vlan 65,70,120
switchport mode trunk
switchport nonegotiate
no ip address
no shutdown
exit

3 Replies 3

DuncanM2008
Level 1
Level 1

I would personally from experience and preference configure the Vlan's first & name them.


Then configure any Layer 3/SVI interfaces for IP Routing where required.

Finally configure port memberships and trunking requirements for the required VLAN's.

If you configure port memberships without the VLAN being created it'll complain and create the VLAN for you anyway so it's always worth creating the VLAN first from a best practice point of view.

I also probably wouldn't post your actual IP & VLAN configuration just from a security point of view anyway, although it is helpful in understanding sometimes.

Thanks,

Thanks for your prompt response.  For verification, is this what you would do?  Would you say "no shutdown" right away after configuring the Switch port.  Please feel free to add or change anything since VLANs are new to me.  Thanks.

config t
interface Vlan70
name Vlan70
ip address 216.131.251.70
exit


config t
interface Vlan65
name Vlan65
ip address 216.131.251.65
exit


config t
interface Vlan120
name Vlan120
ip address 216.131.251.120
exit


config t
int g1/1
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 200
switchport trunk allowed vlan 65,70,120
switchport mode trunk
switchport nonegotiate
no ip address
no shutdown
exit

Hi,

You don't have to no shut switchports as it is the default.

interface Vlan70
name Vlan70

this name command won't work here but you can give it a description with the description command.

What the other person told was to do like this:

1) create vlan: in vlan database or global config ( first option is being deprecated).

  (config)# vlan 10

  (config-vlan)# name vlan10

  (config-vlan) # exit

2)assign vlan to access port

(config)# interface f1/0

(config-interface)# switchport mode access

(config-interface)#switchport access vlan 10

3)configure SVIs ( only one on L2 switches that is used for management)

(config)# interface vlan10

(config-interface)# ip address 192.168.1.1 255.255.255.0

For verification:

1) are your vlans created and correctly assigned to interfaces :  show vlan brief

2) is your SVI up/up:  show ip interface brief | in Vlan

Regards.

Alain.

Don't forget to rate helpful posts.
Review Cisco Networking for a $25 gift card