cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
822
Views
0
Helpful
6
Replies

Switch freezes when Port Channel comes UP

dfaber
Beginner
Beginner

Hello,

       I have a weird issue that when one of my Port Channel comes UP on my 3850, the entire switch freezes for a few seconds.

 

       Basically, I have a two switch stack of WS-C3850-48U and six IE-2000-4TS-G-B connected via Etherchannel on the 3850. All IE-2000-4TS-G-B are configured exactly the same and all Port Channel on the 3850 are identical. For some reason, when I bring the port channel of one of the IE-2000 down and bring it back up, the entire 3850 freezes for a few seconds as the port channel is coming up. I loose SSH communication and even directly in console, the switch stop responding. This happens only with one the IE-2000. All five other work correctly.

 

Only po11 is causing the issue. I have no errors on the port and nothing in the logs.

 

Here are a few info for my setup:

 

2 x WS-C3850-48U, stacked running 16.3.7

6 x IE-2000-4TS-G-B running 15.2(4)EA5

 

Config on 3850

interface Port-channel11
 description swSH6603
 switchport mode trunk
 switchport nonegotiate
 ip arp inspection trust
 spanning-tree portfast trunk
 spanning-tree bpduguard disable
 ip dhcp snooping trust

!

interface GigabitEthernet1/0/11
 description swSH6603
 switchport mode trunk
 switchport nonegotiate
 ip arp inspection trust
 channel-protocol lacp
 channel-group 11 mode active
 spanning-tree portfast trunk
 spanning-tree bpduguard disable
 ip dhcp snooping trust

!

interface GigabitEthernet2/0/11
 description swSH6603
 switchport mode trunk
 switchport nonegotiate
 ip arp inspection trust
 channel-protocol lacp
 channel-group 11 mode active
 spanning-tree portfast trunk
 spanning-tree bpduguard disable
 ip dhcp snooping trust

!

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
11     Po11(SU)        LACP      Gi1/0/11(P) Gi2/0/11(P)
12     Po12(SU)        LACP      Gi1/0/12(P) Gi2/0/12(P)
13     Po13(SU)        LACP      Gi1/0/13(P) Gi2/0/13(P)
14     Po14(SD)        LACP      Gi1/0/14(P) Gi2/0/14(P)
15     Po15(SU)        LACP      Gi1/0/15(P) Gi2/0/15(P)
16     Po16(SU)        LACP      Gi1/0/16(P) Gi2/0/16(P)

 

Config on the IE-2000

interface Port-channel1
 description vers swSH6601
 switchport mode trunk
 switchport nonegotiate
 ip arp inspection trust
 ip dhcp snooping trust

!
interface GigabitEthernet1/1
 description vers swSH6601
 switchport mode trunk
 switchport nonegotiate
 ip arp inspection trust
 channel-protocol lacp
 channel-group 1 mode active
 ip dhcp snooping trust

!
interface GigabitEthernet1/2
 description vers swSH6601
 switchport mode trunk
 switchport nonegotiate
 ip arp inspection trust
 channel-protocol lacp
 channel-group 1 mode active
 ip dhcp snooping trust

!

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Gi1/1(P)    Gi1/2(P)   

 

I already did several test. If I only bring one interface down, meaning that the port channel does not come down, I don't get the issue. Only when the entire port channel comes down and return to the UP state that I get the issue. I tried changing the physical ports on the switch, no luck. I tired changing the ports with one of the working IE-2000 and the issue followes the switch. I have triple checked the configuration on the problem switch with a working switch and, aside from their IP adresses, the configs are identical.

 

Any help would be appreciated.

1 Accepted Solution

Accepted Solutions

Replaced the switch with a new one and the problem is gone. I will send the old switch back for a RMA.

View solution in original post

6 Replies 6

Leo Laohoo
VIP Community Legend VIP Community Legend
VIP Community Legend
Sounds like a bug.

gaston.benitez
Beginner
Beginner

Hi

 

Did you try to start up with a basic config, something like this? Then on if this works you can continue with the rest of the config.

 

interface GigabitEthernet X/Y/Z
 switchport mode trunk
 switchport nonegotiate
 channel-protocol lacp
 channel-group 11 mode active

 

BR

Gaston

 

Yes, I tried with no luck.

 

I have a new IE-2000 in order. I should receive it tomorrow. I will try and swap it. I will also try some new SFP and try with some other ethernet cables.

 

Hopefully. one of these is the issue.

Hello,

 

which SFPs are you using ? The below bugs applies to 3rd party SFP ACCELINK GLC-GE-100FX:

 

C3850-24S EtherChannel member keep down after opposite side(IE-2000) reboot
CSCvc61354
Description
Symptom:
There is a known quality issue with 3rd party SFP ACCELINK GLC-GE-100FX.

Conditions:
Issue was observed with the following topology:

IE2000(GLC-FE-100FX)=====C3850(GLC-GE-100FX)

IE2000(GLC-FE-100FX) connect with C3850(GLC-GE-100FX) with port channel(pagp).
When reboot IE2000 device, after IE2000 boot up, interface on C3850 may change portchannel status to I(Stand-along).


C3850 running 3.6.5E IOS.
IE2000 running 15.0(2)EA1 IOS.

Workaround:
Shut/no shut of the interface solves this issue.

I am using Cisco brand SFP.

 

I have a new IE-2000 at my desk. I will try and replace the one that is causing me issues on Tuesday next week. Hopefully, it will solve the issue.

 

Thanks.

Replaced the switch with a new one and the problem is gone. I will send the old switch back for a RMA.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers