Showing results for 
Search instead for 
Did you mean: 
Join Customer Connection to register!

Switch to Switch Connection


I have One Switch 3548 with few vlans configured. Now I bought one more switch and want to do the following :

Switch 3548 has One VLan as 880 with network as for ports 1 to 8. Now I added one more switch in the network, configured VLan 880 on this new switch with network same as for ports 1 to 17.

Now I want to connect port 8 of old switch to port 17 of new switch so that will have flow of same network to new switch's VLan.

I tried to have both ports 8 and 17 in switchport access Vlan, but it did not work. I tried to change new switch to general, trunk but still it didn't work (but at that time I was not changing any configuration at old switch as it is in production).

Old Switch has following config :

interface FastEthernet0/8

duplex full

speed 100

switchport access vlan 880

New switch has following config :

interface FastEthernet0/17

duplex full

speed 100

switchport access vlan 880

Above did not work.

Please advise.



Collin Clark

Did you use a cross-over cable between the two switches? Do you get any link lights or is it traffic is not passing? You might want to also add switchport mode access under the two interfaces.

I did use a cross over cable.

I am getting amber light at New switch and old switch has normal green LED.

I think it is by default in access mode.


Sounds like spanning-tree port block.

I did use a cross over cable.

I am getting amber light at New switch and old switch has normal green LED.

I think it is by default in access mode.



Can you share the output for show spanning-tree vlan 80 and show interface FastEthernet0/8.

and are you pinging from host from old switch to host in new switch or from switch to switch.


Hi Shashikant,

I given few thought what could be issue and following are few of the guess

  1. Switch to Switch should be connected with cross cable -- It is connected
  2. Both the ports should have same speed and duplex setting -- It is shared and OK
  3. Possible Layer-2 loop - Needs to verify for both switches- Need topology view (if these switches are connected to any other networking devices)
    • Output of show cdp nei
    • Output of show spanning-tree
    • Output of show vtp status
  4. Shutdown interface and then no shut the interface. Check the logging message on both the switches.

With this certainly you would be in position to identify the close the problem.

With regards,



Pls provide "show  spanning-tree vlan 880" on both switches and interface output of both sides ,

Can u also verify on another port so that physical layer problem can be outlined.

Also configure switch mode access on both interfaces because by default mode is dynamic desirable and

sometimes "swichport access vlan 880" alone doesn't work.

If you already solved kindly provide the soultion.


Could you pls check the VLAN configuration and the VTP status of the switches.

I think there could be issue with the VTP mode.


Perhaps you could configure the inter-switch ports as access ports with the "switchport mode access" interface subcommand.  This would prevent them from trying to negotiate a trunk if you are only needing to carry one vlan across the switch link.  Using the "switchport access vlan x" interface subcommand applies when the ports are access ports, so you still need it.



I guess port 8 on  Old and port 17 on new needs to be configured as trunk port.




  If you do a show vlan does vlan 880 show up as a active vlan with ports in it ?  If not then you did not create the layer 2 vlan for vlan 880 .  At the config command prompt just type vlan 880 then end .  The do  a show vlan again  , if it shows active with the port  that you want to connect to the other switch then there is no reason for it not to work.