cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
1062
Views
0
Helpful
3
Replies
Fernando_Meza
Rising star

Unable to add another spanning-tree VLAN instance !!!

Hi Netpros,

I am just trying to add several VLANs to run spanning-tree. Spanning-tree instances have being limited by the command no spanning-tree ... as below. I am unable to modify this command in order to allow VLANS 5,50 and 150 as spanning-instances .. any help is much appreciated.

no spanning-tree vlan 2-10,12-19,21-100,102-4094

spanning-tree vlan 1,5,11,20,50,101,150 priority 24576

IOS version;

Cisco IOS Software, C3560 Software (C3560-IPBASE-M), Version 12.2(25)SEB2, RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2005 by Cisco Systems, Inc.

Compiled Tue 07-Jun-05 23:34 by yenanh

ROM: Bootstrap program is C3560 boot loader

BOOTLDR: C3560 Boot Loader (C3560-HBOOT-M) Version 12.2(25r)SEA, RELEASE SOFTWARE (fc)

SW_3560_LVL1_01 uptime is 3 weeks, 21 hours, 29 minutes

System returned to ROM by power-on

System restarted at 17:50:15 AEDT Sun Feb 17 2008

System image file is "flash:c3560-ipbase-mz.122-25.SEB2/c3560-ipbase-mz.122-25.SEB2.bin"

3 REPLIES 3
shahnawaz.khot
Beginner

You don't require to negate spanning-tree commands for existing vlans. You can execute a command

spanning-tree vlan priority <>

to configure any additional vlan for spanning-tree.

New vlans will be added in the list of configured spanning-tree priority.

mahmoodmkl
Rising star

HI

If u see u r config

no spanning-tree vlan 2-10,12-19,21-100,102-4094 it is covering all the vlan for which u r trying to enable spanning-tree.I think first remove this vlans from this range and enable spanning-tree on this vlans.

Thanks

Mahmood

Thanks ...

These are the original commands as shown on the config:

no spanning-tree vlan 2-10,12-19,21-100,102-4094

spanning-tree vlan 1,11,20,101 priority 24576

I am trying to add VLAN 5, 50 and 150

1.- If I type in spanning-tree vlan 1,5,11,20,50,101,150 priority 24576. The command takes it however there is no changes to the command "no spanning-tree vlan 2-10,12-19,21-100,102-4094".

2.- I then try and type "no spanning-tree vlan 2-4,6-10,12-19,21-49,51-100,102-144,151-4094" The command is taken however it does not change the output which stills shows "no spanning-tree vlan 2-10,12-19,21-100,102-4094" and so I am still unable to create the STP instances for VLAN 5,50 and 150.

So the command I posted originally are the ones AFTER trying already to add VLAN 5,50,and 150