Showing results for 
Search instead for 
Did you mean: 

unable to add vrf to Vlan interface


Running 3750 in stack Version 15.0(2)SE2

I am geting error when trying to add vrf vlan int

switch(config)#interface Vlan101

switch(config-if)#ip vrf forwarding dummy

% CEF table 0x6 does not exist (Vlan101).


Please help

8 Replies 8

Jon Marshall
Hall of Fame
Hall of Fame

Did you create the vrf first ie.

switch(config)# ip vrf

also you need the IP Services or Advanced IP Services feature set on your switch.


Yes i did

switch#sh run vrf dummy
Building configuration...

Current configuration : 360 bytes
ip vrf dummy rd 65529:1
route-target export 65529:1
route-target import 65529:1


Regarding your 2nd query

switch#sh license
Index 1 Feature: ipservices
        Period left: Life time
        License Type: Permanent
        License State: Active, In Use
        License Priority: Medium
        License Count: Non-Counted

Do you have CEF enabled on your switch?

#show ip cef

Yes Cef is by default on the switch i believe

switch#sh ip cef

Prefix               Next Hop             Interface             FastEthernet0            drop           receive        attached             FastEthernet0        receive              FastEthernet0        attached             FastEthernet0        attached             FastEthernet0       attached             FastEthernet0       attached             FastEthernet0       attached             FastEthernet0       receive              FastEthernet0      receive              FastEthernet0      receive              Virtual3          drop          drop         receive          drop   receive



Did you ever get a fix for this issue? I have the same issue, recently licensed to IP Services image to be able to configure VRF lite im running on the exact same image as yours 15.0(2)SE2.

% CEF table 0x2 does not exist (Vlan1901).


I raised with our support who escalated to Cisco, they reported they couldn't re-create the fault and requested a reload of the stack which I have done but hasn't clear the fault?





We are having number of switches with same IOS but facinf the problem on one of those.

Certainly unusual..

You could try recreating the VLAN interface. Also ensure the Layer 2 VLAN is created.

I have tried to delete vrf and vlans.

Tried it ont another vlan interface but same error

Tried creating vrf using vrf defination.

getting same erro when tring to add vrf to loopback interface too,

switch(config)#interface Loopback1

switch(config-if)#ip vrf forwarding test

% CEF table 0x9 does not exist (Loopback1).


Cant reboot have to get a pew window.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: