cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
209
Views
0
Helpful
4
Replies

Unable to pass switch traffic trough nexus N7K-M348XP-25L

Hi,

A customer just bought a few N7K-M348XP-25L so i bring one into my lab to test the basic capabilities (customer request) with traffic generators (spirent and viavi).

 

The issue that i'm experiencing is that the interfaces receive traffic but not transmit it and right now i'm out of clues whenever is that the traffic is not going trough the card/fabric or is anything else.

 

Could somebody with experience in that linecard point out if there is any special configuration that need to be done.

 

Regards,

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Unable to pass switch traffic trough nexus N7K-M348XP-25L

Hi Again Georg,

 

I just did another test changing some parameters in our spirent and finally i got it to work, looks like this card is more picky than the rest in term of traffic.

 

Normally i never specify next protocol for the traffic generator as it work like a charm doing raw packets, in this case after specifying ICMP as next protocol and ECHO as the packet itself is working fine.

 

Thanks for your help.

 

 

4 REPLIES 4
VIP Mentor

Re: Unable to pass switch traffic trough nexus N7K-M348XP-25L

Hello,

 

hard to say what you are missing, can you post the running config ? Make sure your VLANs are active, below is a sample:

 

N7K# configure terminal
N7K(config)# vlan 2
N7K(config-vlan)# name DATA
N7K(config-vlan)# state active
N7K(config-vlan)# no shutdown

 

N7K# configure terminal
N7K(config)# interface ethernet 1/10
N7K(config-if)# switchport access vlan 2
N7K(config-if)# spanning-tree portfast

Re: Unable to pass switch traffic trough nexus N7K-M348XP-25L

Hi Georg,

 

Here is the show of the interfaces connected to the spirent traffic generator, ports are configured as access as you can see in attached config file.

 

This is the most basic config that i can imagine to get it up and running.

 

 

switch# show inter eth8/10
Ethernet8/10 is down (SFP not inserted)
admin state is up, Dedicated Interface
Hardware: 1000/10000 Ethernet, address: 6cdd.30eb.5099 (bia 6cdd.30eb.5099)
MTU 9216 bytes, BW 10000000 Kbit, DLY 10 usec
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, medium is broadcast
Port mode is access
auto-duplex, auto-speed
Beacon is turned off
Auto-Negotiation is turned on
Input flow-control is off, output flow-control is off
Auto-mdix is turned off
Switchport monitor is off
EtherType is 0x8100
EEE (efficient-ethernet) : n/a
Last link flapped never
Last clearing of "show interface" counters 00:02:18
0 interface resets
Load-Interval #1: 30 seconds
30 seconds input rate 0 bits/sec, 0 packets/sec
30 seconds output rate 0 bits/sec, 0 packets/sec
input rate 0 bps, 0 pps; output rate 0 bps, 0 pps
Load-Interval #2: 5 minute (300 seconds)
300 seconds input rate 0 bits/sec, 0 packets/sec
300 seconds output rate 0 bits/sec, 0 packets/sec
input rate 0 bps, 0 pps; output rate 0 bps, 0 pps
RX
0 unicast packets 0 multicast packets 0 broadcast packets
0 input packets 0 bytes
0 jumbo packets 0 storm suppression packets
0 runts 0 giants 0 CRC/FCS 0 no buffer
0 input error 0 short frame 0 overrun 0 underrun 0 ignored
0 watchdog 0 bad etype drop 0 bad proto drop 0 if down drop
0 input with dribble 0 input discard
0 Rx pause
TX
0 unicast packets 0 multicast packets 0 broadcast packets
0 output packets 0 bytes
0 jumbo packets
0 output error 0 collision 0 deferred 0 late collision
0 lost carrier 0 no carrier 0 babble 0 output discard
0 Tx pause

switch# show inter eth8/17
Ethernet8/17 is up
admin state is up, Dedicated Interface
Hardware: 1000/10000 Ethernet, address: 6cdd.30eb.50a0 (bia 6cdd.30eb.50a0)
MTU 9216 bytes, BW 10000000 Kbit, DLY 10 usec
reliability 255/255, txload 1/255, rxload 5/255
Encapsulation ARPA, medium is broadcast
Port mode is access
full-duplex, 10 Gb/s, media type is 10G
Beacon is turned off
Auto-Negotiation is turned on
Input flow-control is off, output flow-control is off
Auto-mdix is turned off
Rate mode is dedicated
Switchport monitor is off
EtherType is 0x8100
EEE (efficient-ethernet) : n/a
Last link flapped 00:08:57
Last clearing of "show interface" counters 00:02:28
0 interface resets
Load-Interval #1: 30 seconds
30 seconds input rate 201105952 bits/sec, 17949 packets/sec
30 seconds output rate 0 bits/sec, 0 packets/sec
input rate 201.10 Mbps, 17.95 Kpps; output rate 0 bps, 0 pps
Load-Interval #2: 5 minute (300 seconds)
300 seconds input rate 307434616 bits/sec, 21401 packets/sec
300 seconds output rate 24 bits/sec, 0 packets/sec
input rate 307.43 Mbps, 21.40 Kpps; output rate 24 bps, 0 pps
RX
5281405 unicast packets 0 multicast packets 0 broadcast packets
5281435 input packets 7394882600 bytes
0 jumbo packets 0 storm suppression packets
0 runts 0 giants 0 CRC/FCS 0 no buffer
0 input error 0 short frame 0 overrun 0 underrun 0 ignored
0 watchdog 0 bad etype drop 0 bad proto drop 0 if down drop
0 input with dribble 0 input discard
0 Rx pause
TX
44 unicast packets 2 multicast packets 0 broadcast packets
2 output packets 438 bytes
0 jumbo packets
0 output error 0 collision 0 deferred 0 late collision
0 lost carrier 0 no carrier 0 babble 0 output discard
0 Tx pause

switch# show inter eth8/33
Ethernet8/33 is up
admin state is up, Dedicated Interface
Hardware: 1000/10000 Ethernet, address: 6cdd.30eb.50b0 (bia 6cdd.30eb.50b0)
MTU 9216 bytes, BW 10000000 Kbit, DLY 10 usec
reliability 255/255, txload 1/255, rxload 3/255
Encapsulation ARPA, medium is broadcast
Port mode is access
full-duplex, 10 Gb/s, media type is 10G
Beacon is turned off
Auto-Negotiation is turned on
Input flow-control is off, output flow-control is off
Auto-mdix is turned off
Rate mode is dedicated
Switchport monitor is off
EtherType is 0x8100
EEE (efficient-ethernet) : n/a
Last link flapped 00:05:26
Last clearing of "show interface" counters 00:02:45
0 interface resets
Load-Interval #1: 30 seconds
30 seconds input rate 130844688 bits/sec, 11632 packets/sec
30 seconds output rate 56 bits/sec, 0 packets/sec
input rate 130.84 Mbps, 11.63 Kpps; output rate 56 bps, 0 pps
Load-Interval #2: 5 minute (300 seconds)
300 seconds input rate 286079584 bits/sec, 20231 packets/sec
300 seconds output rate 24 bits/sec, 0 packets/sec
input rate 286.08 Mbps, 20.23 Kpps; output rate 24 bps, 0 pps
RX
5512767 unicast packets 0 multicast packets 0 broadcast packets
5512763 input packets 7717868200 bytes
0 jumbo packets 0 storm suppression packets
0 runts 0 giants 0 CRC/FCS 0 no buffer
0 input error 0 short frame 0 overrun 0 underrun 0 ignored
0 watchdog 0 bad etype drop 0 bad proto drop 0 if down drop
0 input with dribble 0 input discard
0 Rx pause
TX
4 unicast packets 3 multicast packets 0 broadcast packets
3 output packets 657 bytes
0 jumbo packets
0 output error 0 collision 0 deferred 0 late collision
0 lost carrier 0 no carrier 0 babble 0 output discard
0 Tx pause

switch#

 

 

Thanks for your help,

Highlighted

Re: Unable to pass switch traffic trough nexus N7K-M348XP-25L

Hi Again Georg,

 

I just did another test changing some parameters in our spirent and finally i got it to work, looks like this card is more picky than the rest in term of traffic.

 

Normally i never specify next protocol for the traffic generator as it work like a charm doing raw packets, in this case after specifying ICMP as next protocol and ECHO as the packet itself is working fine.

 

Thanks for your help.

 

 

VIP Mentor

Re: Unable to pass switch traffic trough nexus N7K-M348XP-25L

Good to hear that you got it working...:)

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards