cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
3160
Views
0
Helpful
2
Replies
benlemasurier
Beginner

VLAN interface won't come up

I have a few 2921 routers, they all have almost the same configuration (different subnets), on one of them I can't get the vlan interface (Vlan10) to come up, any thoughts??

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname a-gw

!

boot-start-marker

boot system flash c1900-universalk9-mz.SPA.151-4.M.bin

boot-end-marker

!

aaa new-model

!

!

!

!

!

!

!

aaa session-id common

clock timezone GMT -7 0

!

no ipv6 cef

ip source-route

ip cef

!

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.20.1 192.168.20.20

!

ip dhcp pool PRIMARY

network 192.168.20.0 255.255.255.0

dns-server 192.168.0.77

default-router 192.168.20.1

!

ip dhcp pool WIRELESS

network 192.168.21.0 255.255.255.0

dns-server 8.8.8.8

default-router 192.168.21.1

!

!

ip name-server 192.168.0.77

multilink bundle-name authenticated

!

password encryption aes

crypto pki token default removal timeout 0

!

!

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

ip address 192.168.0.20 255.255.252.0

ip flow ingress

ip flow egress

ip virtual-reassembly in

duplex auto

speed auto

no mop enabled

!

interface GigabitEthernet0/1

ip address 192.168.20.1 255.255.255.0

ip flow ingress

ip flow egress

ip virtual-reassembly in

duplex auto

speed auto

!

interface GigabitEthernet0/0/0

switchport access vlan 10

no ip address

!

interface GigabitEthernet0/0/1

no ip address

!

interface GigabitEthernet0/0/2

no ip address

!

interface GigabitEthernet0/0/3

no ip address

!

interface Vlan1

no ip address

!

interface Vlan10

ip address 192.168.21.1 255.255.255.0

ip access-group WIRELESS in

ip access-group WIRELESS out

ip virtual-reassembly in

!

!

router eigrp 10

network 192.168.0.0 0.0.3.255

network 192.168.20.0

network 192.168.21.0

!

ip default-gateway 192.168.0.1

ip forward-protocol nd

!

ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 192.168.0.1

!

ip access-list extended WIRELESS

permit ip host 192.168.21.2 any

deny   ip any 192.168.0.0 0.0.3.255

permit ip any any

!

access-list 23 permit 10.10.10.0 0.0.0.63

access-list 23 permit 192.168.0.0 0.0.255.255

!

!

snmp-server community public RO

!

!

!

control-plane

!

!

banner login 

!

line con 0

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

transport input ssh

line vty 5 15

access-class 23 in

transport input ssh

!

scheduler allocate 20000 1000

ntp update-calendar

ntp peer 91.189.94.4

end

# sh ip int bri

GigabitEthernet0/0         192.168.0.20    YES NVRAM  up                    up     

GigabitEthernet0/1         192.168.20.1    YES NVRAM  up                    up     

GigabitEthernet0/0/0       unassigned      YES unset  up                    up     

GigabitEthernet0/0/1       unassigned      YES unset  down                  down   

GigabitEthernet0/0/2       unassigned      YES unset  down                  down   

GigabitEthernet0/0/3       unassigned      YES unset  down                  down   

Vlan1                      unassigned      YES unset  down                  down   

Vlan10                     192.168.21.1    YES NVRAM  down                  down 

2 REPLIES 2
benlemasurier
Beginner

well, I'm not sure why, but I did the following:

a-gw#config t

Enter configuration commands, one per line.  End with CNTL/Z.

a-gw(config)#interface gigabitEthernet 0/0/0

a-gw(config-if)#no switchport access vlan 10

a-gw(config)#interface gigabitEthernet 0/0/0

a-gw(config-if)#switchport access vlan 10     

% Access VLAN does not exist. Creating vlan 10

This fixed the issue!

t_mcwilliams
Beginner

Is vlan10 showing in the vlan database?