cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

7515
Views
10
Helpful
3
Replies
Highlighted
Beginner

vPC from FEX interfaces

I am trying to create a vPC port-channel for two different FEX interfaces. We have two Nexus 5000 series switches connected via vPC and FEX 106 and 107 each with a connection to our Nexus 5000 switches (proda1 and proda2) connected via port-channel and vPC.

The following configuration is working at the moment:

interface port-channel201

  description pdxnas03

  switchport access vlan 100

interface Ethernet106/1/31

  description pdxnas03-e1a

  switchport access vlan 100

  speed auto

  channel-group 201 mode passive

interface Ethernet107/1/31

  description pdxnas03-e2a

  switchport access vlan 100

  speed auto

  channel-group 201 mode passive

interface port-channel202

  description pdxnas04

  switchport access vlan 100

interface Ethernet106/1/32

  description pdxnas04-e1a

  switchport access vlan 100

  speed auto

  channel-group 202 mode passive

interface Ethernet107/1/32

  description pdxnas04-e2a

  switchport access vlan 100

  speed auto

  channel-group 202 mode passive

Per this Cisco document I had attempted to port-channel201 in vpc 201 and port-channel202 in vpc 202 yet receive this error no matter how I try it:

ERROR: Operation failed: [vPC already exists]

When attempting to look up any details for vpc 201 or 202 the system says it does not exist yet I still get the above error. When I issue the followign commands I get the results below.

Command: show interface port-channel201

Pertinent Portion: vPC Status: Up, vPC number: 262344

Command: show interface port-channel202

Pertinent Portion: vPC Status: Up, vPC number: 262345

Can anyone explain what is going on here? The document I followed is the same I have followed when configuring vPC port-channel interfaces for all my FEX units. I have tried making these vPC with and without LACP.

Any advice or knowledge on helping me understand this would be greatly appreciated.

Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Cisco Employee

vPC from FEX interfaces

So from my understanding you have something similar to the following topology

http://www.cisco.com/en/US/i/300001-400000/330001-340000/331001-332000/331179.jpg

If so, then you do not need to VPC the port-channels off the FEX, as they are already VPC on the 5k side

For example:

Step 7

Configure a host port channel on each FEX

Example:

NX-5000-1(config)# interface eth101/1/1, eth101/1/2
NX-5000-1(config-if)# channel-group 2 mode active
NX-5000-1(config-if)# interface eth102/1/1, eth102/1/2
NX-5000-1(config-if)# channel-group 2 mode active
NX-5000-1(config-if)# int po2
NX-5000-1(config-if)# switchport access vlan 10

NX-5000-2(config)# interface eth101/1/1, eth101/1/2
NX-5000-2(config-if)# channel-group 2 mode active
NX-5000-2(config-if)# interface eth102/1/1, eth102/1/2
NX-5000-2(config-if)# channel-group 2 mode active
NX-5000-2(config-if)# int po2
NX-5000-2(config-if)# switchport access vlan 10

This can be found in the following document.

http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/layer2/513_n1_1/b_Cisco_n5k_layer2_config_gd_rel_513_N1_1_chapter_01010.html

View solution in original post

3 REPLIES 3
Highlighted
Cisco Employee

vPC from FEX interfaces

So from my understanding you have something similar to the following topology

http://www.cisco.com/en/US/i/300001-400000/330001-340000/331001-332000/331179.jpg

If so, then you do not need to VPC the port-channels off the FEX, as they are already VPC on the 5k side

For example:

Step 7

Configure a host port channel on each FEX

Example:

NX-5000-1(config)# interface eth101/1/1, eth101/1/2
NX-5000-1(config-if)# channel-group 2 mode active
NX-5000-1(config-if)# interface eth102/1/1, eth102/1/2
NX-5000-1(config-if)# channel-group 2 mode active
NX-5000-1(config-if)# int po2
NX-5000-1(config-if)# switchport access vlan 10

NX-5000-2(config)# interface eth101/1/1, eth101/1/2
NX-5000-2(config-if)# channel-group 2 mode active
NX-5000-2(config-if)# interface eth102/1/1, eth102/1/2
NX-5000-2(config-if)# channel-group 2 mode active
NX-5000-2(config-if)# int po2
NX-5000-2(config-if)# switchport access vlan 10

This can be found in the following document.

http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/layer2/513_n1_1/b_Cisco_n5k_layer2_config_gd_rel_513_N1_1_chapter_01010.html

View solution in original post

Highlighted
Beginner

vPC from FEX interfaces

Yes! Thank you Colby Beam. Was not aware I have enhanced vPC here. This makes a lot of sense now given the errors I was getting back.

Highlighted
Cisco Employee

vPC from FEX interfaces

Great! Could you mark this as resolved, so it helps other people in the future as well?

CreatePlease to create content
Content for Community-Ad