cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

171
Views
0
Helpful
2
Replies
Beginner

VRF Routing

Hallo All , 

 

I am not not able to ping from vrf to external networks , anyone could guide me. 


vrf definition lan
!
address-family ipv4
exit-address-family
!
vrf definition prov-pri
!
address-family ipv4
exit-address-family
!
vrf definition prov-sec
!
address-family ipv4
exit-address-family
!
!
!
interface FastEthernet0/0
vrf forwarding prov-pri
ip address 13.13.13.1 255.255.255.0
duplex full
!
interface FastEthernet1/0
vrf forwarding prov-sec
ip address 12.12.12.1 255.255.255.0
duplex full
!
interface FastEthernet2/0
vrf forwarding lan
no ip address
speed auto
duplex auto
!
interface FastEthernet2/0.100
encapsulation dot1Q 100
vrf forwarding lan
ip address 192.168.100.1 255.255.255.0
!
interface FastEthernet2/0.200
encapsulation dot1Q 200
vrf forwarding lan
ip address 192.168.200.1 255.255.255.0


R1# show ip vrf
Name Default RD Interfaces
lan <not set> Fa2/0
Fa2/0.100
Fa2/0.200
prov-pri <not set> Fa0/0
prov-sec <not set> Fa1/0

 


R1#show ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 13.13.13.1 YES manual up up
FastEthernet1/0 12.12.12.1 YES manual up up
FastEthernet2/0 unassigned YES unset up up
FastEthernet2/0.100 192.168.100.1 YES manual up up
FastEthernet2/0.200 192.168.200.1 YES manual up up
FastEthernet2/1 unassigned YES unset administratively down down
R1#show run | sec ip rotue
R1#show run | sec ip route
ip route vrf lan 0.0.0.0 0.0.0.0 FastEthernet0/0 13.13.13.3
ip route vrf lan 0.0.0.0 0.0.0.0 FastEthernet1/0 12.12.12.2 20
ip route vrf lan 13.13.13.1 255.255.255.255 FastEthernet0/0 13.13.13.3
ip route vrf prov-pri 0.0.0.0 0.0.0.0 13.13.13.3
ip route vrf prov-sec 0.0.0.0 0.0.0.0 12.12.12.2
R1#show run | sec ip router
R1#show run | sec router
router eigrp 100
network 192.168.100.0
network 192.168.200.0
R1#


R1#ping vrf prov-pri 13.13.13.3 source fast
R1#ping vrf prov-pri 13.13.13.3 source fastEthernet 2/0.100
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 13.13.13.3, timeout is 2 seconds:
Packet sent with a source address of 192.168.100.1
.....
Success rate is 0 percent (0/5)
R1#ping vrf prov-pri 13.13.13.3 source fastEthernet 2/0.200
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 13.13.13.3, timeout is 2 seconds:
Packet sent with a source address of 192.168.200.1
.....
Success rate is 0 percent (0/5)
R1#ping vrf lan 192.168.100.254
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.254, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/7/32 ms
R1#ping vrf lan 192.168.200.254
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.200.254, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/15/40 ms
R1#ping vrf prov-pri 4.4.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/64/120 ms
R1#ping vrf prov-sec 4.4.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/52/68 ms
R1#


R1#ping vrf prov-pri 13.13.13.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 13.13.13.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/27/36 ms
R1#ping vrf prov-pri 13.13.13.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 13.13.13.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R1#ping vrf prov-sec 12.12.12.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.12.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R1#ping vrf prov-sec 12.12.12.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.12.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/21/36 ms
R1#ping vrf lan 13.13.13.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 13.13.13.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R1#ping vrf lan 13.13.13.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 13.13.13.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R1#ping vrf prov-sec 4.4.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/80/136 ms
R1#ping vrf prov-pri 4.4.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/71/96 ms
R1#

With Regards

 

2 REPLIES 2
VIP Advisor

Re: VRF Routing

Hi,

It will not able to communicate because they are on different VRF instances, separated routing tables:

 

interface FastEthernet0/0
vrf forwarding prov-pri
ip address 13.13.13.1 255.255.255.0
duplex full

!
interface FastEthernet2/0.100
encapsulation dot1Q 100
vrf forwarding lan
ip address 192.168.100.1 255.255.255.0

It could communicate between each other if you are importing the subnets into each others, currently they should not have the prefixes entries into their routing tables. 

 

:-)

Collaborator

Re: VRF Routing

Hi,

What does you topology look like? Where are these addresses: 13.13.13.3, 12.12.12.2

 

Thanks

John

**Please rate posts you find helpful**
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards