cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4034
Views
0
Helpful
8
Replies

Problem with Expressway SRV records

HeribertoVV
Level 1
Level 1

Hello,

I have an Expressway deployment v8.9.2 with CUCM/IMP 11.5. We are using single-NIC and dual domain, one internal and one external.

We have our Unified Communication Traversal zone active. Expressway-C is pointing to the public IP address of Expressway-E.

When someone tries to log-in, Jabber asks for the password and, if wrong it says "password wrong...", but if right, it says "cannot locate the sever". I am receiving this error:

2017-05-23T17:26:22.486-05:00 edgeconfigprovisioning: Level="WARN" Detail="Service not found for edge config response" Service="_cisco-uds" User="fmixtega" UTCTime="2017-05-23 22:26:22,485"
2017-05-23T17:26:22.486-05:00 edgeconfigprovisioning: Level="WARN" Detail="Service not found for edge config response" Service="_cuplogin" User="fmixtega" UTCTime="2017-05-23 22:26:22,485"


1. My client doesn't have external.domain and internal.domain "folders" in their INTERNAL DNS server. So, the SRV records they have in their internal DNS server are: cuplogin, cisco-uds, sip, sips, h323 (all in internal.domian folder). Is it mandatory to have cisco-uds and cuploging in an external.domain folder in the internal DNS server?

2. For the peer in the Unified Communication zone we have expe.internal.domain which is resolved to the public IP Address. Could this configuration have an effect in this errors we are facing? With other clients I use to resolve the public IP address to expe.external.domain (example).

External DNS server are configured in Expressway-E and internal DNS servers in Expressway-C (DNS config).

8 Replies 8

Patrick Sparkman
VIP Alumni
VIP Alumni

Alok Jaiswal
Level 4
Level 4

You don't need "cisco-uds and cuploging srv records in an external.domain" on internal DNS server.

But its important that the zone you are pointing to, that FQDN must be externally resolvable. For e.g. if i am pointing my UC traversal client zone to "exp-e.internal.domain", then this would be sent out to Jabber login via MRA over Exp-E, and when it tries to connection "exp-e.internal.domain" it might fail from public side and then jabber login will also fails.

Regards,

Alok 

alex.kanaykin
Level 1
Level 1
Hi, HeribertoVV.
Do you solve this problem?
edgeconfigprovisioning: Level="WARN" Detail="Service not found for edge config response" Service="_cuplogin" User="('username', 'test')" UTCTime="2017-12-18 07:52:51,222"

Is MRA configured per the multi-domain example linked earlier in the thread?

Thanks, for answering. I've find solution.
It was dns misconfig. One I had to note. Reverse lookup for EXP-E must
exist in internal dns. External ip for external fqdn. Spend couple of hours
in debugs to resolve. It's OK for now. Thanks again. Sorry for bad
language.

Hi, I'm facing the same issue now, May I have more detail on DNS configuration? thanks

@ctohang99 Please have a look at the document that @Patrick Sparkman shared in his response as the information about what is needed in the DNS should be covered in it. If you still have questions or issues I suggest that you create your own post to ask your question(s) as that would likely get you a better chance of getting the help that you need.



Response Signature


alex.kanaykin
Level 1
Level 1