10-07-2011 05:59 AM - edited 03-17-2019 10:32 PM
Hi guys,
i'm doing some pre sale testing for a customer. he wants to use cisco router as a sip proxy. either in CME mode or as a ip2ip gw.
i tried 2 configurations with the clients SIP softphone.
1. CME config while i register the sip softphones.
2. ip2ip gw while i use dial peer voip with session protocol sipv2 to point to the ip add for the extension.
tests were doing great up untill the calee tried to hang up.
when the callee hangs up, a bye msg is sent to the router and the callee leg disconnects but the bye msg never gets to the caller!
and this leg stays up. i run several debugs including debug ccsip all and saw no errors. it seems like the router is fine with everything.
i never have a problem while the caller hangs up. the session ends just fine on both call legs.
this happens both in CME and ip2ip configurations.
i've tried the same with another softphone and everything was working great!
the only difference i saw was this:
on the other softphone i used, the BYE message that was generated by the callee had a CSEQ value greater than the INVITE (generated by the caller).
on the clients softphone the CSEQ of the BYE message (from the callee) was initial. ie- 1.
i've done some research on the issue and everything works out just fine by IETF rules.
since the INVITE came from the caller with CSEQ 1, if the caller would send the BYE it should have had CSEQ 2, but since
its the callee that sends the BYE and this is the first initiation from its behalf, CSEQ indeed should be 1.
any thoughts about this?
10-08-2011 10:18 AM
What is the IOS version used on your router?
Post also the config.
Regards.
10-09-2011 06:39 AM
I use IOS
c2801-advipservicesk9-mz.124-24.T5.bin
with the following config (please note that cme and dial-peers are not configured at the same time...)
R_Main-Site-A#sh run
Building configuration...
Current configuration : 10702 bytes
!
! Last configuration change at 14:52:13 UTC Wed Oct 5 2011
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service sequence-numbers
!
hostname R_Main-Site-A
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
aaa new-model
!
!
aaa authentication login default local
!
!
aaa session-id common
network-clock-participate wic 2
network-clock-select 1 E1 0/2/0
dot11 syslog
ip source-route
!
ip cef
no ip domain lookup
ip domain name vc.lab
ip multicast-routing
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-net5
!
!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
redirect ip2ip
fax protocol cisco
h323
h225 timeout setup 3
sip
bind control source- interface FastEthernet0/1.501
bind media source- interface FastEthernet0/1.501
header-passing
registrar server
!
!
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729r8
!
!
!
!
voice class h323 1
h225 timeout tcp establish 3
!
!
!
!
!
!
!
!
!
voice register global
mode cme
source-address 172.16.10.253 port 5060
max-dn 144
max-pool 24
!
voice register dn 1
number 710
!
voice register dn 2
number 720
!
voice register dn 3
number 730
!
voice register pool 1
busy-trigger-per-button 50
id mac 5CFF.350C.16E3
number 1 dn 1
!
voice register pool 2
busy-trigger-per-button 50
id mac 0014.5E6B.1564
number 1 dn 2
voice-class codec 1
!
voice register pool 3
busy-trigger-per-button 50
id mac 0021.5ACB.40C2
number 1 dn 3
voice-class codec 1
!
!
!
controller E1 0/2/0
pri-group timeslots 1-4,16 service mgcp
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.11
encapsulation dot1Q 11
ip address 172.16.11.253 255.255.255.0
!
interface FastEthernet0/1.501
encapsulation dot1Q 501
ip address 172.16.10.253 255.255.255.0
!
interface Serial0/1/0
no ip address
encapsulation frame-relay
no fair-queue
clock rate 2000000
frame-relay lmi-type cisco
!
interface Serial0/1/0.16 point-to-point
description ****** Connected To Site-C Serial 0/1/0 ******
ip address 10.10.10.1 255.255.255.252
ip pim dense-mode
snmp trap link-status
frame-relay interface-dlci 16
!
interface Serial0/1/1
no ip address
encapsulation frame-relay
no fair-queue
!
interface Serial0/1/1.17 point-to-point
description ****** Connected To Site-B Serial 0/1/0 ******
ip address 10.10.10.6 255.255.255.252
ip pim dense-mode
snmp trap link-status
frame-relay interface-dlci 17
!
interface Serial0/2/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
isdn bind-l3 ccm-manager
no cdp enable
!
ip local pool SSLVPNphone_pool 172.16.10.80 172.16.10.90
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.16.10.254
ip route 172.16.10.0 255.255.255.0 FastEthernet0/1
ip route 172.16.30.0 255.255.255.0 10.10.10.2
ip http server
ip http authentication local
ip http secure-server
!
!
!
ip sla responder
disable-eadi
!
!
!
!
!
snmp-server community read RO
snmp-server community write RW
snmp-server community public RO
!
control-plane
!
!
!
dial-peer voice 999 voip
destination-pattern 700
session protocol sipv2
session target ipv4:172.16.10.2
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 998 voip
destination-pattern 705
session protocol sipv2
session target ipv4:172.16.10.1
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 996 voip
destination-pattern 702
session protocol sipv2
session target ipv4:172.16.10.3
dtmf-relay sip-notify
codec g711ulaw
!
dial-peer voice 995 voip
destination-pattern 703
session protocol sipv2
session target ipv4:172.16.10.210
dtmf-relay sip-notify
codec g711ulaw
!
dial-peer voice 994 voip
destination-pattern 704
session protocol sipv2
session target ipv4:172.16.10.200
dtmf-relay sip-notify
codec g711ulaw
!
dial-peer voice 993 voip
destination-pattern 706
session protocol sipv2
session target ipv4:172.16.10.201
dtmf-relay sip-notify
codec g711ulaw
!
dial-peer voice 992 voip
destination-pattern 701
session protocol sipv2
session target ipv4:172.16.10.100
dtmf-relay sip-notify
codec g711ulaw
!
!
sip-ua
registrar ipv4:172.16.10.253 expires 3600
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
line vty 5 15
privilege level 15
!
scheduler allocate 20000 1000
ntp master
ntp server 172.16.10.253
!
!
end
10-13-2011 11:58 AM
Can you add the debug ccsip messages output?
Regards.
11-10-2011 05:21 AM
please post the sip debugs or sniffer capture for the call.
debugs
simple
debug ccsip messages
advanced
deb ccsip all <
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide