Showing results for 
Search instead for 
Did you mean: 

Telepresence endpoints directory search

Matthieu LIENART

I tried to look the forum and the web but couldn't find anything that relates to my problem.

Our Telepresence endpoints (TC6) are registered on the CUCM. So they pull the directory from the CUCM which (because we change the LDAP sync filter to also include disabled AD rooms accounts) contains the list of both employees and meeting/telepresence/video-conference rooms.

So the directory contains a lot of contacts.

The problem we have is that the directory search is totaly unfriendly. It only shows contacts which have the first or last name STARTING by the letters typed in the search field.

It doesn't show contacts which CONTAINS the letters typed.

For example if I want to look for all Telepresence rooms I would type in the word "Telepresence".

Our rooms are named like City-Building-Floor-Telepresence

So the search won't return any result.

Is there a way to change that behavior somewhere?

6 Replies 6

Wayne DeNardi
VIP Alumni
VIP Alumni

Hi Matthieu,

I've just tried doing a directory search on both an EX90 and a C60 I have here in my lab (both running TC6.3), and both of them search the way you want them to, not just by the starting letters...  (Note: I'm not getting my directory from CUCM, but instead from TMS).



Please remember to rate responses and to mark your question as answered if appropriate.

Please remember to mark helpful responses and to set your question as answered if appropriate.

HI Matt.  What version of CCM and TC are you running? Says TC6, not sure TC6.3 or lower etc...



Hi Matt.  Hate to ask this, but the dashes may be inhibiting you on the search (Just thinking out loud).  If you have one room, that you can remove the dashes from, does your search yield the results or no?



The CUCM is now in version 9.1.2 and still the same behavior.

endpoint EX 90 TC6.2.1

I'll test the dash and let you know. I have the feeling that it will work but it then goes back to what I was saying is that the search only works as a "start from" for each word. If in the object name you have the word "Telepresence" and try to search for "Tele", it will gives back all results with a word starting with "Tele" in their name but if you search for "presence" it will not display any result.

Actually, I looked at the calls to/from UCM when I was developing my own custom directory and I believe that the corporate directory application that is built into CUCM is treating the queries as "starts with" not "contains". So, I think it is behaving as designed. Which I know doesn't help.

(t) @ucguerrilla

Please remember to rate helpful responses and identify helpful or correct answers.

HTH -Bill (b) (t) @ucguerrilla

Please remember to rate helpful responses and identify

I try by removing the dash and putting spaces and it is still the same. It only makes a "start with" search from firstname or lastname of the CUCM directory, which is not user friendly.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: