Showing results for 
Search instead for 
Did you mean: 

VCS "Failed to register to external manager" --> TMS


Hello exprerts,

I am trying to add VCS to TMS.

From the TMS connection is sucessfull and i am able to add the VCS to TMS.

But when i go the to the VCS --> External Manager.

Status (last updated: 23:29:56 EDT)
ReasonFailed to register to external manager

I have tried to purge the VCS out and re add it.

Checked the network settings to see if secure device communication is off

Rebooted the VCS

Path looks to be correct

Certificatoin verification mode on VCS is : OFF

Not sure what else to check.

Any help will be appreciated.

6 Replies 6

Martin Koch
VIP Alumni
VIP Alumni

Hi Guji!

Is there a firewall or NAT in between the VCS and the TMS?

There shall be no NAT and the VCS needs to access the website of the TMS.

Which versions of TMS and VCS do you use? Some combinations forced the VCS to use https

which was often not enabled on the TMS.

As you use HTTP, a tcpdump on the VCS might be helpful.

You could login as root as ssh and execute:

tcdpump -vAnls0 -i eth0 host and port (161 or 80)

and save the external manager settings again and see what you see.

Please remember to rate helpful responses and identify


Attaching TCP Dumps for refrence. TMS is running 13.2 and vcs is running 7.2.


Looks like i am getting 405 method not allowed being returned.

Not sure what should i be looking at.

Magnus Ohm
Cisco Employee
Cisco Employee


What Martin say is totally valid but I just have some input on this that also is known to cause this when other options is not getting you anywhere.

A very common issue is that the Public folder in IIS is set to challenge requests with authentication. The public folder is supposed to have anonymous authentication enabled in IIS with a valid anonymous user.

An easy way to detect this is to open the URL that the VCS is trying to reach in a browser (Firefox) that is not currently authenticated to the TMS (else it will just use the authenticated session you already have open and give you a false negative).

If you get prompted for a password, then this is most likely the issue. Double check the public folder in IIS anyway. A wireshark will give the ultimate answer if you see the 401 response when its trying to reach the system management service.

Can your systems see phonebooks from TMS or do you get any CDR's? If not then this might also be an indication that the public folder is protected which it should not be.



That solved the issue for me.

However I didn't understood at first because when I was connecting with my accoung (which has admin permissions on the TMS) I was able to open the tms/public/external/management/systemmanagementservice.asmx URL.

I had to get a colleague to connect to the URL to figure out that this was the issue.


Magnus Ohm
Cisco Employee
Cisco Employee


Still an IIS problem. The POST method is probably not allowed? Do you have the webdav feature in your IIS?

An alternative if you dont know is to either open a tac case or uninstall iis completely along with tms and let tms setup iis for you during reinstallation. I assume you did not setup iis? Find the person who did and tell him to allow the methods required. Especially "Post".


Sent from Cisco Technical Support iPhone App

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: