cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
7463
Views
30
Helpful
17
Replies

Cube config sip trunk to Deutsche Telekom

ajber
Level 1
Level 1

Does anyone have a cube config with sip trunk to Deutsche Telekom?

I have a manual from https://www.cisco.com/c/dam/en/us/solutions/collateral/enterprise/interoperability-portal/connecting-unified-communication-manager.pdf but sip settings are different (document from 2017) 

 

1 Accepted Solution

Accepted Solutions

Hi Roger,

 

maybe you are right

 

Config is attached to this post.

 

This config is for the "Standard SIP Trunk" product of Deutsch Telekom.

If you need to configure a SIP Trunk for the product "CompanyFlex" of Deutsch Telekom, this is a different configuration.

 

One important thing to mention:

This configuration assumes, that the CUBE has a public IP address configured on the WAN-Interface.

 

If you have a private IP with NAT in front (e.g. on FW), then there will be a "No-way-audio"-issue for calls coming in from PSTN, which then will be forward (CFwdAll) back to PSTN.

PSTN --> CUBE --> CUCM --> CUBE --> PSTN

This is a "specific" behaviour of the SIP-plattform used by Deutsch Telekom (and other (german) providers).

 

Solution:

1: MTP on SIP Trunk in CUCM (easiest, but not a good solution)

2: add STUN config on CUBE

3: add "media anti-trombone" under "voice service voip" on CUBE

 

If anyone, who reeds this post, has questions about the config, just drop me a PM

 

Best regards,

Björn

View solution in original post

17 Replies 17

b.winter
VIP
VIP

Hi Ajber,

 

PM me, I have a complete configuration.

 

Best regards

Okay thanks, i have sent you an PM

@b.winter Why do you not post the configuration here for the greater good of the community? Recommend you to remove/edit any part(s) of it that would contain personalised/corporate information before posting it.



Response Signature


Hi Roger,

 

maybe you are right

 

Config is attached to this post.

 

This config is for the "Standard SIP Trunk" product of Deutsch Telekom.

If you need to configure a SIP Trunk for the product "CompanyFlex" of Deutsch Telekom, this is a different configuration.

 

One important thing to mention:

This configuration assumes, that the CUBE has a public IP address configured on the WAN-Interface.

 

If you have a private IP with NAT in front (e.g. on FW), then there will be a "No-way-audio"-issue for calls coming in from PSTN, which then will be forward (CFwdAll) back to PSTN.

PSTN --> CUBE --> CUCM --> CUBE --> PSTN

This is a "specific" behaviour of the SIP-plattform used by Deutsch Telekom (and other (german) providers).

 

Solution:

1: MTP on SIP Trunk in CUCM (easiest, but not a good solution)

2: add STUN config on CUBE

3: add "media anti-trombone" under "voice service voip" on CUBE

 

If anyone, who reeds this post, has questions about the config, just drop me a PM

 

Best regards,

Björn

Thank you! ':-)'



Response Signature


Would be awesome, to get my first solution

Well deserved! Let's hope @ajber markes it as solved.



Response Signature


ajber
Level 1
Level 1

Thank you very much. I now also understand there is a difference in legacy sip-trunk product and new companyflex product. Both have different configuration settings. Appreciated your help!

reindl_mc
Level 1
Level 1

Hi Björn,

 

can you also share your config for "CompanyFlex" SIP Trunk ?

 

Greetings from Austria, Bernhard

Hi Bernhard,

 

sorry, was on holiday.

Config is attached.

 

Please keep also my mentions for the other config in mind.

 

Greetings back to my old company

Hi Björn

 

great document, thank you very much.

 

kind regards

Bernhard

Hello Bjoern,

This Company Flex config seems to be outdated when not using a dedicated Telekom access, as TLS seems to be mandatory now, which is badly documented.

Would you have a working configuration with description as you've posted it for the other telekon variants?

Thanks a lot,

Jacky

Hi Jacky,

yes that's true. If the internet connection is not from Telekom, TLS/sRTP is mandatory.

"outdated" is good, I have never seen a secure config in all the info I've gotten ':D'

CA-Cert from Telekom can be downloaded here, it's the "T-TeleSec GlobalRoot Class 2"
https://www.telesec.de/de/root-programm/informationen-zu-ca-zertifikaten/root-zertifikate/

Attached is a text file with the config changes to be made.

Hi Bjoern,

Thank you for your reply, but I could make a working config just in time for my project, but will compare to your config.

I mean "outdated" because the technical document for CompanyFlex provided by Telekom schould not be an earlier Version than 04/22, because both options, secure/unsecure were possible in the past.

I've seen that you've described a common issue, the lack of RTP/audio transmission and call interruption by PSTN > CUCM/Phone> PSTN (mobile) CFWD, with clip no screening enabled, of course.

What's your own recommended and most consistent method to resolve this ever returning issue ?  A STUN config as best method?

Cheers,

Jacky