Showing results for 
Search instead for 
Did you mean: 

UCCE 8.5(2) web setup tool issue - HTTP Error 404.0 - Not Found


I have installed UCCE 8.0(1a) along with 8.5(2) MR twice in a row. I dont receive any errors during my installation, the second time around I had all my prerequisites including OS patches, Visual Studio, SQL 2005 SP4 patching and everything written down from the first go around and was able to complete the install with zero errors.

But once I complete the install and click on the Web Setup Tool I get a

UCCE error.jpg

I am not sure what I am doing wrong, Apache is running, this is for my lab system and we just got our Production system installed a few months and I compared all my version with the Production system at work and they all look the same, only difference is that this is going to be a sprawler. But I havent even gotten to that part yet.

I have attached images of the specs my Lab Server , any help is greatly appreciated, I am stumped at this point ..

Hardware Specs and OS

Lab - Specs.jpg

Installed Programs

Lab - Installed Programs.jpg







Gajanan Pande

looks like some issue with the IIS setup on the box. Try to browse the same site from IIS Admin, if it doesnt work there, I believe you might need to disable/enable IIS component from Windows Server. This might affect your Web tool setup install too ( might need a rebuild, being a lab system, one can afford rebuilt )

Check out the event logs for IIS related errors/warnings, to conclude it being IIS setup issue.

Lemme know how it goes.


Gajanan Pande

As indicated in the first screenshot, some file on the given path is either renamed or removed. Checkout if that's the case, then it becomes easier to fix.


I checked all of that , only to find out today that the ICM Web Setup does not even use IIS .. it uses Apache tomcat that is installed in there ...

This is crazy ... I did the install on the prod system and I am doing it the same way in my lab ...there are a lot of difference

1) At work I did not setup the domain

2) at Work I did not setup SQL or install the OS on the servers and patch it

I have tried to Mimic all of those settings including making sure the verisions or ASP, IIS, Visual Studio 2005 and every other minute setting such as changing the 32 bit flag for IIS to be the same as the Prod system ....

The only good thing going right now is that I can do the install in the middle of my sleep ;-)

has anyone else seen this error ? I am tempted to call TAC

Finally -  Got it fixed, I had missed a little fine print in Cisco's Documentation. Do Not Install IIS on any of your ICM Server !

I dont know how our Prod system works, But I can tell you that ICM Web Setup does not work if you install IIS on your Windows 2008 R2 SP1 server.

And Cisco does have tiny little note that tells you not to install IIS, it does not tell you that your Web Setup wont work. But now I know. SQL Install was complaining about IIS, I just ignored it and went ahead with any IIS and what do you, Web Setup works now !!! to me too . Would you mind sharing that Cisco document with tiny note about IIS ? I couldnt locate the guideline in installation/pre-install planning guides, BoM guide etc.

Thanks for posting the findings, anyways. +5 to you.



What did you do to fix? Modify IIS? I have same problem, but i installed 8.0.1a and up-grade for 8.5.3.
I can´t open web setup, http error 404 host not found.

I tried to access localhost, ip address, hostname, but nothing works.

Folks, apologize for not following up on the responses, works gotten busy again. Anyways .. the requirement is described in the "Staging Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted Release 8.x(y)" on Page 104.

It states " Do not install Internet Information Services unless the server will host WebView or UnifiedICM multichannel options."

One thing to note is that in Version 8.5 - Web View is no longer supported, which means - Do NOT Install IIS on your AW's HDS, DDS, Router or Logger or Rogger Servers since these use the Web Setup tool for installation and configuration.

I would say dont install IIS on any of your ICM servers period !

After some poking around and research I found out that Web Setup uses Apache Tomcat and the Web Setup does not like it when you have IIS running or installed on the same box.

I fixed mine in my lab with Fresh install of the OS (from scratch). For those who cannot afford a fresh install and have this issue on a Production Box, Uninstalling IIS does not seem to fix the problem. Prior to my Fresh Install I tried Uninstalling it and it did not work.

While I have not tried this trick out, I found out that having IIS and Apache creates some sort of conflict for port 80/ 443 on the server which results in these 40X errors that you see. Unfortunately Uninstalling IIS didnt seem to fix it in case. What I did find out is that there is some way of resolving the conflict and one way is to change the default port used by IIS (changing it from 80/443 to something else).

I have not tried this out, But I have heard that this might work. Also to note - based on my uninstall of IIS which did not fix the problem, changes are that Apache Tomcat may need some tweaking as well.

My guess is the default port used by IIS and Apache need to be worked on to resolve this issue on a production box. IF you can scarp the box and rebuild, then just dont install IIS and you should be fine.

One correction, I actually do know that resolving the port conflict does infact work, I have a box at work that one of the consutants used Cisco TAC to screw around and get Web Setup to work alongside IIS running, so there is something that can be changed on IIS and or Apache to make it work and its got something to do with the port allocation for these 2 web services.

Rising star


Can you check this also

1.)    Open Internet Information Service Manager.

2.)    Navigate Sites->Default Web Site.

3.)    Click on ISAPI filters. Check the number of filters configured. 

There should be only one filter -> tomcat. Make sure the filter is pointing to the executable isapi_redirector2.dll from directory :\icm\tomcat\bin\i386.  If there are no filters, please create one with name tomcat and select the executable isapi_redirector2 from location :\icm\tomcat\bin\i386. 

4.)    Restart Apache , IIS and WWW services.




Same issue 404. Creating above filter worked.

Thanks Shalu


Thanks Anthony :-)



Recognize Your Peers
Content for Community-Ad