Showing results for 
Search instead for 
Did you mean: 

UCS C22 M3 Cisco VIC 1225 no link


I have a C22 M3 with Vmware 5.5 running and a Cisco VIC 1225 card installed.  I have recently updated all the firmware to 2.0.3i on the box through CIMC.  I can see the Cisco VIC card installed and i have configured each port as a standard switch.


i have installed SFP-10G-SR fiber module in one of the ports.

Product name: UCS VIC 1225

Product ID: USCS-PCIE-CSC-02

Current Firmware: 4.0(1e)


I have my switch 4510R+E configured as the following:


interface TenGigabitEthernet2/1/1

description Cisco VM Fiber NIC

 switchport trunk native vlan 20

 switchport trunk allowed vlan 20

 switchport mode trunk

 spanning-tree portfast



is there any other configuration that i am missing on why i am not able to get a link between the server and switch?

1 Accepted Solution

Accepted Solutions

Cool, I hope you also tried another port in the switch to be sure.

If the card was bad, please mark this thread as answered so that you can show future users you got this figured out; I hope I was of help somehow.



View solution in original post

10 Replies 10




A direct connection to FI is required to manage a VIC card, see below:

The VIC 1225 is a PCIe card that can help you integrate your server directly to a Fabric Interconnect without the need of a FEX in between but you can also use that card if your server is in standalone mode.


Let me know if you have doubts.



Keny Perez

clear the counters for the interface on the switch and then post the output of show interface ten2/1/1 so that we can see if packets  are going through.

Are you tagging your traffic with vlan 20 on the vSwitch? if yes, that might be your issue cause you are telling your switch to expect that traffic untagged and keep it as such.



BM-CoreVSS-1#sh int te 2/1/1
TenGigabitEthernet2/1/1 is down, line protocol is down (notconnect)
  Hardware is Ten Gigabit Ethernet Port, address is e4d3.f153.dea2 (bia e4d3.f153.dea2)
  Description: Cisco VM Fiber NIC
  MTU 1500 bytes, BW 10000000 Kbit/sec, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 10Gb/s, link type is auto, media type is 10GBase-SR
  input flow-control is off, output flow-control is off
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 00:00:23
  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

This is what the current configuration on the CIMC and Vmware looks like.


The switch configuration is above.  I am going directly from the cisco VIC interface card and plugging directly into our Cisco 4510R+E switch.

If your interface is down/down your Layer 1 is having issues.... be sure you have known good cable and SFP, if you are using a twinax cable, replace it with another one and check the interface again... at this point there are no packets going through.


Let me know, but if the issue is solve with my suggestion, please mark it as "answered" so future users see you found the solution  for your question.


Currently Cisco TAC is sending me another Cisco VIC card to replace this one.

The fiber modules are from working systems and i have swapped out the fiber jumper with another one.

Will see if the card is defective.

Cool, I hope you also tried another port in the switch to be sure.

If the card was bad, please mark this thread as answered so that you can show future users you got this figured out; I hope I was of help somehow.




Card was defective, replacement card installed both ports came right up and traffic is flowing just fine.

Thanks for your troubleshooting tips, they did come in handy for future troubleshooting.

great, I am glad I helped :)



Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: