Showing results for 
Search instead for 
Did you mean: 

Continuing DCHP issues with WAP321

Level 1
Level 1

I am having problems with 5 Cisco WAP321 devices all failing to give clients DCHP addresses throughout the day.  The wireless device is able to connect to the Access Point but is never given an IP.  If I reboot a given Access Point then the same wireless device can connect and recieve a valid DHCP address.  Once a wireless device gets a good IP it can move between AP's without issue (even if the other AP's are not passing DHCP to other devices).  I am having this issue at least once a day  on each AP.  Some days I need to reboot an AP 3-4 times a day.

I have a small network with DHCP running on a commercial router.  Everything is on the same subnet with no VLANs.  I actually have 6 wireless access points setup.  All 5 WAP321 are having this issue, while 1 low quality netgear device is working fine.  DHCP works fine with all wired connections as well.  All of the WAP321 are wired into 1 of several network switches.  The DHCP range is 100 IP's and normally shows no more than 40 reservations (with 24 hour leases).

I have tried the following:

-factory reset 1 of the WAP321 and reconfigured - no change

-Installed different firmware versions on AP's to see if one resolved the issue

          1 AP has

          1 AP has

          1 AP has

          2 AP's have (This was just done today and I do not know if they will perform any differently than the others)

-I have tested with a DHCP server running on Windows 2003 - no change, moved DHCP back to router

-I have factory reset my router and reconfigured it with as basic settings as I can

-Added the netgear AP mentioned above to see how it behaved - it has been fine

The issue has been the same on:

Windows laptops

Mac laptops

Android Mobile devices

Apple Mobile devices

At this point the firmware is my last gasp at figuring this out myself.  If I cannot resolve this soon I will have to replace these units with something else that will likely not be a cisco AP.  I really do not want to do that.

9 Replies 9

Level 7
Level 7

Good morning

Hi Kim, thanks for using our forum, my name is Johnnatan and I am part of the Small business Support community. I have a couple of questions for you

How many devices are DHCP server? Did you try with al l the devices using the latest firmware version?

You can see this document, here you can see some tips

I hope you find this answer useful

*Please mark the question as Answered or rate it so other users can benefit from it*


Johnnatan Rodriguez Miranda.

Cisco Network Support Engineer.

“Please rate useful posts so other users can benefit from it” Greetings, Johnnatan Rodriguez Miranda. Cisco Network Support Engineer.


To answer your questions:

1.) There is only 1 DHCP server on the network.  It has a 100 IP range and averages 40 leases at a time.  I have tried to troubleshoot the DCHP by moving it to serveral different locations but at each time I have only had it running in one place at a time.  It is now back on the main router.

2.) all of the AP's are now updated to the firmware.  At first I thought that this helped but I have found out that the users have started to manually power cycle the AP's on their own.  So they are still having the issue on each of the AP's multiple times a day.

I looked over the support document that you list in your last post and I want to point out that the client devices are connecting to the wireless network each time.  However once they connect they fail to get a DHCP address.  If I statically set the IP on the client device then they begin to work normally.  So it does not appear to be a channel or WDS bridge issue.

So I am still at the point where 5 WAP321 units allow clients to connect to the wireless network but fail to pass along any DHCP addresses (from the DHCP server).  1 non-cisco AP has been working fine without any issue throughout this.  Also wired connections for devices get DHCP addresses without issue.

Still having issues with multiple WAP321 devices.  I now have 1 device that has managed to work correctly for 14 days but the other 4 access points are still failing to pass DHCP information through to any client device without regular reboots.  All of the devices have firmware installed and have the same network and radio settings other than channel and IP.  I can see no difference between the 1 working WAP321 and the other 4 setups.

Hi Kim, 

Have you tried to grab a packet capture from the WAP321 while the client is requesting DHCP?  I would be interested to see if the OFFER is being sent from the DHCP server and hitting the WAP and how the client is responding.  You can also monitor the traffic using Wireshark at the client as well to verify that the OFFER is being forwarded.  I have included the link to the administration guide for the WAP below.  The packet capture information is located on page 49.  Be sure to save this information in the event you open a case with Cisco Small Business.


Jason Nickle

Good morning

I also have this issue our layer 3 switch is relaying DHCP addresses from our windows 2008 dhcp server. some clients are working fine but others are unable to get address leases even though there are spare addresses in the pool.

hi what was the result for this as i am having the same issue with 5 new wap321 i have used them before with no issues 2 years ago but the new ones are not passing addressing.


i have upgraded the firmware to latest 1.0.6 from the cisco site

My name Eric Moyers. I am an Engineer in the Small Business Support Center.

I am sorry to hear that you are experiencing this issue. In order to troubleshoot this quickly and efficiently, there is more information that is needed.How is the network setup?

Can you get into the Access Point via hardwire? If you set a static on your wireless client can you get to the internet? Are you using VLANs on the network? Can we get a configuration file from one of the Access Points?  

If you need this resolved quickly it may be best to call our support center and open a case so that one of our engineers can work directly with you.

Eric Moyers
.:|:.:|:. CISCO | Cisco Presales Technical Support | Wireless Subject Matter Expert

Please rate helpful Posts and Let others know when your Question has been answered.


I also have some new WAP321 running firmware and my clients are getting no IP address from the DHCP. The AP gets an IP address. I am using VLANS on the network. How to I fix the issue?

Hi, I have what sounds like a very similar issue on a brand new WAP121.


I have a single router which acts as the DHCP server and a WAP121 as my WAP. I want the client devices (there are about 5 of them) to get their IP from the DHCP router, but most of them can't connect and fail to get an IP address.


If I give the devices a fixed IP address then it works fine. However this is not a good workaround as the laptops are taken home and then cannot connect to their home wifi networks.