Showing results for 
Search instead for 
Did you mean: 

Getting DHCP on a VMWare Virtual Machine via wireless

I have a WLC 2006 running 4.2.130 code with AP1020s.

I also have several users that have VMware machines that run various flavors of Linux, etc Virtual Machines on Windows XP Pro.

The Windows XP works fine on the wireless. It is the VMWare Virtual Machine running the “Bridged” ethernet connection that have problems.

The problem is that the Virtual Machine doesn't get a DHCP IP address from the wireless network.

If the user plugs into the wired network all works fine.

I have done some captures that show the DHCP requests going out with the MAC address of the wireless client, but no DHCP replies.

It looks like the WLC is seeing the additional DHCP requests from the MAC address of the wireless adapter and dropping them.

The same DHCP server (different scopes) are used for both wireless and wired clients.

The DHCP server shows NO activity when the Virtual Machine tries to get a DHCP IP address.

The DHCP server is a Cat 6500 running IOS v12.2(33)SXH. DHCP activity was monitored using debug IP dhcp server events/debug IP dhcp server packets.

The VMWare Workstation tried is 6.02-6.04.

Any ideas on this?

Scott Fella
Hall of Fame Master

Both passive client and config network ip-mac-binding disable can help... also depends on the version you are using.  I run Parallel's and doesn't work for me.  Lets say its hit or miss... sometimes my VM can bridge traffic by then my host fails or vice versa.



*****Help out other by using the rating system and marking answered questions as "Answered"*****

*** Please rate helpful posts ***

I too had same problem.Running..

WLC 8.0.100

VM 6.0.4

I too had issue of sometime my VM get bridged then my base machine and vice-versa.

After running "config network ip-mac-binding disable" and "config wlan passive-client disable"
i get through connectivity with both (VM+base machine)

But still my VM can't get IP from DHCP. (On static its working)

Any resolution did we get on this ?


I'm running, with VMFusion Professional Version 7.1.3.  I'm running my APs in local mode and Passive Client worked for me.

The secret to succeeding at technology is to say yes you can, and to not be afraid of change. Forget the words, "That's how we always do it"
Scott Fella
Hall of Fame Master

Hyper-V also works with passive client enabled.  Running 8.0 and 8.2


*** Please rate helpful posts ***
Content for Community-Ad