Showing results for 
Search instead for 
Did you mean: 

PoE switch provides power maximum, but AP only gets medium power.



I'm not sure I need to get TAC support for this or get some advice from here, professionals.

Please look at my issue, and provide your precious comments for me.

   - Switch : C9200L-48P-4G-E (PoE switch)
   - AP: Aironet 2802E-K9 (WLC: 8.3.140)

My switch provides full power to AP, but AP gets only medium power when I checked from Wireless Controller.


So I thought maybe cable is faulty, so I tried cable test with tdr, and got this result:


When I tried other interface port, I got same cable test result.

Why is this happening? My switch has an error?


Thank you for your comments.


12 Replies 12

Kasun Bandara
VIP Advisor VIP Advisor
VIP Advisor

how long you waited to get output of TDR after initiating it? in power inline command, it should display AP model under device column, and class. seems like PoE class negotiation not happened correctly when you using commands. (normally it takes minute or two to do negotiate and agree power classes). 

Please rate this and mark as solution/answer, if this resolved your issue
Good luck


Whenever I plug 2802E AP series to Cisco switch, the logs are full of:

Oct 13 09:15:24.567 CST: %CDP-4-DUPLEX_MISMATCH: duplex mismatch discovered on GigabitEthernet1/0/21 (not half duplex), with AP_13 GigabitEthernet0 (half duplex).

This issue always happens until I disable CDP (and do 'lldp run'). Do you think disabling CDP can cause an issue?

Thank you.

MHM Cisco World
VIP Mentor VIP Mentor
VIP Mentor
C9000#show power inline gigabitEthernet 1/0/21 detail 

 please share output here 


Here is the command result:

MCA-Sec-C1#sh power inline gi1/0/21 det

Interface: Gi1/0/21

Inline Power Mode: static

Operational status: off

Device Detected: no

Device Type: n/a

IEEE Class: n/a

Discovery mechanism used/configured: Ieee and Cisco

Police: off

Power Allocated

Admin Value: 30.0

Power drawn from the source: 30.0

Power available to the device: 30.0

Actual consumption

Measured at the port: 0.0

Maximum Power drawn by the device since powered on: 0.0

Absent Counter: 0

Over Current Counter: 0

Short Current Counter: 0

Invalid Signature Counter: 0

Power Denied Counter: 0

Power Negotiation Used: IEEE 802.3at LLDP

LLDP Power Negotiation --Sent to PD-- --Rcvd from PD--

Power Type: Type 2 PSE Type 2 PD

Power Source: Primary PSE

Power Priority: high high

Requested Power(W): 25.5 22.0

Allocated Power(W): 25.5 0.0

Four-Pair PoE Supported: No

Spare Pair Power Enabled: No

Four-Pair PD Architecture: N/A

LLDP power couldn't receive from PD, do you think that's the reason?

Inline Power Mode: static <<- why you config static power inline ??

if you decide to make mode AUTO try in one port if success then apply to all other port.
good luck friend.

Arshad Safrulla
VIP Advocate VIP Advocate
VIP Advocate

I wouldn't depend much on switch tdr to test the cable, get a proper cable testing tool like Fluke.

I would start by just bouncing the port and enable terminal monitor from switch side to make sure that the POE negotiation is happening correclty. It would be really great if you can console to the AP same time as well. I would also check the POE budget on the switch as to what's used and remaining to make sure that it's not oversubscribed. Make sure that you have CDP or LLDP enabled on the AP connecting ports.

From AP side I would start by disabling the USB port in the AP, however I am not sure that the code you are running supports it.

Choose Wireless > Access Points > All APs > access point name > Advanced tab to open the Advanced page.

If the WLC is under valid support contract, I would open a TAC case to check whether the WLC having a bug. It could be a cosmetic error from WLC side where it is displaying incorrect info.

However 8.3 code is EOL and no longer under support. It is highly recommended that you follow TAC recommendations when it comes to the code. Upgrade only after confirming that AP compatibility with new code. If you have other integrations check the compatibilty for that as well (ISE, PI etc)

Recommended AireOS Wireless LAN Controller Releases - Cisco

Leo Laohoo
VIP Community Legend VIP Community Legend
VIP Community Legend

@eeebbunee wrote:
%CDP-4-DUPLEX_MISMATCH: duplex mismatch discovered on GigabitEthernet1/0/21 (not half duplex), with AP_13 GigabitEthernet0 (half duplex).

That is a very well-known issue with early firmware for APs on Cheetah OS (non-classic IOS). 

The fix is to upgrade the firmware of the controller.

Rich R
VIP Advisor VIP Advisor
VIP Advisor

Regarding switch TDR results: You haven't mentioned what IOS you're using but you should make sure it's up to date.

We've got a TAC case open for similar issue with (amongst other things) completely random TDR test results on 9300 which has been running for months now.  BU and TAC are still struggling with it.  Short answer - like @Leo Laohoo  said you must not rely on the switch port TDR test.  Sometimes it works, sometimes it doesn't, even with the same device and cable connected.  And the results can look different every time you run it.

TAC recommended codes for AireOS WLC's
Best Practices for AireOS WLC's
TAC recommended codes for 9800 WLC's
Best Practices for 9800 WLC's
Cisco Wireless compatibility matrix
Field Notice: FN-72424 Later Versions of WiFi 6 APs Fail to Join WLC - Software Upgrade Recommended
WARNING - see CSCwd37092 Throughput degraded after upgrading to code - 2800/3800/4800 series
- The fix for CSCwd37092 is now released in and
- For IOS-XE 17.3.6 select controller model, go to IOS XE Software AP Service Pack, select CSCwd40096 17.3.6 APSP2
Field Notice: FN-63942 Lightweight APs and WLCs Fail to Create CAPWAP Connections Due to Certificate
      Expiration - Software Upgrade Recommended
Field Notice: FN-72524 - During Software Upgrade/Downgrade IOS APs Might Remain in Downloading State
     After 4 Dec 2022 Due to Certificate Expiration - Fixed in and 17.3.6 APSP5 (APSP_CSCwd83653)
     Also fixed in (8.5 mainline) and (8.5 IRCM) if you can't upgrade to 8.10
     TAC confirmed that subordinate Mobility Express APs downloading by TFTP are not affected so ME still works
     Note that and have been deferred (withdrawn) and are effectively unsupported by Cisco
Leo Laohoo's list of bugs affecting 2800/3800/4800/1560 APs
Richard R

It is disappointing that unreliable tdr test result.. 

Thank you very much for your comment!

friend when you config mode static this meaning the SW will supply full power to PoE device whatever it class 
so you need to change to auto. 

""Use "power inline static” interface level configuration to give the maximum power to the PD irrespective of its class, PD architecture and the negotiation protocol in use. Use this step when maximum power needed by PD is not known.""


I changed to providing auto back. I need to consider WLC upgrade.

Thank you for your comment! 

Leo Laohoo
VIP Community Legend VIP Community Legend
VIP Community Legend

TDR on IOS-XE on 16.X.X and 17.X.X is unreliable due to on-going bugs.  The processes would crash and take everything with it.  TDR output might look "ok" but it is not.  

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers