cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
445
Views
2
Helpful
3
Replies

Problem while configuring whireless bridge cisco 1602i

kap1
Level 1
Level 1

Hi everyone,

I have problem while trying to make wireless bridge configuration containing 2 cisco aironet 1602i access points. I was able to make the root device work but I have problem with repeater. Root is conected to my home router and is broadcasting ssid with internet access. While trying to configure repeater and set parent i get error:  Interface Dot11Radio0, cannot associate: Not specified parent (from SOME_MAC_ADDRESS). Also I don't know if it's important, but while specyfying station-role i get notification: Disabling 802.11n aggregation in WGB/Repeater/NRB mode. Root device is connected to my router and repeater is not as I want to create wireless bridge configuration between these access points. Can someone explain why it doesn't work ? Scripts I used to configure devices are listed below. 

========ROOT===========
configure terminal
interface dot11Radio 0
station-role root
exit
dot11 ssid NAME_OF_SSID
guest-mode
authentication open
authentication key-management wpa version 2
wpa-psk ascii Cisco123
exit
interface dot11Radio 0
encryption mode ciphers aes-ccm
ssid NAME_OF_SSID
channel least-congested
no shutdown
exit


==========REPEATER============
configure terminal
dot11 ssid NAME_OF_SSID
authentication open
authentication key-management wpa version 2
guest-mode
infrastructure-ssid
wpa-psk ascii Cisco123
exit
interface dot11Radio 0
encryption mode ciphers aes-ccm
ssid NAME_OF_SSID
antenna gain 0
parent 1 MAC_OF_ROOT
dot11 extension aironet
bridge-group 1
no shutdown
exit
interface bvi1
ip address 192.168.0.19 255.255.255.0
no shutdown
exit



1 Accepted Solution

Accepted Solutions

balaji.bandi
Hall of Fame
Hall of Fame

Hope Both AP running same Code - can you check on the root AP config of BVI

check below example : run some debug and post the logs here :

https://mrncciew.com/2013/01/20/autonomous-ap-repeater/

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

View solution in original post

3 Replies 3

balaji.bandi
Hall of Fame
Hall of Fame

Hope Both AP running same Code - can you check on the root AP config of BVI

check below example : run some debug and post the logs here :

https://mrncciew.com/2013/01/20/autonomous-ap-repeater/

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Hello,
Sorry for late response,
Here is bvi run config and bvi config for root device:
------SHOW RUN-------:
Current configuration : 1842 bytes
!
! Last configuration change at 00:06:13 UTC Mon Mar 1 1993
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ap
!
!
logging rate-limit console 9
enable secret xxx
!
no aaa new-model
no ip routing
no ip cef
!
!
!
!
dot11 syslog
!
dot11 ssid test_wlan
authentication open
authentication key-management wpa version 2
guest-mode
wpa-psk ascii xxx
!
!
dot11 guest
!
!
!
username Cisco password xxx
!
!
bridge irb
!
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
encryption mode ciphers aes-ccm
!
ssid test_wlan
!
antenna gain 0
stbc
beamform ofdm
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio1
no ip address
no ip route-cache
shutdown
antenna gain 0
peakdetect
no dfs band block
channel dfs
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface GigabitEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
bridge-group 1
bridge-group 1 spanning-disabled
no bridge-group 1 source-learning
!
interface BVI1
ip address dhcp client-id GigabitEthernet0
no ip route-cache
ipv6 address dhcp
ipv6 address autoconfig
ipv6 enable
!
ip forward-protocol nd
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
!
!
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
login local
transport input all
!
end
------------------------------
---SHOW INTERFACES BVI1---
BVI1 is up, line protocol is up
Hardware is BVI, address is 18e7.2811.5355 (bia 18e7.2811.5355)
Internet address is 192.168.0.21/24
MTU 1500 bytes, BW 54000 Kbit/sec, DLY 5000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:22, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/0 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
21 packets input, 2496 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
22 packets output, 2556 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out
Will try to configure repeater from the site in a minute will update after I am done



It worked I don't know what was the real reason why my first configuration didn't work but with that guide everything worked perfectly. Thank you so much for help I will paste both scripts for devices maybe someone will use it in the future:

========ROOT===========
configure terminal
interface dot11Radio 0
station-role root
exit
dot11 ssid NAME_OF_SSID
guest-mode
authentication open
authentication key-management wpa version 2
wpa-psk ascii Cisco123
exit
interface dot11Radio 0
encryption mode ciphers aes-ccm
ssid NAME_OF_SSID
channel least-congested
no shutdown
exit


==========REPEATER============

configure terminal
interface dot11Radio 0
encryption mode ciphers aes-ccm
ssid test_wlan
exit
station-role repeater
exit
dot11 ssid test_wlan
guest-mode
infrastructure-ssid
authentication open
authentication key-management wpa version 2
wpa-psk ascii Cisco123
exit
interface bvI 1
ip address 192.168.0.19 255.255.255.0
no shutdown
exit
ip default-gateway 192.168.0.1
interface dot11Radio 0
no shutdown
exit
Now everything works fine, I can connect to both devices using ip addres in browser, in wi fi analyzer I see 2 same ssid and both root and repeater can ping each other and also default gateway of my home router. PC can also ping both devices

Review Cisco Networking for a $25 gift card