cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
924
Views
5
Helpful
3
Replies

ASR9K Layer2

Hamza_MX
Level 1
Level 1

Hello ,

 

I want to pass Layer 2 connection acroos an ASR9K but it is not working .

 

Find below architecture and config :

----Layer2ASR9K.png                   ---------------csr---------------

interface GigabitEthernet1
no ip address
negotiation auto
!
interface GigabitEthernet1.10
encapsulation dot1Q 10
ip address 10.10.10.1 255.255.255.0
!
interface GigabitEthernet1.20
encapsulation dot1Q 20
ip address 10.10.20.1 255.255.255.0
!
interface GigabitEthernet2
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet3
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet4
no ip address
shutdown
negotiation auto
!
router bgp 65001
bgp log-neighbor-changes
neighbor 10.10.10.2 remote-as 65002
!
address-family ipv4
neighbor 10.10.10.2 activate
neighbor 10.10.10.2 soft-reconfiguration inbound
exit-address-family
!

-----------------xrv1--------------

interface GigabitEthernet0/0/0/0.10
ipv4 address 10.10.10.2 255.255.255.0
encapsulation dot1q 10
!
interface GigabitEthernet0/0/0/0.20 l2transport
encapsulation dot1q 20
rewrite ingress tag pop 1 symmetric
!
interface GigabitEthernet0/0/0/1.20 l2transport
encapsulation dot1q 20
rewrite ingress tag pop 1 symmetric
!
interface GigabitEthernet0/0/0/2
shutdown
!
router bgp 65002
bgp router-id 10.10.10.2
address-family ipv4 unicast
!
neighbor 10.10.10.1
remote-as 65001
address-family ipv4 unicast
soft-reconfiguration inbound always
!
!
!
l2vpn
bridge group BG20
bridge-domain 20
interface GigabitEthernet0/0/0/0.20
!
interface GigabitEthernet0/0/0/1.20
!

 

 

----xrv2--------

!
interface GigabitEthernet0/0/0/0.20
ipv4 address 10.10.20.2 255.255.255.0
encapsulation dot1q 20
!

 

 

 

ping between 10.10.20.2 and 0.10.20.1 dont work

 

1 Accepted Solution

Accepted Solutions

Hamza_MX
Level 1
Level 1

Hello ,

 

It worked with the configuration below :

 

l2vpn
xconnect group FO
p2p FO1
interface GigabitEthernet0/0/0/0.20
interface GigabitEthernet0/0/0/1.20
!

View solution in original post

3 Replies 3

show l2vpn bridge-domain group NAME bd-name NAME


please share the output for above command.

 

Did you create the respective vlan on each device?

csr - vlan 10 and 20

xrv1 - vlan 10

xrv2 - vlan 20

 

If yes, can you check the spanning tree?

 

 

Hamza_MX
Level 1
Level 1

Hello ,

 

It worked with the configuration below :

 

l2vpn
xconnect group FO
p2p FO1
interface GigabitEthernet0/0/0/0.20
interface GigabitEthernet0/0/0/1.20
!